compiler/Make.spec
changeset 7 cccc239c8833
parent 5 77d56b3a771b
child 8 c2de4aaa2670
equal deleted inserted replaced
6:06efdfe62106 7:cccc239c8833
     1 # $Header$
     1 # $Header$
     2 #
     2 #
     3 # DO NOT EDIT
     3 # DO NOT EDIT
     4 # automagically generated from the projectDefinition: jv_dart_compiler.
     4 # automagically generated from the projectDefinition: ctu_dart_compiler.
     5 #
     5 #
     6 # Warning: once you modify this file, do not rerun
     6 # Warning: once you modify this file, do not rerun
     7 # stmkmp or projectDefinition-build again - otherwise, your changes are lost.
     7 # stmkmp or projectDefinition-build again - otherwise, your changes are lost.
     8 #
     8 #
     9 # This file contains specifications which are common to all platforms.
     9 # This file contains specifications which are common to all platforms.
    10 #
    10 #
    11 
    11 
    12 # Do NOT CHANGE THESE DEFINITIONS
    12 # Do NOT CHANGE THESE DEFINITIONS
    13 # (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
    13 # (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
    14 #  to find the source code of a class and to find the library for a package)
    14 #  to find the source code of a class and to find the library for a package)
    15 MODULE=jv
    15 MODULE=ctu
    16 MODULE_DIR=dart/compiler
    16 MODULE_DIR=dart/compiler
    17 PACKAGE=$(MODULE):$(MODULE_DIR)
    17 PACKAGE=$(MODULE):$(MODULE_DIR)
    18 
    18 
    19 
    19 
    20 # Argument(s) to the stc compiler (stc --usage).
    20 # Argument(s) to the stc compiler (stc --usage).
    48 # STCWARNINGS=-warnNonStandard
    48 # STCWARNINGS=-warnNonStandard
    49 # STCWARNINGS=-warnEOLComments
    49 # STCWARNINGS=-warnEOLComments
    50 STCWARNINGS=-warnNonStandard
    50 STCWARNINGS=-warnNonStandard
    51 
    51 
    52 COMMON_CLASSES= \
    52 COMMON_CLASSES= \
    53 	jv_dart_compiler \
    53 	ctu_dart_compiler \
    54 	Dart::ScannerBase \
    54 	Dart::ScannerBase \
    55 	Dart::Parser \
    55 	Dart::Parser \
    56 	Dart::Scanner \
    56 	Dart::Scanner \
    57 	Dart::ScannerTests \
    57 	Dart::ScannerTests \
    58 	Dart::ParserError \
    58 	Dart::ParserError \
    61 
    61 
    62 
    62 
    63 
    63 
    64 
    64 
    65 COMMON_OBJS= \
    65 COMMON_OBJS= \
    66     $(OUTDIR)jv_dart_compiler.$(O) \
    66     $(OUTDIR)ctu_dart_compiler.$(O) \
    67     $(OUTDIR)Dart__ScannerBase.$(O) \
    67     $(OUTDIR)Dart__ScannerBase.$(O) \
    68     $(OUTDIR)Dart__Parser.$(O) \
    68     $(OUTDIR)Dart__Parser.$(O) \
    69     $(OUTDIR)Dart__Scanner.$(O) \
    69     $(OUTDIR)Dart__Scanner.$(O) \
    70     $(OUTDIR)Dart__ScannerTests.$(O) \
    70     $(OUTDIR)Dart__ScannerTests.$(O) \
    71     $(OUTDIR)Dart__ParserError.$(O) \
    71     $(OUTDIR)Dart__ParserError.$(O) \