Make.spec
author Jan Vrany <jan.vrany@fit.cvut.cz>
Mon, 29 Oct 2012 10:41:23 +0000
changeset 40 c99f058e2276
parent 39 d361eb9419e6
child 41 f3898a3b378d
permissions -rw-r--r--
- removed dependency on an obsolete libtool3

# $Header$
#
# DO NOT EDIT
# automagically generated from the projectDefinition: cvut_stx_goodies_newcompiler.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=cvut
MODULE_DIR=stx/goodies/newcompiler
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -headerDir=. : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optspace3


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard

COMMON_CLASSES= \
	IRBuilder \
	IRBytecodeGenerator \
	IRFunction \
	IRInstruction \
	IRInterpreter \
	IRSequence \
	IRStackCount \
	cvut_stx_goodies_newcompiler \
	IRAccess \
	IRClosure \
	IRConstant \
	IRDecompiler \
	IRDup \
	IRJump \
	IRLine \
	IRMethod \
	IRPop \
	IRPrinter \
	IRReturn \
	IRSend \
	IRTranslator \
	IRBlockReturnTop \
	IRInstVarAccess \
	IRJumpIf \
	IRJumpOverBlock \
	IRLiteralVariableAccess \
	IRTempAccess \
	IRInstVarRead \
	IRInstVarStore \
	IRLiteralVariableRead \
	IRLiteralVariableStore \
	IRTempRead \
	IRTempStore \




COMMON_OBJS= \
    $(OUTDIR)IRBuilder.$(O) \
    $(OUTDIR)IRBytecodeGenerator.$(O) \
    $(OUTDIR)IRFunction.$(O) \
    $(OUTDIR)IRInstruction.$(O) \
    $(OUTDIR)IRInterpreter.$(O) \
    $(OUTDIR)IRSequence.$(O) \
    $(OUTDIR)IRStackCount.$(O) \
    $(OUTDIR)cvut_stx_goodies_newcompiler.$(O) \
    $(OUTDIR)IRAccess.$(O) \
    $(OUTDIR)IRClosure.$(O) \
    $(OUTDIR)IRConstant.$(O) \
    $(OUTDIR)IRDecompiler.$(O) \
    $(OUTDIR)IRDup.$(O) \
    $(OUTDIR)IRJump.$(O) \
    $(OUTDIR)IRLine.$(O) \
    $(OUTDIR)IRMethod.$(O) \
    $(OUTDIR)IRPop.$(O) \
    $(OUTDIR)IRPrinter.$(O) \
    $(OUTDIR)IRReturn.$(O) \
    $(OUTDIR)IRSend.$(O) \
    $(OUTDIR)IRTranslator.$(O) \
    $(OUTDIR)IRBlockReturnTop.$(O) \
    $(OUTDIR)IRInstVarAccess.$(O) \
    $(OUTDIR)IRJumpIf.$(O) \
    $(OUTDIR)IRJumpOverBlock.$(O) \
    $(OUTDIR)IRLiteralVariableAccess.$(O) \
    $(OUTDIR)IRTempAccess.$(O) \
    $(OUTDIR)IRInstVarRead.$(O) \
    $(OUTDIR)IRInstVarStore.$(O) \
    $(OUTDIR)IRLiteralVariableRead.$(O) \
    $(OUTDIR)IRLiteralVariableStore.$(O) \
    $(OUTDIR)IRTempRead.$(O) \
    $(OUTDIR)IRTempStore.$(O) \
    $(OUTDIR)extensions.$(O) \