compiler/Make.spec
author Jan Vrany <jan.vrany@fit.cvut.cz>
Tue, 22 Sep 2015 17:43:38 +0100
changeset 14 fa42d3f1a578
parent 11 6d39860d0fdb
child 15 10a95d798b36
permissions -rw-r--r--
Removed syntax for inline assembly, use <primitive: [:asm | ... ]> syntax. This one is easier to implement and less introusive, syntax-wise. And follows Smalltalk tradiiton.

# $Header$
#
# DO NOT EDIT
# automagically generated from the projectDefinition: jv_tea_compiler.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=jv
MODULE_DIR=tea/compiler
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -headerDir=. : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optspace3


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#  -warnUnused      : no warnings about unused variables
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard

COMMON_CLASSES= \
	TBinding \
	TClassDefinition \
	TCompilationUnitDefinition \
	TCompiler \
	TCompilerContext \
	TCompilerError \
	TEnvironmentProvider \
	TFormatter \
	TMetaDefinition \
	TMethodDefinition \
	TNamespaceDefinition \
	TParser \
	TProgramNodeVisitor \
	TScope \
	TSourceReader \
	TSpecialFormNode \
	TType \
	TTypeNode \
	TTypeSpecNode \
	jv_tea_compiler \
	TBlockType \
	TClassBinding \
	TCompilerPass \
	TEnvironment \
	TFilesystemProvider \
	TFunctionBinding \
	TNamespaceBinding \
	TSimpleType \
	TSimpleTypeNode \
	TValueBinding \
	TBlockBinding \
	TConstantBinding \
	TLLVMCodeGenerator \
	TMethodBinding \
	TSemanticAnalyser \
	TTypechecker \
	TVariableBinding \
	TArgumentBinding \
	TLocalBinding \




COMMON_OBJS= \
    $(OUTDIR_SLASH)TBinding.$(O) \
    $(OUTDIR_SLASH)TClassDefinition.$(O) \
    $(OUTDIR_SLASH)TCompilationUnitDefinition.$(O) \
    $(OUTDIR_SLASH)TCompiler.$(O) \
    $(OUTDIR_SLASH)TCompilerContext.$(O) \
    $(OUTDIR_SLASH)TCompilerError.$(O) \
    $(OUTDIR_SLASH)TEnvironmentProvider.$(O) \
    $(OUTDIR_SLASH)TFormatter.$(O) \
    $(OUTDIR_SLASH)TMetaDefinition.$(O) \
    $(OUTDIR_SLASH)TMethodDefinition.$(O) \
    $(OUTDIR_SLASH)TNamespaceDefinition.$(O) \
    $(OUTDIR_SLASH)TParser.$(O) \
    $(OUTDIR_SLASH)TProgramNodeVisitor.$(O) \
    $(OUTDIR_SLASH)TScope.$(O) \
    $(OUTDIR_SLASH)TSourceReader.$(O) \
    $(OUTDIR_SLASH)TSpecialFormNode.$(O) \
    $(OUTDIR_SLASH)TType.$(O) \
    $(OUTDIR_SLASH)TTypeNode.$(O) \
    $(OUTDIR_SLASH)TTypeSpecNode.$(O) \
    $(OUTDIR_SLASH)jv_tea_compiler.$(O) \
    $(OUTDIR_SLASH)TBlockType.$(O) \
    $(OUTDIR_SLASH)TClassBinding.$(O) \
    $(OUTDIR_SLASH)TCompilerPass.$(O) \
    $(OUTDIR_SLASH)TEnvironment.$(O) \
    $(OUTDIR_SLASH)TFilesystemProvider.$(O) \
    $(OUTDIR_SLASH)TFunctionBinding.$(O) \
    $(OUTDIR_SLASH)TNamespaceBinding.$(O) \
    $(OUTDIR_SLASH)TSimpleType.$(O) \
    $(OUTDIR_SLASH)TSimpleTypeNode.$(O) \
    $(OUTDIR_SLASH)TValueBinding.$(O) \
    $(OUTDIR_SLASH)TBlockBinding.$(O) \
    $(OUTDIR_SLASH)TConstantBinding.$(O) \
    $(OUTDIR_SLASH)TLLVMCodeGenerator.$(O) \
    $(OUTDIR_SLASH)TMethodBinding.$(O) \
    $(OUTDIR_SLASH)TSemanticAnalyser.$(O) \
    $(OUTDIR_SLASH)TTypechecker.$(O) \
    $(OUTDIR_SLASH)TVariableBinding.$(O) \
    $(OUTDIR_SLASH)TArgumentBinding.$(O) \
    $(OUTDIR_SLASH)TLocalBinding.$(O) \
    $(OUTDIR_SLASH)extensions.$(O) \