parsers/smalltalk/tests/Make.spec
changeset 385 44a36ed4e484
child 421 7e08b31e0dae
equal deleted inserted replaced
384:a613ecf5d2a1 385:44a36ed4e484
       
     1 # $Header$
       
     2 #
       
     3 # DO NOT EDIT
       
     4 # automagically generated from the projectDefinition: stx_goodies_petitparser_parsers_smalltalk_tests.
       
     5 #
       
     6 # Warning: once you modify this file, do not rerun
       
     7 # stmkmp or projectDefinition-build again - otherwise, your changes are lost.
       
     8 #
       
     9 # This file contains specifications which are common to all platforms.
       
    10 #
       
    11 
       
    12 # Do NOT CHANGE THESE DEFINITIONS
       
    13 # (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
       
    14 #  to find the source code of a class and to find the library for a package)
       
    15 MODULE=stx
       
    16 MODULE_DIR=goodies/petitparser/parsers/smalltalk/tests
       
    17 PACKAGE=$(MODULE):$(MODULE_DIR)
       
    18 
       
    19 
       
    20 # Argument(s) to the stc compiler (stc --usage).
       
    21 #  -headerDir=. : create header files locally
       
    22 #                (if removed, they will be created as common
       
    23 #  -Pxxx       : defines the package
       
    24 #  -Zxxx       : a prefix for variables within the classLib
       
    25 #  -Dxxx       : defines passed to to CC for inline C-code
       
    26 #  -Ixxx       : include path passed to CC for inline C-code
       
    27 #  +optspace   : optimized for space
       
    28 #  +optspace2  : optimized more for space
       
    29 #  +optspace3  : optimized even more for space
       
    30 #  +optinline  : generate inline code for some ST constructs
       
    31 #  +inlineNew  : additionally inline new
       
    32 #  +inlineMath : additionally inline some floatPnt math stuff
       
    33 #
       
    34 # ********** OPTIONAL: MODIFY the next line(s) ***
       
    35 # STCLOCALOPTIMIZATIONS=+optinline +inlineNew
       
    36 # STCLOCALOPTIMIZATIONS=+optspace3
       
    37 STCLOCALOPTIMIZATIONS=+optspace3
       
    38 
       
    39 
       
    40 # Argument(s) to the stc compiler (stc --usage).
       
    41 #  -warn            : no warnings
       
    42 #  -warnNonStandard : no warnings about ST/X extensions
       
    43 #  -warnEOLComments : no warnings about EOL comment extension
       
    44 #  -warnPrivacy     : no warnings about privateClass extension
       
    45 #
       
    46 # ********** OPTIONAL: MODIFY the next line(s) ***
       
    47 # STCWARNINGS=-warn
       
    48 # STCWARNINGS=-warnNonStandard
       
    49 # STCWARNINGS=-warnEOLComments
       
    50 STCWARNINGS=-warnNonStandard
       
    51 
       
    52 COMMON_CLASSES= \
       
    53 	stx_goodies_petitparser_parsers_smalltalk_tests \
       
    54 
       
    55 
       
    56 
       
    57 
       
    58 COMMON_OBJS= \
       
    59     $(OUTDIR_SLASH)stx_goodies_petitparser_parsers_smalltalk_tests.$(O) \
       
    60 
       
    61 
       
    62