compiler/Make.spec
changeset 420 b2f2f15cef26
parent 413 5389e6fbb3bc
child 421 7e08b31e0dae
equal deleted inserted replaced
419:5c502ab8e87d 420:b2f2f15cef26
    40 # Argument(s) to the stc compiler (stc --usage).
    40 # Argument(s) to the stc compiler (stc --usage).
    41 #  -warn            : no warnings
    41 #  -warn            : no warnings
    42 #  -warnNonStandard : no warnings about ST/X extensions
    42 #  -warnNonStandard : no warnings about ST/X extensions
    43 #  -warnEOLComments : no warnings about EOL comment extension
    43 #  -warnEOLComments : no warnings about EOL comment extension
    44 #  -warnPrivacy     : no warnings about privateClass extension
    44 #  -warnPrivacy     : no warnings about privateClass extension
       
    45 #  -warnUnused      : no warnings about unused variables
    45 #
    46 #
    46 # ********** OPTIONAL: MODIFY the next line(s) ***
    47 # ********** OPTIONAL: MODIFY the next line(s) ***
    47 # STCWARNINGS=-warn
    48 # STCWARNINGS=-warn
    48 # STCWARNINGS=-warnNonStandard
    49 # STCWARNINGS=-warnNonStandard
    49 # STCWARNINGS=-warnEOLComments
    50 # STCWARNINGS=-warnEOLComments
    50 STCWARNINGS=-warnNonStandard
    51 STCWARNINGS=-warnNonStandard
    51 
    52 
    52 COMMON_CLASSES= \
    53 COMMON_CLASSES= \
    53 	PPCBenchmark \
       
    54 	PPCBenchmarkResources \
       
    55 	PPCBridge \
    54 	PPCBridge \
    56 	PPCCompiledMethod \
    55 	PPCCompiledMethod \
    57 	PPCCompiler \
    56 	PPCCompiler \
    58 	PPCContext \
    57 	PPCContext \
    59 	PPCContextMemento \
    58 	PPCContextMemento \
   117 
   116 
   118 
   117 
   119 
   118 
   120 
   119 
   121 COMMON_OBJS= \
   120 COMMON_OBJS= \
   122     $(OUTDIR_SLASH)PPCBenchmark.$(O) \
       
   123     $(OUTDIR_SLASH)PPCBenchmarkResources.$(O) \
       
   124     $(OUTDIR_SLASH)PPCBridge.$(O) \
   121     $(OUTDIR_SLASH)PPCBridge.$(O) \
   125     $(OUTDIR_SLASH)PPCCompiledMethod.$(O) \
   122     $(OUTDIR_SLASH)PPCCompiledMethod.$(O) \
   126     $(OUTDIR_SLASH)PPCCompiler.$(O) \
   123     $(OUTDIR_SLASH)PPCCompiler.$(O) \
   127     $(OUTDIR_SLASH)PPCContext.$(O) \
   124     $(OUTDIR_SLASH)PPCContext.$(O) \
   128     $(OUTDIR_SLASH)PPCContextMemento.$(O) \
   125     $(OUTDIR_SLASH)PPCContextMemento.$(O) \