Make.spec
changeset 0 739fe9b7253e
child 4 90de244a7fa2
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/Make.spec	Thu Aug 18 20:56:17 2011 +0200
@@ -0,0 +1,133 @@
+# $Header: /cvs/stx/stx/goodies/petitparser/Make.spec,v 1.1 2011-08-18 18:56:17 cg Exp $
+#
+# DO NOT EDIT 
+# automagically generated from the projectDefinition: squeak_petitparser.
+#
+# Warning: once you modify this file, do not rerun
+# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
+#
+# This file contains specifications which are common to all platforms.
+#
+
+# Do NOT CHANGE THESE DEFINITIONS
+# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
+#  to find the source code of a class and to find the library for a package)
+MODULE=squeak
+MODULE_DIR=petitparser
+PACKAGE=$(MODULE):$(MODULE_DIR)
+
+
+# Argument(s) to the stc compiler (stc --usage).
+#  -H.         : create header files locally
+#                (if removed, they will be created as common
+#  -Pxxx       : defines the package
+#  -Zxxx       : a prefix for variables within the classLib
+#  -Dxxx       : defines passed to to CC for inline C-code
+#  -Ixxx       : include path passed to CC for inline C-code
+#  +optspace   : optimized for space
+#  +optspace2  : optimized more for space
+#  +optspace3  : optimized even more for space
+#  +optinline  : generate inline code for some ST constructs
+#  +inlineNew  : additionally inline new
+#  +inlineMath : additionally inline some floatPnt math stuff
+#
+# ********** OPTIONAL: MODIFY the next line(s) ***
+# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
+# STCLOCALOPTIMIZATIONS=+optspace3
+STCLOCALOPTIMIZATIONS=+optspace3
+
+
+# Argument(s) to the stc compiler (stc --usage).
+#  -warn            : no warnings
+#  -warnNonStandard : no warnings about ST/X extensions
+#  -warnEOLComments : no warnings about EOL comment extension
+#  -warnPrivacy     : no warnings about privateClass extension
+#
+# ********** OPTIONAL: MODIFY the next line(s) ***
+# STCWARNINGS=-warn
+# STCWARNINGS=-warnNonStandard
+# STCWARNINGS=-warnEOLComments
+STCWARNINGS=-warnNonStandard
+
+COMMON_CLASSES= \
+	PPCharSetPredicate \
+	PPFailure \
+	PPMemento \
+	PPParser \
+	PPStream \
+	PPToken \
+	squeak_petitparser \
+	PPDelegateParser \
+	PPEpsilonParser \
+	PPFailingParser \
+	PPListParser \
+	PPLiteralParser \
+	PPPluggableParser \
+	PPPredicateParser \
+	PPUnresolvedParser \
+	PPActionParser \
+	PPAndParser \
+	PPChoiceParser \
+	PPCompositeParser \
+	PPEndOfInputParser \
+	PPExpressionParser \
+	PPFlattenParser \
+	PPLiteralObjectParser \
+	PPLiteralSequenceParser \
+	PPMemoizedParser \
+	PPNotParser \
+	PPOptionalParser \
+	PPPredicateObjectParser \
+	PPPredicateSequenceParser \
+	PPRepeatingParser \
+	PPSequenceParser \
+	PPTrimmingParser \
+	PPArithmeticParser \
+	PPLambdaParser \
+	PPTokenParser \
+	PPWrappingParser \
+
+
+
+
+COMMON_OBJS= \
+    $(OUTDIR)PPCharSetPredicate.$(O) \
+    $(OUTDIR)PPFailure.$(O) \
+    $(OUTDIR)PPMemento.$(O) \
+    $(OUTDIR)PPParser.$(O) \
+    $(OUTDIR)PPStream.$(O) \
+    $(OUTDIR)PPToken.$(O) \
+    $(OUTDIR)squeak_petitparser.$(O) \
+    $(OUTDIR)PPDelegateParser.$(O) \
+    $(OUTDIR)PPEpsilonParser.$(O) \
+    $(OUTDIR)PPFailingParser.$(O) \
+    $(OUTDIR)PPListParser.$(O) \
+    $(OUTDIR)PPLiteralParser.$(O) \
+    $(OUTDIR)PPPluggableParser.$(O) \
+    $(OUTDIR)PPPredicateParser.$(O) \
+    $(OUTDIR)PPUnresolvedParser.$(O) \
+    $(OUTDIR)PPActionParser.$(O) \
+    $(OUTDIR)PPAndParser.$(O) \
+    $(OUTDIR)PPChoiceParser.$(O) \
+    $(OUTDIR)PPCompositeParser.$(O) \
+    $(OUTDIR)PPEndOfInputParser.$(O) \
+    $(OUTDIR)PPExpressionParser.$(O) \
+    $(OUTDIR)PPFlattenParser.$(O) \
+    $(OUTDIR)PPLiteralObjectParser.$(O) \
+    $(OUTDIR)PPLiteralSequenceParser.$(O) \
+    $(OUTDIR)PPMemoizedParser.$(O) \
+    $(OUTDIR)PPNotParser.$(O) \
+    $(OUTDIR)PPOptionalParser.$(O) \
+    $(OUTDIR)PPPredicateObjectParser.$(O) \
+    $(OUTDIR)PPPredicateSequenceParser.$(O) \
+    $(OUTDIR)PPRepeatingParser.$(O) \
+    $(OUTDIR)PPSequenceParser.$(O) \
+    $(OUTDIR)PPTrimmingParser.$(O) \
+    $(OUTDIR)PPArithmeticParser.$(O) \
+    $(OUTDIR)PPLambdaParser.$(O) \
+    $(OUTDIR)PPTokenParser.$(O) \
+    $(OUTDIR)PPWrappingParser.$(O) \
+    $(OUTDIR)extensions.$(O) \
+
+
+