compiler/Make.spec
author Jan Vrany <jan.vrany@fit.cvut.cz>
Fri, 24 Jul 2015 15:06:54 +0100
changeset 502 1e45d3c96ec5
parent 464 f6d77fee9811
child 503 ff58cd9f1f3c
child 515 b5316ef15274
permissions -rw-r--r--
Updated to PetitCompiler-JanVrany.135, PetitCompiler-Tests-JanKurs.93, PetitCompiler-Extras-Tests-JanVrany.16, PetitCompiler-Benchmarks-JanKurs.12 Name: PetitCompiler-JanVrany.135 Author: JanVrany Time: 22-07-2015, 06:53:29.127 PM UUID: 890178b5-275d-46af-a2ad-1738998f07cb Ancestors: PetitCompiler-JanVrany.134 Name: PetitCompiler-Tests-JanKurs.93 Author: JanKurs Time: 20-07-2015, 11:30:10.283 PM UUID: 6473e671-ad70-42ca-b6c3-654b78edc531 Ancestors: PetitCompiler-Tests-JanKurs.92 Name: PetitCompiler-Extras-Tests-JanVrany.16 Author: JanVrany Time: 22-07-2015, 05:18:22.387 PM UUID: 8f6f9129-dbba-49b1-9402-038470742f98 Ancestors: PetitCompiler-Extras-Tests-JanKurs.15 Name: PetitCompiler-Benchmarks-JanKurs.12 Author: JanKurs Time: 06-07-2015, 02:10:06.901 PM UUID: cb24f1ac-46a4-494d-9780-64576f0f0dba Ancestors: PetitCompiler-Benchmarks-JanKurs.11, PetitCompiler-Benchmarks-JanVrany.e29bd90f388e.20150619081300

# $Header$
#
# DO NOT EDIT
# automagically generated from the projectDefinition: stx_goodies_petitparser_compiler.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=stx
MODULE_DIR=goodies/petitparser/compiler
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -headerDir=. : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optspace3 -inlinenot


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#  -warnUnused      : no warnings about unused variables
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard

COMMON_CLASSES= \
	PEGFsa \
	PEGFsaFailure \
	PEGFsaInterpret \
	PEGFsaPair \
	PEGFsaState \
	PEGFsaTransition \
	PPCArguments \
	PPCBridge \
	PPCClassBuilder \
	PPCCodeBlock \
	PPCCodeGen \
	PPCCompiledMethod \
	PPCCompiler \
	PPCCompilerTokenErrorStrategy \
	PPCCompilerTokenRememberStrategy \
	PPCCompilerTokenizingErrorStrategy \
	PPCCompilerTokenizingRememberStrategy \
	PPCConfiguration \
	PPCContext \
	PPCContextMemento \
	PPCGuard \
	PPCMethod \
	PPCNode \
	PPCNodeVisitor \
	PPCPluggableConfiguration \
	PPCScanner \
	PPCScannerCodeGenerator \
	PPCTokenGuard \
	PPCompiledParser \
	PPMappedActionParser \
	stx_goodies_petitparser_compiler \
	FooScanner \
	PEGFsaGenerator \
	PPCAbstractLiteralNode \
	PPCAbstractPredicateNode \
	PPCAnyNode \
	PPCCharacterNode \
	PPCCodeGenerator \
	PPCDelegateNode \
	PPCEndOfFileNode \
	PPCFSACodeGen \
	PPCInlinedMethod \
	PPCInliningVisitor \
	PPCListNode \
	PPCNilNode \
	PPCPluggableNode \
	PPCProfilingContext \
	PPCRewritingVisitor \
	PPCTokenizingCompiler \
	PPCTokenizingConfiguration \
	PPCUniversalConfiguration \
	PPCUnknownNode \
	PPTokenizingCompiledParser \
	PPCAbstractActionNode \
	PPCAndNode \
	PPCCharSetPredicateNode \
	PPCChoiceNode \
	PPCCopyVisitor \
	PPCEndOfInputNode \
	PPCForwardNode \
	PPCLL1Visitor \
	PPCLiteralNode \
	PPCMergingVisitor \
	PPCMessagePredicateNode \
	PPCNegateNode \
	PPCNotCharSetPredicateNode \
	PPCNotCharacterNode \
	PPCNotLiteralNode \
	PPCNotMessagePredicateNode \
	PPCNotNode \
	PPCOptimizeChoices \
	PPCOptionalNode \
	PPCPlusNode \
	PPCPredicateNode \
	PPCRecognizerComponentDetector \
	PPCRecognizerComponentVisitor \
	PPCSentinelNode \
	PPCSequenceNode \
	PPCSpecializingVisitor \
	PPCStarNode \
	PPCTokenCodeGenerator \
	PPCTokenConsumeNode \
	PPCTokenDetector \
	PPCTokenNode \
	PPCTokenVisitor \
	PPCTokenWhitespaceNode \
	PPCTokenizingCodeGenerator \
	PPCTokenizingParserNode \
	PPCTokenizingVisitor \
	PPCTrimmingTokenNode \
	PPCActionNode \
	PPCDeterministicChoiceNode \
	PPCRecognizingSequenceNode \
	PPCStarAnyNode \
	PPCStarCharSetPredicateNode \
	PPCStarMessagePredicateNode \
	PPCSymbolActionNode \
	PPCTokenChoiceNode \
	PPCTrimNode \
	PPCTrimmingCharacterTokenNode \
	PPCMappedActionNode \
	PPCTokenStarMessagePredicateNode \
	PPCTokenStarSeparatorNode \




COMMON_OBJS= \
    $(OUTDIR_SLASH)PEGFsa.$(O) \
    $(OUTDIR_SLASH)PEGFsaFailure.$(O) \
    $(OUTDIR_SLASH)PEGFsaInterpret.$(O) \
    $(OUTDIR_SLASH)PEGFsaPair.$(O) \
    $(OUTDIR_SLASH)PEGFsaState.$(O) \
    $(OUTDIR_SLASH)PEGFsaTransition.$(O) \
    $(OUTDIR_SLASH)PPCArguments.$(O) \
    $(OUTDIR_SLASH)PPCBridge.$(O) \
    $(OUTDIR_SLASH)PPCClassBuilder.$(O) \
    $(OUTDIR_SLASH)PPCCodeBlock.$(O) \
    $(OUTDIR_SLASH)PPCCodeGen.$(O) \
    $(OUTDIR_SLASH)PPCCompiledMethod.$(O) \
    $(OUTDIR_SLASH)PPCCompiler.$(O) \
    $(OUTDIR_SLASH)PPCCompilerTokenErrorStrategy.$(O) \
    $(OUTDIR_SLASH)PPCCompilerTokenRememberStrategy.$(O) \
    $(OUTDIR_SLASH)PPCCompilerTokenizingErrorStrategy.$(O) \
    $(OUTDIR_SLASH)PPCCompilerTokenizingRememberStrategy.$(O) \
    $(OUTDIR_SLASH)PPCConfiguration.$(O) \
    $(OUTDIR_SLASH)PPCContext.$(O) \
    $(OUTDIR_SLASH)PPCContextMemento.$(O) \
    $(OUTDIR_SLASH)PPCGuard.$(O) \
    $(OUTDIR_SLASH)PPCMethod.$(O) \
    $(OUTDIR_SLASH)PPCNode.$(O) \
    $(OUTDIR_SLASH)PPCNodeVisitor.$(O) \
    $(OUTDIR_SLASH)PPCPluggableConfiguration.$(O) \
    $(OUTDIR_SLASH)PPCScanner.$(O) \
    $(OUTDIR_SLASH)PPCScannerCodeGenerator.$(O) \
    $(OUTDIR_SLASH)PPCTokenGuard.$(O) \
    $(OUTDIR_SLASH)PPCompiledParser.$(O) \
    $(OUTDIR_SLASH)PPMappedActionParser.$(O) \
    $(OUTDIR_SLASH)stx_goodies_petitparser_compiler.$(O) \
    $(OUTDIR_SLASH)FooScanner.$(O) \
    $(OUTDIR_SLASH)PEGFsaGenerator.$(O) \
    $(OUTDIR_SLASH)PPCAbstractLiteralNode.$(O) \
    $(OUTDIR_SLASH)PPCAbstractPredicateNode.$(O) \
    $(OUTDIR_SLASH)PPCAnyNode.$(O) \
    $(OUTDIR_SLASH)PPCCharacterNode.$(O) \
    $(OUTDIR_SLASH)PPCCodeGenerator.$(O) \
    $(OUTDIR_SLASH)PPCDelegateNode.$(O) \
    $(OUTDIR_SLASH)PPCEndOfFileNode.$(O) \
    $(OUTDIR_SLASH)PPCFSACodeGen.$(O) \
    $(OUTDIR_SLASH)PPCInlinedMethod.$(O) \
    $(OUTDIR_SLASH)PPCInliningVisitor.$(O) \
    $(OUTDIR_SLASH)PPCListNode.$(O) \
    $(OUTDIR_SLASH)PPCNilNode.$(O) \
    $(OUTDIR_SLASH)PPCPluggableNode.$(O) \
    $(OUTDIR_SLASH)PPCProfilingContext.$(O) \
    $(OUTDIR_SLASH)PPCRewritingVisitor.$(O) \
    $(OUTDIR_SLASH)PPCTokenizingCompiler.$(O) \
    $(OUTDIR_SLASH)PPCTokenizingConfiguration.$(O) \
    $(OUTDIR_SLASH)PPCUniversalConfiguration.$(O) \
    $(OUTDIR_SLASH)PPCUnknownNode.$(O) \
    $(OUTDIR_SLASH)PPTokenizingCompiledParser.$(O) \
    $(OUTDIR_SLASH)PPCAbstractActionNode.$(O) \
    $(OUTDIR_SLASH)PPCAndNode.$(O) \
    $(OUTDIR_SLASH)PPCCharSetPredicateNode.$(O) \
    $(OUTDIR_SLASH)PPCChoiceNode.$(O) \
    $(OUTDIR_SLASH)PPCCopyVisitor.$(O) \
    $(OUTDIR_SLASH)PPCEndOfInputNode.$(O) \
    $(OUTDIR_SLASH)PPCForwardNode.$(O) \
    $(OUTDIR_SLASH)PPCLL1Visitor.$(O) \
    $(OUTDIR_SLASH)PPCLiteralNode.$(O) \
    $(OUTDIR_SLASH)PPCMergingVisitor.$(O) \
    $(OUTDIR_SLASH)PPCMessagePredicateNode.$(O) \
    $(OUTDIR_SLASH)PPCNegateNode.$(O) \
    $(OUTDIR_SLASH)PPCNotCharSetPredicateNode.$(O) \
    $(OUTDIR_SLASH)PPCNotCharacterNode.$(O) \
    $(OUTDIR_SLASH)PPCNotLiteralNode.$(O) \
    $(OUTDIR_SLASH)PPCNotMessagePredicateNode.$(O) \
    $(OUTDIR_SLASH)PPCNotNode.$(O) \
    $(OUTDIR_SLASH)PPCOptimizeChoices.$(O) \
    $(OUTDIR_SLASH)PPCOptionalNode.$(O) \
    $(OUTDIR_SLASH)PPCPlusNode.$(O) \
    $(OUTDIR_SLASH)PPCPredicateNode.$(O) \
    $(OUTDIR_SLASH)PPCRecognizerComponentDetector.$(O) \
    $(OUTDIR_SLASH)PPCRecognizerComponentVisitor.$(O) \
    $(OUTDIR_SLASH)PPCSentinelNode.$(O) \
    $(OUTDIR_SLASH)PPCSequenceNode.$(O) \
    $(OUTDIR_SLASH)PPCSpecializingVisitor.$(O) \
    $(OUTDIR_SLASH)PPCStarNode.$(O) \
    $(OUTDIR_SLASH)PPCTokenCodeGenerator.$(O) \
    $(OUTDIR_SLASH)PPCTokenConsumeNode.$(O) \
    $(OUTDIR_SLASH)PPCTokenDetector.$(O) \
    $(OUTDIR_SLASH)PPCTokenNode.$(O) \
    $(OUTDIR_SLASH)PPCTokenVisitor.$(O) \
    $(OUTDIR_SLASH)PPCTokenWhitespaceNode.$(O) \
    $(OUTDIR_SLASH)PPCTokenizingCodeGenerator.$(O) \
    $(OUTDIR_SLASH)PPCTokenizingParserNode.$(O) \
    $(OUTDIR_SLASH)PPCTokenizingVisitor.$(O) \
    $(OUTDIR_SLASH)PPCTrimmingTokenNode.$(O) \
    $(OUTDIR_SLASH)PPCActionNode.$(O) \
    $(OUTDIR_SLASH)PPCDeterministicChoiceNode.$(O) \
    $(OUTDIR_SLASH)PPCRecognizingSequenceNode.$(O) \
    $(OUTDIR_SLASH)PPCStarAnyNode.$(O) \
    $(OUTDIR_SLASH)PPCStarCharSetPredicateNode.$(O) \
    $(OUTDIR_SLASH)PPCStarMessagePredicateNode.$(O) \
    $(OUTDIR_SLASH)PPCSymbolActionNode.$(O) \
    $(OUTDIR_SLASH)PPCTokenChoiceNode.$(O) \
    $(OUTDIR_SLASH)PPCTrimNode.$(O) \
    $(OUTDIR_SLASH)PPCTrimmingCharacterTokenNode.$(O) \
    $(OUTDIR_SLASH)PPCMappedActionNode.$(O) \
    $(OUTDIR_SLASH)PPCTokenStarMessagePredicateNode.$(O) \
    $(OUTDIR_SLASH)PPCTokenStarSeparatorNode.$(O) \
    $(OUTDIR_SLASH)extensions.$(O) \