compiler/Make.spec
author Jan Vrany <jan.vrany@fit.cvut.cz>
Wed, 15 Apr 2015 05:22:53 +0100
changeset 429 23de165842c3
parent 422 116d2b2af905
child 438 20598d7ce9fa
permissions -rw-r--r--
Tell stc to NOT to inline #not as it has different meaning in PetitParser...

# $Header$
#
# DO NOT EDIT
# automagically generated from the projectDefinition: stx_goodies_petitparser_compiler.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=stx
MODULE_DIR=goodies/petitparser/compiler
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -headerDir=. : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optspace3 -inlinenot


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#  -warnUnused      : no warnings about unused variables
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard

COMMON_CLASSES= \
	PPCBridge \
	PPCCompiledMethod \
	PPCCompiler \
	PPCContext \
	PPCContextMemento \
	PPCGuard \
	PPCMethod \
	PPCMethodStrategy \
	PPCNode \
	PPCOptimizationResult \
	PPCompiledParser \
	stx_goodies_petitparser_compiler \
	PPCAbstractCharacterNode \
	PPCAbstractLiteralNode \
	PPCAbstractPredicateNode \
	PPCAnyNode \
	PPCDelegateNode \
	PPCInlinedMethod \
	PPCListNode \
	PPCNilNode \
	PPCPluggableNode \
	PPCProfilingContext \
	PPCUnknownNode \
	PPCAbstractActionNode \
	PPCAndNode \
	PPCCharSetPredicateNode \
	PPCCharacterNode \
	PPCChoiceNode \
	PPCForwardNode \
	PPCInlineAnyNode \
	PPCInlineCharacterNode \
	PPCInlineNilNode \
	PPCInlinePluggableNode \
	PPCLiteralNode \
	PPCMessagePredicateNode \
	PPCNegateNode \
	PPCNotCharSetPredicateNode \
	PPCNotLiteralNode \
	PPCNotMessagePredicateNode \
	PPCNotNode \
	PPCOptionalNode \
	PPCPlusNode \
	PPCPredicateNode \
	PPCSentinelNode \
	PPCSequenceNode \
	PPCStarNode \
	PPCTokenNode \
	PPCTrimNode \
	PPCTrimmingTokenNode \
	PPCActionNode \
	PPCInlineCharSetPredicateNode \
	PPCInlineLiteralNode \
	PPCInlineMessagePredicateNode \
	PPCInlineNotCharSetPredicateNode \
	PPCInlineNotLiteralNode \
	PPCInlineNotMessagePredicateNode \
	PPCStarAnyNode \
	PPCStarCharSetPredicateNode \
	PPCStarMessagePredicateNode \
	PPCSymbolActionNode \
	PPCTokenSequenceNode \
	PPCTokenActionNode \
	PPCTokenStarMessagePredicateNode \
	PPCInlineTokenStarMessagePredicateNode \
	PPCTokenStarSeparatorNode \
	PPCInlineTokenStarSeparatorNode \




COMMON_OBJS= \
    $(OUTDIR_SLASH)PPCBridge.$(O) \
    $(OUTDIR_SLASH)PPCCompiledMethod.$(O) \
    $(OUTDIR_SLASH)PPCCompiler.$(O) \
    $(OUTDIR_SLASH)PPCContext.$(O) \
    $(OUTDIR_SLASH)PPCContextMemento.$(O) \
    $(OUTDIR_SLASH)PPCGuard.$(O) \
    $(OUTDIR_SLASH)PPCMethod.$(O) \
    $(OUTDIR_SLASH)PPCMethodStrategy.$(O) \
    $(OUTDIR_SLASH)PPCNode.$(O) \
    $(OUTDIR_SLASH)PPCOptimizationResult.$(O) \
    $(OUTDIR_SLASH)PPCompiledParser.$(O) \
    $(OUTDIR_SLASH)stx_goodies_petitparser_compiler.$(O) \
    $(OUTDIR_SLASH)PPCAbstractCharacterNode.$(O) \
    $(OUTDIR_SLASH)PPCAbstractLiteralNode.$(O) \
    $(OUTDIR_SLASH)PPCAbstractPredicateNode.$(O) \
    $(OUTDIR_SLASH)PPCAnyNode.$(O) \
    $(OUTDIR_SLASH)PPCDelegateNode.$(O) \
    $(OUTDIR_SLASH)PPCInlinedMethod.$(O) \
    $(OUTDIR_SLASH)PPCListNode.$(O) \
    $(OUTDIR_SLASH)PPCNilNode.$(O) \
    $(OUTDIR_SLASH)PPCPluggableNode.$(O) \
    $(OUTDIR_SLASH)PPCProfilingContext.$(O) \
    $(OUTDIR_SLASH)PPCUnknownNode.$(O) \
    $(OUTDIR_SLASH)PPCAbstractActionNode.$(O) \
    $(OUTDIR_SLASH)PPCAndNode.$(O) \
    $(OUTDIR_SLASH)PPCCharSetPredicateNode.$(O) \
    $(OUTDIR_SLASH)PPCCharacterNode.$(O) \
    $(OUTDIR_SLASH)PPCChoiceNode.$(O) \
    $(OUTDIR_SLASH)PPCForwardNode.$(O) \
    $(OUTDIR_SLASH)PPCInlineAnyNode.$(O) \
    $(OUTDIR_SLASH)PPCInlineCharacterNode.$(O) \
    $(OUTDIR_SLASH)PPCInlineNilNode.$(O) \
    $(OUTDIR_SLASH)PPCInlinePluggableNode.$(O) \
    $(OUTDIR_SLASH)PPCLiteralNode.$(O) \
    $(OUTDIR_SLASH)PPCMessagePredicateNode.$(O) \
    $(OUTDIR_SLASH)PPCNegateNode.$(O) \
    $(OUTDIR_SLASH)PPCNotCharSetPredicateNode.$(O) \
    $(OUTDIR_SLASH)PPCNotLiteralNode.$(O) \
    $(OUTDIR_SLASH)PPCNotMessagePredicateNode.$(O) \
    $(OUTDIR_SLASH)PPCNotNode.$(O) \
    $(OUTDIR_SLASH)PPCOptionalNode.$(O) \
    $(OUTDIR_SLASH)PPCPlusNode.$(O) \
    $(OUTDIR_SLASH)PPCPredicateNode.$(O) \
    $(OUTDIR_SLASH)PPCSentinelNode.$(O) \
    $(OUTDIR_SLASH)PPCSequenceNode.$(O) \
    $(OUTDIR_SLASH)PPCStarNode.$(O) \
    $(OUTDIR_SLASH)PPCTokenNode.$(O) \
    $(OUTDIR_SLASH)PPCTrimNode.$(O) \
    $(OUTDIR_SLASH)PPCTrimmingTokenNode.$(O) \
    $(OUTDIR_SLASH)PPCActionNode.$(O) \
    $(OUTDIR_SLASH)PPCInlineCharSetPredicateNode.$(O) \
    $(OUTDIR_SLASH)PPCInlineLiteralNode.$(O) \
    $(OUTDIR_SLASH)PPCInlineMessagePredicateNode.$(O) \
    $(OUTDIR_SLASH)PPCInlineNotCharSetPredicateNode.$(O) \
    $(OUTDIR_SLASH)PPCInlineNotLiteralNode.$(O) \
    $(OUTDIR_SLASH)PPCInlineNotMessagePredicateNode.$(O) \
    $(OUTDIR_SLASH)PPCStarAnyNode.$(O) \
    $(OUTDIR_SLASH)PPCStarCharSetPredicateNode.$(O) \
    $(OUTDIR_SLASH)PPCStarMessagePredicateNode.$(O) \
    $(OUTDIR_SLASH)PPCSymbolActionNode.$(O) \
    $(OUTDIR_SLASH)PPCTokenSequenceNode.$(O) \
    $(OUTDIR_SLASH)PPCTokenActionNode.$(O) \
    $(OUTDIR_SLASH)PPCTokenStarMessagePredicateNode.$(O) \
    $(OUTDIR_SLASH)PPCInlineTokenStarMessagePredicateNode.$(O) \
    $(OUTDIR_SLASH)PPCTokenStarSeparatorNode.$(O) \
    $(OUTDIR_SLASH)PPCInlineTokenStarSeparatorNode.$(O) \
    $(OUTDIR_SLASH)extensions.$(O) \