parsers/smalltalk/tests/Make.spec
author Jan Vrany <jan.vrany@fit.cvut.cz>
Tue, 07 Oct 2014 09:42:03 +0100
changeset 385 44a36ed4e484
child 421 7e08b31e0dae
permissions -rw-r--r--
Commited a Smalltalk parser (MC package PetitSmalltalk) Name: PetitSmalltalk-JanKurs.71 Author: JanKurs Time: 19-08-2014, 02:18:05 AM UUID: d1d11836-f3e2-4709-abd3-e2ff3b72d7c4 Repository: http://smalltalkhub.com/mc/Moose/PetitParser/main Ancestors: Fixes to be compatible with PPContext

# $Header$
#
# DO NOT EDIT
# automagically generated from the projectDefinition: stx_goodies_petitparser_parsers_smalltalk_tests.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=stx
MODULE_DIR=goodies/petitparser/parsers/smalltalk/tests
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -headerDir=. : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optspace3


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard

COMMON_CLASSES= \
	stx_goodies_petitparser_parsers_smalltalk_tests \




COMMON_OBJS= \
    $(OUTDIR_SLASH)stx_goodies_petitparser_parsers_smalltalk_tests.$(O) \