tests/Make.spec
author Jan Vrany <jan.vrany@fit.cvut.cz>
Mon, 13 Apr 2015 22:00:44 +0100
changeset 427 a7f5e6de19d2
parent 426 2a65c972b937
permissions -rw-r--r--
Merged JK's version from Monticello Name: PetitParser-JanKurs.275 Author: JanKurs Time: 31-03-2015, 05:51:24.398 PM UUID: 9ab3be24-8393-4794-a7e6-e318f3195673 Name: PetitTests-JanKurs.73 Author: JanKurs Time: 21-02-2015, 01:10:13.115 PM UUID: de4f77e3-2d07-476b-855e-69f845edfc7c

# $Header$
#
# DO NOT EDIT
# automagically generated from the projectDefinition: stx_goodies_petitparser_tests.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=stx
MODULE_DIR=goodies/petitparser/tests
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -headerDir=. : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optspace3 -inlinenot


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#  -warnUnused      : no warnings about unused variables
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard

COMMON_CLASSES= \
	PPAbstractParserTest \
	PPArithmeticParser \
	PPContextMementoTest \
	PPContextTest \
	PPLambdaParser \
	PPParserResource \
	stx_goodies_petitparser_tests \
	PPComposedTest \
	PPCompositeParserTest \
	PPConditionalParserTest \
	PPConditionalParserTests \
	PPExtensionTest \
	PPMappingTest \
	PPObjectTest \
	PPParserTest \
	PPPredicateTest \
	PPScriptingTest \
	PPTokenTest \
	PPArithmeticParserTest \
	PPLambdaParserTest \
	PPExpressionParserTest \




COMMON_OBJS= \
    $(OUTDIR_SLASH)PPAbstractParserTest.$(O) \
    $(OUTDIR_SLASH)PPArithmeticParser.$(O) \
    $(OUTDIR_SLASH)PPContextMementoTest.$(O) \
    $(OUTDIR_SLASH)PPContextTest.$(O) \
    $(OUTDIR_SLASH)PPLambdaParser.$(O) \
    $(OUTDIR_SLASH)PPParserResource.$(O) \
    $(OUTDIR_SLASH)stx_goodies_petitparser_tests.$(O) \
    $(OUTDIR_SLASH)PPComposedTest.$(O) \
    $(OUTDIR_SLASH)PPCompositeParserTest.$(O) \
    $(OUTDIR_SLASH)PPConditionalParserTest.$(O) \
    $(OUTDIR_SLASH)PPConditionalParserTests.$(O) \
    $(OUTDIR_SLASH)PPExtensionTest.$(O) \
    $(OUTDIR_SLASH)PPMappingTest.$(O) \
    $(OUTDIR_SLASH)PPObjectTest.$(O) \
    $(OUTDIR_SLASH)PPParserTest.$(O) \
    $(OUTDIR_SLASH)PPPredicateTest.$(O) \
    $(OUTDIR_SLASH)PPScriptingTest.$(O) \
    $(OUTDIR_SLASH)PPTokenTest.$(O) \
    $(OUTDIR_SLASH)PPArithmeticParserTest.$(O) \
    $(OUTDIR_SLASH)PPLambdaParserTest.$(O) \
    $(OUTDIR_SLASH)PPExpressionParserTest.$(O) \