compiler/Make.spec
author Jan Vrany <jan.vrany@fit.cvut.cz>
Mon, 01 Jun 2015 22:02:17 +0100
changeset 477 b18b6cc7aabc
parent 464 f6d77fee9811
child 480 5b0254cca4db
permissions -rw-r--r--
Codegen refactoring [1/x]: Introduced a PPCCodeBlock A PPCCodeBlock is an abstraction of a block of statements with temporaries. This will allow for scoped temporary management in code generator - temporary variables could be allocated for block only. (i.e., make them block-temporaries)

# $Header$
#
# DO NOT EDIT
# automagically generated from the projectDefinition: stx_goodies_petitparser_compiler.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=stx
MODULE_DIR=goodies/petitparser/compiler
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -headerDir=. : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optspace3 -inlinenot


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#  -warnUnused      : no warnings about unused variables
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard

COMMON_CLASSES= \
	PPCArguments \
	PPCBridge \
	PPCCodeBlock \
	PPCCompiledMethod \
	PPCCompiler \
	PPCCompilerTokenErrorStrategy \
	PPCCompilerTokenRememberStrategy \
	PPCCompilerTokenizingErrorStrategy \
	PPCCompilerTokenizingRememberStrategy \
	PPCConfiguration \
	PPCContext \
	PPCContextMemento \
	PPCGuard \
	PPCMethod \
	PPCNode \
	PPCNodeVisitor \
	PPCPluggableConfiguration \
	PPCTokenGuard \
	PPCompiledParser \
	stx_goodies_petitparser_compiler \
	PPCAbstractLiteralNode \
	PPCAbstractPredicateNode \
	PPCAnyNode \
	PPCCharacterNode \
	PPCCodeGenerator \
	PPCDelegateNode \
	PPCEndOfFileNode \
	PPCInlinedMethod \
	PPCInliningVisitor \
	PPCListNode \
	PPCNilNode \
	PPCPluggableNode \
	PPCProfilingContext \
	PPCRewritingVisitor \
	PPCTokenizingCompiler \
	PPCTokenizingConfiguration \
	PPCUniversalConfiguration \
	PPCUnknownNode \
	PPTokenizingCompiledParser \
	PPCAbstractActionNode \
	PPCAndNode \
	PPCCharSetPredicateNode \
	PPCChoiceNode \
	PPCCopyVisitor \
	PPCEndOfInputNode \
	PPCForwardNode \
	PPCLL1Visitor \
	PPCLiteralNode \
	PPCMergingVisitor \
	PPCMessagePredicateNode \
	PPCNegateNode \
	PPCNotCharSetPredicateNode \
	PPCNotCharacterNode \
	PPCNotLiteralNode \
	PPCNotMessagePredicateNode \
	PPCNotNode \
	PPCOptimizeChoices \
	PPCOptionalNode \
	PPCPlusNode \
	PPCPredicateNode \
	PPCRecognizerComponentDetector \
	PPCRecognizerComponentVisitor \
	PPCSentinelNode \
	PPCSequenceNode \
	PPCSpecializingVisitor \
	PPCStarNode \
	PPCTokenCodeGenerator \
	PPCTokenConsumeNode \
	PPCTokenDetector \
	PPCTokenNode \
	PPCTokenVisitor \
	PPCTokenWhitespaceNode \
	PPCTokenizingCodeGenerator \
	PPCTokenizingParserNode \
	PPCTokenizingVisitor \
	PPCTrimmingTokenNode \
	PPCActionNode \
	PPCDeterministicChoiceNode \
	PPCRecognizingSequenceNode \
	PPCStarAnyNode \
	PPCStarCharSetPredicateNode \
	PPCStarMessagePredicateNode \
	PPCSymbolActionNode \
	PPCTokenChoiceNode \
	PPCTrimNode \
	PPCTrimmingCharacterTokenNode \
	PPCTokenStarMessagePredicateNode \
	PPCTokenStarSeparatorNode \




COMMON_OBJS= \
    $(OUTDIR_SLASH)PPCArguments.$(O) \
    $(OUTDIR_SLASH)PPCBridge.$(O) \
    $(OUTDIR_SLASH)PPCCodeBlock.$(O) \
    $(OUTDIR_SLASH)PPCCompiledMethod.$(O) \
    $(OUTDIR_SLASH)PPCCompiler.$(O) \
    $(OUTDIR_SLASH)PPCCompilerTokenErrorStrategy.$(O) \
    $(OUTDIR_SLASH)PPCCompilerTokenRememberStrategy.$(O) \
    $(OUTDIR_SLASH)PPCCompilerTokenizingErrorStrategy.$(O) \
    $(OUTDIR_SLASH)PPCCompilerTokenizingRememberStrategy.$(O) \
    $(OUTDIR_SLASH)PPCConfiguration.$(O) \
    $(OUTDIR_SLASH)PPCContext.$(O) \
    $(OUTDIR_SLASH)PPCContextMemento.$(O) \
    $(OUTDIR_SLASH)PPCGuard.$(O) \
    $(OUTDIR_SLASH)PPCMethod.$(O) \
    $(OUTDIR_SLASH)PPCNode.$(O) \
    $(OUTDIR_SLASH)PPCNodeVisitor.$(O) \
    $(OUTDIR_SLASH)PPCPluggableConfiguration.$(O) \
    $(OUTDIR_SLASH)PPCTokenGuard.$(O) \
    $(OUTDIR_SLASH)PPCompiledParser.$(O) \
    $(OUTDIR_SLASH)stx_goodies_petitparser_compiler.$(O) \
    $(OUTDIR_SLASH)PPCAbstractLiteralNode.$(O) \
    $(OUTDIR_SLASH)PPCAbstractPredicateNode.$(O) \
    $(OUTDIR_SLASH)PPCAnyNode.$(O) \
    $(OUTDIR_SLASH)PPCCharacterNode.$(O) \
    $(OUTDIR_SLASH)PPCCodeGenerator.$(O) \
    $(OUTDIR_SLASH)PPCDelegateNode.$(O) \
    $(OUTDIR_SLASH)PPCEndOfFileNode.$(O) \
    $(OUTDIR_SLASH)PPCInlinedMethod.$(O) \
    $(OUTDIR_SLASH)PPCInliningVisitor.$(O) \
    $(OUTDIR_SLASH)PPCListNode.$(O) \
    $(OUTDIR_SLASH)PPCNilNode.$(O) \
    $(OUTDIR_SLASH)PPCPluggableNode.$(O) \
    $(OUTDIR_SLASH)PPCProfilingContext.$(O) \
    $(OUTDIR_SLASH)PPCRewritingVisitor.$(O) \
    $(OUTDIR_SLASH)PPCTokenizingCompiler.$(O) \
    $(OUTDIR_SLASH)PPCTokenizingConfiguration.$(O) \
    $(OUTDIR_SLASH)PPCUniversalConfiguration.$(O) \
    $(OUTDIR_SLASH)PPCUnknownNode.$(O) \
    $(OUTDIR_SLASH)PPTokenizingCompiledParser.$(O) \
    $(OUTDIR_SLASH)PPCAbstractActionNode.$(O) \
    $(OUTDIR_SLASH)PPCAndNode.$(O) \
    $(OUTDIR_SLASH)PPCCharSetPredicateNode.$(O) \
    $(OUTDIR_SLASH)PPCChoiceNode.$(O) \
    $(OUTDIR_SLASH)PPCCopyVisitor.$(O) \
    $(OUTDIR_SLASH)PPCEndOfInputNode.$(O) \
    $(OUTDIR_SLASH)PPCForwardNode.$(O) \
    $(OUTDIR_SLASH)PPCLL1Visitor.$(O) \
    $(OUTDIR_SLASH)PPCLiteralNode.$(O) \
    $(OUTDIR_SLASH)PPCMergingVisitor.$(O) \
    $(OUTDIR_SLASH)PPCMessagePredicateNode.$(O) \
    $(OUTDIR_SLASH)PPCNegateNode.$(O) \
    $(OUTDIR_SLASH)PPCNotCharSetPredicateNode.$(O) \
    $(OUTDIR_SLASH)PPCNotCharacterNode.$(O) \
    $(OUTDIR_SLASH)PPCNotLiteralNode.$(O) \
    $(OUTDIR_SLASH)PPCNotMessagePredicateNode.$(O) \
    $(OUTDIR_SLASH)PPCNotNode.$(O) \
    $(OUTDIR_SLASH)PPCOptimizeChoices.$(O) \
    $(OUTDIR_SLASH)PPCOptionalNode.$(O) \
    $(OUTDIR_SLASH)PPCPlusNode.$(O) \
    $(OUTDIR_SLASH)PPCPredicateNode.$(O) \
    $(OUTDIR_SLASH)PPCRecognizerComponentDetector.$(O) \
    $(OUTDIR_SLASH)PPCRecognizerComponentVisitor.$(O) \
    $(OUTDIR_SLASH)PPCSentinelNode.$(O) \
    $(OUTDIR_SLASH)PPCSequenceNode.$(O) \
    $(OUTDIR_SLASH)PPCSpecializingVisitor.$(O) \
    $(OUTDIR_SLASH)PPCStarNode.$(O) \
    $(OUTDIR_SLASH)PPCTokenCodeGenerator.$(O) \
    $(OUTDIR_SLASH)PPCTokenConsumeNode.$(O) \
    $(OUTDIR_SLASH)PPCTokenDetector.$(O) \
    $(OUTDIR_SLASH)PPCTokenNode.$(O) \
    $(OUTDIR_SLASH)PPCTokenVisitor.$(O) \
    $(OUTDIR_SLASH)PPCTokenWhitespaceNode.$(O) \
    $(OUTDIR_SLASH)PPCTokenizingCodeGenerator.$(O) \
    $(OUTDIR_SLASH)PPCTokenizingParserNode.$(O) \
    $(OUTDIR_SLASH)PPCTokenizingVisitor.$(O) \
    $(OUTDIR_SLASH)PPCTrimmingTokenNode.$(O) \
    $(OUTDIR_SLASH)PPCActionNode.$(O) \
    $(OUTDIR_SLASH)PPCDeterministicChoiceNode.$(O) \
    $(OUTDIR_SLASH)PPCRecognizingSequenceNode.$(O) \
    $(OUTDIR_SLASH)PPCStarAnyNode.$(O) \
    $(OUTDIR_SLASH)PPCStarCharSetPredicateNode.$(O) \
    $(OUTDIR_SLASH)PPCStarMessagePredicateNode.$(O) \
    $(OUTDIR_SLASH)PPCSymbolActionNode.$(O) \
    $(OUTDIR_SLASH)PPCTokenChoiceNode.$(O) \
    $(OUTDIR_SLASH)PPCTrimNode.$(O) \
    $(OUTDIR_SLASH)PPCTrimmingCharacterTokenNode.$(O) \
    $(OUTDIR_SLASH)PPCTokenStarMessagePredicateNode.$(O) \
    $(OUTDIR_SLASH)PPCTokenStarSeparatorNode.$(O) \
    $(OUTDIR_SLASH)extensions.$(O) \