analyzer/tests/Make.spec
author Claus Gittinger <cg@exept.de>
Tue, 04 Mar 2014 21:26:19 +0100
changeset 264 dab627821108
child 380 8fe3cb4e607f
permissions -rw-r--r--
initial checkin

# $Header: /cvs/stx/stx/goodies/petitparser/analyzer/tests/Make.spec,v 1.1 2014-03-04 20:26:19 cg Exp $
#
# DO NOT EDIT
# automagically generated from the projectDefinition: stx_goodies_petitparser_analyzer_tests.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=stx
MODULE_DIR=goodies/petitparser/analyzer/tests
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -headerDir=. : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optspace3


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard

COMMON_CLASSES= \
	PPAnalyzerTest \
	PPRewriterTest \
	PPSearcherTest \
	stx_goodies_petitparser_analyzer_tests \




COMMON_OBJS= \
    $(OUTDIR_SLASH)PPAnalyzerTest.$(O) \
    $(OUTDIR_SLASH)PPRewriterTest.$(O) \
    $(OUTDIR_SLASH)PPSearcherTest.$(O) \
    $(OUTDIR_SLASH)stx_goodies_petitparser_analyzer_tests.$(O) \