compiler/tests/Make.spec
author Jan Vrany <jan.vrany@fit.cvut.cz>
Thu, 21 May 2015 14:12:22 +0100
changeset 464 f6d77fee9811
parent 459 4751c407bb40
child 502 1e45d3c96ec5
permissions -rw-r--r--
Updated to PetitCompiler-JanKurs.118, PetitCompiler-Tests-JanKurs.46, PetitCompiler-Extras-Tests-JanKurs.11, and PetitCompiler-Benchmarks-JanKurs.11 Name: PetitCompiler-JanKurs.118 Author: JanKurs Time: 13-05-2015, 03:59:01.292 PM UUID: 4a8ccd94-3131-4cc7-9098-528f8e5ea0b5 Name: PetitCompiler-Tests-JanKurs.46 Author: JanKurs Time: 04-05-2015, 04:25:06.162 PM UUID: 9f4cf8b7-876e-4a13-9579-b833f016db66 Name: PetitCompiler-Extras-Tests-JanKurs.11 Author: JanKurs Time: 13-05-2015, 04:27:27.940 PM UUID: e9f30c31-fbd0-4e96-ad2a-868f88d20ea8 Name: PetitCompiler-Benchmarks-JanKurs.11 Author: JanKurs Time: 13-05-2015, 02:21:49.932 PM UUID: 6a23fd1e-a86f-46db-8221-cc41b778d32c

# $Header$
#
# DO NOT EDIT
# automagically generated from the projectDefinition: stx_goodies_petitparser_compiler_tests.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=stx
MODULE_DIR=goodies/petitparser/compiler/tests
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -headerDir=. : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optspace3 -inlinenot


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#  -warnUnused      : no warnings about unused variables
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard

COMMON_CLASSES= \
	PPCCodeGeneratorTest \
	PPCCompilerTest \
	PPCContextMementoTest \
	PPCContextTest \
	PPCCopyVisitorTest \
	PPCGuardTest \
	PPCInliningVisitorTest \
	PPCLL1VisitorTest \
	PPCLTokenizingOptimizationTest \
	PPCMergingVisitorTest \
	PPCMockCompiler \
	PPCNodeFirstFollowNextTests \
	PPCNodeTest \
	PPCOptimizeChoicesTest \
	PPCRecognizerComponentDetectorTest \
	PPCRecognizerComponentVisitorTest \
	PPCSpecializingVisitorTest \
	PPCTokenDetectorTest \
	PPCTokenGuardTest \
	PPCTokenizingCodeGeneratorTest \
	PPCTokenizingTest \
	PPCTokenizingVisitorTest \
	PPCUniversalOptimizationTest \
	PPCUniversalTest \
	stx_goodies_petitparser_compiler_tests \




COMMON_OBJS= \
    $(OUTDIR_SLASH)PPCCodeGeneratorTest.$(O) \
    $(OUTDIR_SLASH)PPCCompilerTest.$(O) \
    $(OUTDIR_SLASH)PPCContextMementoTest.$(O) \
    $(OUTDIR_SLASH)PPCContextTest.$(O) \
    $(OUTDIR_SLASH)PPCCopyVisitorTest.$(O) \
    $(OUTDIR_SLASH)PPCGuardTest.$(O) \
    $(OUTDIR_SLASH)PPCInliningVisitorTest.$(O) \
    $(OUTDIR_SLASH)PPCLL1VisitorTest.$(O) \
    $(OUTDIR_SLASH)PPCLTokenizingOptimizationTest.$(O) \
    $(OUTDIR_SLASH)PPCMergingVisitorTest.$(O) \
    $(OUTDIR_SLASH)PPCMockCompiler.$(O) \
    $(OUTDIR_SLASH)PPCNodeFirstFollowNextTests.$(O) \
    $(OUTDIR_SLASH)PPCNodeTest.$(O) \
    $(OUTDIR_SLASH)PPCOptimizeChoicesTest.$(O) \
    $(OUTDIR_SLASH)PPCRecognizerComponentDetectorTest.$(O) \
    $(OUTDIR_SLASH)PPCRecognizerComponentVisitorTest.$(O) \
    $(OUTDIR_SLASH)PPCSpecializingVisitorTest.$(O) \
    $(OUTDIR_SLASH)PPCTokenDetectorTest.$(O) \
    $(OUTDIR_SLASH)PPCTokenGuardTest.$(O) \
    $(OUTDIR_SLASH)PPCTokenizingCodeGeneratorTest.$(O) \
    $(OUTDIR_SLASH)PPCTokenizingTest.$(O) \
    $(OUTDIR_SLASH)PPCTokenizingVisitorTest.$(O) \
    $(OUTDIR_SLASH)PPCUniversalOptimizationTest.$(O) \
    $(OUTDIR_SLASH)PPCUniversalTest.$(O) \
    $(OUTDIR_SLASH)stx_goodies_petitparser_compiler_tests.$(O) \