compiler/tests/extras/Make.spec
author Jan Vrany <jan.vrany@fit.cvut.cz>
Thu, 21 May 2015 14:35:34 +0100
changeset 465 f729f6cd3c76
parent 461 5986bf6d7d60
parent 464 f6d77fee9811
child 469 8dc4eb06316e
permissions -rw-r--r--
Merge

# $Header$
#
# DO NOT EDIT
# automagically generated from the projectDefinition: stx_goodies_petitparser_compiler_tests_extras.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=stx
MODULE_DIR=goodies/petitparser/compiler/tests/extras
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -headerDir=. : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optspace3


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#  -warnUnused      : no warnings about unused variables
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard

COMMON_CLASSES= \
	PPCCompiledJavaVerificationTest \
	PPCExpressionsVerificationTest \
	PPExpressionGrammar \
	PPLL1ExpressionGrammar \
	PPCResources \
	PPCSmalltalkTests \
	PPCSmalltalkVerificationTest \
	PPCompiledJavaResource \
	PPCompiledSmalltalkGrammarResource \
	PPCompiledSmalltalkGrammarTests \
	PPTokenizedSmalltalkGrammarResource \
	PPTokenizedSmalltalkGrammarTests \
	stx_goodies_petitparser_compiler_tests_extras \
	PPCompiledExpressionsVerificationTest \
	PPCompiledSmalltalkVerificationTest \
	PPTokenizedExpressionsVerificationTest \
	PPTokenizedSmalltalkVerificationTest \




COMMON_OBJS= \
    $(OUTDIR_SLASH)PPCCompiledJavaVerificationTest.$(O) \
    $(OUTDIR_SLASH)PPCExpressionsVerificationTest.$(O) \
    $(OUTDIR_SLASH)PPExpressionGrammar.$(O) \
    $(OUTDIR_SLASH)PPLL1ExpressionGrammar.$(O) \
    $(OUTDIR_SLASH)PPCResources.$(O) \
    $(OUTDIR_SLASH)PPCSmalltalkTests.$(O) \
    $(OUTDIR_SLASH)PPCSmalltalkVerificationTest.$(O) \
    $(OUTDIR_SLASH)PPCompiledJavaResource.$(O) \
    $(OUTDIR_SLASH)PPCompiledSmalltalkGrammarResource.$(O) \
    $(OUTDIR_SLASH)PPCompiledSmalltalkGrammarTests.$(O) \
    $(OUTDIR_SLASH)PPTokenizedSmalltalkGrammarResource.$(O) \
    $(OUTDIR_SLASH)PPTokenizedSmalltalkGrammarTests.$(O) \
    $(OUTDIR_SLASH)stx_goodies_petitparser_compiler_tests_extras.$(O) \
    $(OUTDIR_SLASH)PPCompiledExpressionsVerificationTest.$(O) \
    $(OUTDIR_SLASH)PPCompiledSmalltalkVerificationTest.$(O) \
    $(OUTDIR_SLASH)PPTokenizedExpressionsVerificationTest.$(O) \
    $(OUTDIR_SLASH)PPTokenizedSmalltalkVerificationTest.$(O) \