Make.spec
changeset 2062 c46879a2a970
parent 2059 bd1c39acf4ec
child 2084 11b96ceded72
equal deleted inserted replaced
2061:76026acab86d 2062:c46879a2a970
     1 # $Header$
     1 # $Header$
       
     2 #
       
     3 # DO NOT EDIT 
       
     4 # automagically generated from the projectDefinition: stx_libtool2.
       
     5 #
       
     6 # Warning: once you modify this file, do not rerun
       
     7 # stmkmp or projectDefinition-build again - otherwise, your changes are lost.
       
     8 #
       
     9 # This file contains specifications which are common to all platforms.
       
    10 #
     2 
    11 
     3 # -------------- no need to change anything below ----------
    12 # Do NOT CHANGE THESE DEFINITIONS
     4 
    13 # (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
       
    14 #  to find the source code of a class and to find the library for a package)
     5 MODULE=stx
    15 MODULE=stx
     6 MODULE_DIR=libtool2
    16 MODULE_DIR=libtool2
       
    17 PACKAGE=$(MODULE):$(MODULE_DIR)
     7 LIBNAME=libstx_libtool2
    18 LIBNAME=libstx_libtool2
     8 PACKAGE=$(MODULE):$(MODULE_DIR)
       
     9 THIS_IS_A_BASE_LIBRARY="yes"
       
    10 
    19 
    11 UNUSED_OBJS=  \
       
    12 	$(OUTDIR)NewInspectorList.$(O)      \
       
    13 	$(OUTDIR)NewInspectorListView.$(O)  \
       
    14 	$(OUTDIR)NewInspectorView.$(O)      \
       
    15 	$(OUTDIR)NewInspectorPanelView.$(O)
       
    16 
    20 
    17 OBJS= \
    21 # Argument(s) to the stc compiler (stc --usage).
    18 	$(LIBTOOL2_PACKAGE_OBJS) \
    22 #  -H.         : create header files locally
    19 	$(OUTDIR)MenuEditor.$(O) \
    23 #                (if removed, they will be created as common
    20 	$(OUTDIR)ImageEditor.$(O) \
    24 #  -Pxxx       : defines the package
    21 	$(OUTDIR)DataSetBuilder.$(O) \
    25 #  -Zxxx       : a prefix for variables within the classLib
    22 	$(OUTDIR)UIGalleryView.$(O) \
    26 #  -Dxxx       : defines passed to to CC for inline C-code
    23 	$(OUTDIR)UIHelpTool.$(O) \
    27 #  -Ixxx       : include path passed to CC for inline C-code
    24 	$(OUTDIR)UILayoutTool.$(O) \
    28 #  +optspace   : optimized for space
    25 	$(OUTDIR)UIObjectView.$(O) \
    29 #  +optspace2  : optimized more for space
    26 	$(OUTDIR)UIPainter.$(O) \
    30 #  +optspace3  : optimized even more for space
    27 	$(OUTDIR)UIPainterView.$(O) \
    31 #  +optinline  : generate inline code for some ST constructs
    28 	$(OUTDIR)UISelectionPanel.$(O) \
    32 #  +inlineNew  : additionally inline new
    29 	$(OUTDIR)UISpecificationTool.$(O) \
    33 #  +inlineMath : additionally inline some floatPnt math stuff
    30 	$(OUTDIR)SelectionBrowser.$(O) \
    34 #
    31 	$(OUTDIR)FileSelectionBrowser.$(O) \
    35 # ********** OPTIONAL: MODIFY the next line(s) ***
    32 	$(OUTDIR)ResourceSelectionBrowser.$(O)
    36 # STCLOCALOPTIMIZATIONS=+optinline +inlineNew
       
    37 # STCLOCALOPTIMIZATIONS=+optspace3
       
    38 STCLOCALOPTIMIZATIONS=+optspace3
       
    39 
       
    40 
       
    41 # Argument(s) to the stc compiler (stc --usage).
       
    42 #  -warn            : no warnings
       
    43 #  -warnNonStandard : no warnings about ST/X extensions
       
    44 #  -warnEOLComments : no warnings about EOL comment extension
       
    45 #  -warnPrivacy     : no warnings about privateClass extension
       
    46 #
       
    47 # ********** OPTIONAL: MODIFY the next line(s) ***
       
    48 # STCWARNINGS=-warn
       
    49 # STCWARNINGS=-warnNonStandard
       
    50 # STCWARNINGS=-warnEOLComments
       
    51 STCWARNINGS=-warnNonStandard
       
    52 
       
    53 COMMON_OBJS= \
       
    54     $(OUTDIR)DataSetBuilder.$(O) \
       
    55     $(OUTDIR)SelectionBrowser.$(O) \
       
    56     $(OUTDIR)ImageEditor.$(O) \
       
    57     $(OUTDIR)MenuEditor.$(O) \
       
    58     $(OUTDIR)ResourceSelectionBrowser.$(O) \
       
    59     $(OUTDIR)FileSelectionBrowser.$(O) \
       
    60     $(OUTDIR)UIGalleryView.$(O) \
       
    61     $(OUTDIR)UIHelpTool.$(O) \
       
    62     $(OUTDIR)UILayoutTool.$(O) \
       
    63     $(OUTDIR)UIObjectView.$(O) \
       
    64     $(OUTDIR)UIPainter.$(O) \
       
    65     $(OUTDIR)UIPainterView.$(O) \
       
    66     $(OUTDIR)UISelectionPanel.$(O) \
       
    67     $(OUTDIR)UISpecificationTool.$(O) \
       
    68     $(OUTDIR)stx_libtool2.$(O) \
       
    69 
       
    70