Make.spec
changeset 2062 c46879a2a970
parent 2059 bd1c39acf4ec
child 2084 11b96ceded72
--- a/Make.spec	Mon Aug 28 19:48:18 2006 +0200
+++ b/Make.spec	Mon Aug 28 19:48:21 2006 +0200
@@ -1,32 +1,70 @@
 # $Header$
+#
+# DO NOT EDIT 
+# automagically generated from the projectDefinition: stx_libtool2.
+#
+# Warning: once you modify this file, do not rerun
+# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
+#
+# This file contains specifications which are common to all platforms.
+#
 
-# -------------- no need to change anything below ----------
-
+# Do NOT CHANGE THESE DEFINITIONS
+# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
+#  to find the source code of a class and to find the library for a package)
 MODULE=stx
 MODULE_DIR=libtool2
+PACKAGE=$(MODULE):$(MODULE_DIR)
 LIBNAME=libstx_libtool2
-PACKAGE=$(MODULE):$(MODULE_DIR)
-THIS_IS_A_BASE_LIBRARY="yes"
+
 
-UNUSED_OBJS=  \
-	$(OUTDIR)NewInspectorList.$(O)      \
-	$(OUTDIR)NewInspectorListView.$(O)  \
-	$(OUTDIR)NewInspectorView.$(O)      \
-	$(OUTDIR)NewInspectorPanelView.$(O)
+# Argument(s) to the stc compiler (stc --usage).
+#  -H.         : create header files locally
+#                (if removed, they will be created as common
+#  -Pxxx       : defines the package
+#  -Zxxx       : a prefix for variables within the classLib
+#  -Dxxx       : defines passed to to CC for inline C-code
+#  -Ixxx       : include path passed to CC for inline C-code
+#  +optspace   : optimized for space
+#  +optspace2  : optimized more for space
+#  +optspace3  : optimized even more for space
+#  +optinline  : generate inline code for some ST constructs
+#  +inlineNew  : additionally inline new
+#  +inlineMath : additionally inline some floatPnt math stuff
+#
+# ********** OPTIONAL: MODIFY the next line(s) ***
+# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
+# STCLOCALOPTIMIZATIONS=+optspace3
+STCLOCALOPTIMIZATIONS=+optspace3
+
 
-OBJS= \
-	$(LIBTOOL2_PACKAGE_OBJS) \
-	$(OUTDIR)MenuEditor.$(O) \
-	$(OUTDIR)ImageEditor.$(O) \
-	$(OUTDIR)DataSetBuilder.$(O) \
-	$(OUTDIR)UIGalleryView.$(O) \
-	$(OUTDIR)UIHelpTool.$(O) \
-	$(OUTDIR)UILayoutTool.$(O) \
-	$(OUTDIR)UIObjectView.$(O) \
-	$(OUTDIR)UIPainter.$(O) \
-	$(OUTDIR)UIPainterView.$(O) \
-	$(OUTDIR)UISelectionPanel.$(O) \
-	$(OUTDIR)UISpecificationTool.$(O) \
-	$(OUTDIR)SelectionBrowser.$(O) \
-	$(OUTDIR)FileSelectionBrowser.$(O) \
-	$(OUTDIR)ResourceSelectionBrowser.$(O)
+# Argument(s) to the stc compiler (stc --usage).
+#  -warn            : no warnings
+#  -warnNonStandard : no warnings about ST/X extensions
+#  -warnEOLComments : no warnings about EOL comment extension
+#  -warnPrivacy     : no warnings about privateClass extension
+#
+# ********** OPTIONAL: MODIFY the next line(s) ***
+# STCWARNINGS=-warn
+# STCWARNINGS=-warnNonStandard
+# STCWARNINGS=-warnEOLComments
+STCWARNINGS=-warnNonStandard
+
+COMMON_OBJS= \
+    $(OUTDIR)DataSetBuilder.$(O) \
+    $(OUTDIR)SelectionBrowser.$(O) \
+    $(OUTDIR)ImageEditor.$(O) \
+    $(OUTDIR)MenuEditor.$(O) \
+    $(OUTDIR)ResourceSelectionBrowser.$(O) \
+    $(OUTDIR)FileSelectionBrowser.$(O) \
+    $(OUTDIR)UIGalleryView.$(O) \
+    $(OUTDIR)UIHelpTool.$(O) \
+    $(OUTDIR)UILayoutTool.$(O) \
+    $(OUTDIR)UIObjectView.$(O) \
+    $(OUTDIR)UIPainter.$(O) \
+    $(OUTDIR)UIPainterView.$(O) \
+    $(OUTDIR)UISelectionPanel.$(O) \
+    $(OUTDIR)UISpecificationTool.$(O) \
+    $(OUTDIR)stx_libtool2.$(O) \
+
+