Make.spec
author Claus Gittinger <cg@exept.de>
Tue, 08 Jan 2008 12:51:44 +0100
changeset 2222 23205ddb56e1
parent 2140 7d6e48e8fbce
child 2288 31f5459f22d9
permissions -rw-r--r--
bug fix: saving a spec while grid is on saved the grid-Form as backgroundColor in the spec.

# $Header$
#
# DO NOT EDIT 
# automagically generated from the projectDefinition: stx_libtool2.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=stx
MODULE_DIR=libtool2
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -H.         : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optspace3


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard

COMMON_OBJS= \
    $(OUTDIR)ColorEditDialog.$(O) \
    $(OUTDIR)DataSetBuilder.$(O) \
    $(OUTDIR)ImageEditor.$(O) \
    $(OUTDIR)MenuEditor.$(O) \
    $(OUTDIR)SelectionBrowser.$(O) \
    $(OUTDIR)UIGalleryView.$(O) \
    $(OUTDIR)UIHelpTool.$(O) \
    $(OUTDIR)UILayoutTool.$(O) \
    $(OUTDIR)UIObjectView.$(O) \
    $(OUTDIR)UIPainter.$(O) \
    $(OUTDIR)UISelectionPanel.$(O) \
    $(OUTDIR)UISpecificationTool.$(O) \
    $(OUTDIR)stx_libtool2.$(O) \
    $(OUTDIR)FileSelectionBrowser.$(O) \
    $(OUTDIR)ResourceSelectionBrowser.$(O) \
    $(OUTDIR)UIPainterView.$(O) \