Make.spec
author Claus Gittinger <cg@exept.de>
Tue, 01 Oct 2019 10:53:24 +0200
changeset 3774 271887d2ed74
parent 3701 6f4df83da9b7
permissions -rw-r--r--
#BUGFIX by exept class: MethodFinderWindow changed: #clear

# $Header$
#
# DO NOT EDIT
# automagically generated from the projectDefinition: stx_libtool2.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=stx
MODULE_DIR=libtool2
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -headerDir=. : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optspace3


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#  -warnUnused      : no warnings about unused variables
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard -warnUnused

COMMON_CLASSES= \
	ColorEditDialog \
	DataSetBuilder \
	DirectoryView \
	FileVersionDiffBrowser \
	FlyByWindowInformation \
	ImageEditor \
	MenuEditor \
	MethodFinderWindow \
	SelectionBrowser \
	ShowMeHowItWorks \
	TabListEditor \
	Tools::InternationalLanguageTranslationEditor \
	Tools::ObjectModuleInformation \
	Tools::ProjectBuilder \
	Tools::ProjectBuilderAssistantApplication \
	UIGalleryView \
	UIHelpTool \
	UILayoutTool \
	UIListEditor \
	UIObjectView \
	UIPainter \
	UISelectionPanel \
	UISpecificationTool \
	stx_libtool2 \
	FileSelectionBrowser \
	ResourceSelectionBrowser \
	UIPainterView \




COMMON_OBJS= \
    $(OUTDIR)ColorEditDialog.$(O) \
    $(OUTDIR)DataSetBuilder.$(O) \
    $(OUTDIR)DirectoryView.$(O) \
    $(OUTDIR)FileVersionDiffBrowser.$(O) \
    $(OUTDIR)FlyByWindowInformation.$(O) \
    $(OUTDIR)ImageEditor.$(O) \
    $(OUTDIR)MenuEditor.$(O) \
    $(OUTDIR)MethodFinderWindow.$(O) \
    $(OUTDIR)SelectionBrowser.$(O) \
    $(OUTDIR)ShowMeHowItWorks.$(O) \
    $(OUTDIR)TabListEditor.$(O) \
    $(OUTDIR)Tools__InternationalLanguageTranslationEditor.$(O) \
    $(OUTDIR)Tools__ObjectModuleInformation.$(O) \
    $(OUTDIR)ProjectBuilder.$(O) \
    $(OUTDIR)Tools__ProjectBuilderAssistantApplication.$(O) \
    $(OUTDIR)UIGalleryView.$(O) \
    $(OUTDIR)UIHelpTool.$(O) \
    $(OUTDIR)UILayoutTool.$(O) \
    $(OUTDIR)UIListEditor.$(O) \
    $(OUTDIR)UIObjectView.$(O) \
    $(OUTDIR)UIPainter.$(O) \
    $(OUTDIR)UISelectionPanel.$(O) \
    $(OUTDIR)UISpecificationTool.$(O) \
    $(OUTDIR)stx_libtool2.$(O) \
    $(OUTDIR)FileSelectionBrowser.$(O) \
    $(OUTDIR)ResourceSelectionBrowser.$(O) \
    $(OUTDIR)UIPainterView.$(O) \
    $(OUTDIR)extensions.$(O) \