Faculty of Information Technology
Software Engineering Group

Opened 2 years ago

Closed 14 months ago

#108 closed defect (fixed)

Debug Trace not removed

Reported by: Patrik Svestka Owned by:
Priority: minor Milestone: 8.0.0
Component: default Keywords:
Cc: Also affects CVS HEAD (eXept version): no

Description

After turning on Debug/Trace? (from menu) and right afterwards switching on Debug/Trace? Sender or Debug/Trace? full walkback; It is impossible to remove the traces using menu Debug/Remove? trace. Only Remove all Break- & Tracepoints works. (Maybe this was intentional?)

Change History (8)

comment:1 Changed 2 years ago by Jan Vrany

Milestone: 8.0.0

comment:2 Changed 17 months ago by Jan Vrany

This is indeed a bug. It's caused by method being wrapped twice - the problem is probably in Tools::NewSystemBrowser >> commonTraceHelperWith:with:clear:

Changed 16 months ago by Jan Vrany

comment:3 Changed 14 months ago by Jan Vrany

Status: newtesting

comment:4 Changed 14 months ago by Patrik Svestka

Resolution: fixed
Status: testingclosed

The patches work perfectly. The traces are now correctly removed and tests do pass.

I'm closing this ticket.

Note: See TracTickets for help on using tickets.