Faculty of Information Technology
Software Engineering Group

Opened 10 months ago

Closed 9 months ago

Last modified 9 months ago

#112 closed defect (fixed)

Creating a simple application produces a MessageNotUnderstood]: Symbol does not understand: #theMetaclass in process UIPainter [564] error

Reported by: Patrik Svestka Owned by:
Priority: major Milestone: 8.0.0
Component: default Keywords:
Cc: Also affects CVS HEAD (eXept version): no

Description

Steps to reproduce on 6.2.6.0 version:

  1. Launch StX
  2. Start GUIPainter via icon on StX Launcher
  3. On a Canvas put two objects 'Entry Field' and a 'Slider'
  4. Launch the application via the 'rocket' button
  5. Fill Class TestingApplication?
  6. Click on 'yes' when asked if Create Class TestingApplication?
  7. An error is displayed - [MessageNotUnderstood?]: Symbol does not understand: #theMetaclass in process UIPainter [155]

The error stops in method: loadFromClass:aClass on line 15 - (aClass theMetaclass implements:helpSpecSelector) ifFalse:[

Attachments (1)

Change History (10)

comment:1 Changed 10 months ago by Jan Vrany

The problem is trivial, UIPainter>>doDefineClassAndSelector sends #buildAndMergeFromClass: passing as class name as parameter. However, UIHelpTool>>#buildAndMergeFromClass: expects a class object (instance of Class).

The complication here is that this is all in package stx:libtool2 which is checked out from eXept's CVS and we cannot commit there, so I have either to fork this package too or ask Claus to fix it for me. Will think of it, but there are so many problems in UI painter anyway so perhaps it's time to fork and fix.

comment:2 Changed 10 months ago by Patrik Svestka

You have to count the pros and cons, what would that fork of stx:libtool2 mean in the end?

comment:3 in reply to:  2 Changed 10 months ago by Jan Vrany

Replying to patrik.svestka@…:

You have to count the pros and cons, what would that fork of stx:libtool2 mean in the end?

In the end all it would take it is to add change couple configuration files here and there, not much.

There are more issues with UI Painter that might need some changes in its codebase e.g. #5, #46, #47, #97 and possibly more will come. So it's clear - fork it.

Will do it soon(ish).

comment:4 Changed 10 months ago by Jan Vrany

Milestone: 8.0.0

comment:5 Changed 10 months ago by Jan Vrany

OK, forked. You may need to update rakefiles, then remove (move aside) build/stx/libtool2, then rake chexkout and recompile rake compile.

comment:6 Changed 10 months ago by Jan Vrany

Attached patch should fix it.

comment:7 Changed 10 months ago by Jan Vrany

Status: newtesting

comment:8 Changed 9 months ago by Patrik Svestka

Keywords: The fix works. added
Resolution: fixed
Status: testingclosed

comment:9 Changed 9 months ago by Patrik Svestka

Keywords: The fix works. removed
Note: See TracTickets for help on using tickets.