Faculty of Information Technology
Software Engineering Group

Opened 9 months ago

Closed 8 months ago

#120 closed defect (fixed)

Inspector2 does not show custom presentations

Reported by: Jan Vrany Owned by:
Priority: major Milestone: 8.0.0
Component: default Keywords:
Cc: Also affects CVS HEAD (eXept version): yes

Description

The tab itself is shown but it's empty. This happens for custom tabs that embed ApplicationModel subclass. For example, try to inspect any method - tabs showing parse trees are empty.

Change History (3)

comment:1 Changed 9 months ago by Jan Vrany

Status: newtesting

The cause was misuse and inconsistence between #application:, #applicationHolder:,
introduced by eXept's commit 9ff9bed9f98e/stx.libtool.

Attached patch should fix it. It will eventually bubble up to public repositories once the integration pipeline successfully finishes. I'll close the issue then.

comment:2 Changed 8 months ago by Jan Vrany

Resolution: fixed
Status: testingclosed
Note: See TracTickets for help on using tickets.