Faculty of Information Technology
Software Engineering Group

Opened 9 months ago

Closed 9 months ago

#122 closed defect (fixed)

Downloading Stable build from Jenkins does not "see" styles - loaded with default Motif sytyle

Reported by: Patrik Svestka Owned by: Jan Vrany
Priority: major Milestone: 8.0.0
Component: default Keywords:
Cc: Also affects CVS HEAD (eXept version): no

Description

Steps to reproduce:
1) download latest stable build (at this time #2480)
2) upacked compiled Stx - smalltalkx-jv-branch-6.2.6_build2430_x86_64-win32.zip
3) run it from StX\bin stx.bat
4) The message on console:
{{{SimpleView? [warning] (2017-03-08 09:31:18.494): * no styleSheet for mswindows8-style.
SimpleView? [warning] (2017-03-08 09:31:18.496): not even a styleSheet for normal-style (using ugly defaults).}}}

Attachments (1)

issue-122-test.bat (251 bytes) - added by Jan Vrany 9 months ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 9 months ago by Jan Vrany

Milestone: 8.0.0
Owner: set to Jan Vrany
Status: newaccepted

Changed 9 months ago by Jan Vrany

Attachment: issue-122-test.bat added

comment:2 Changed 9 months ago by Jan Vrany

Hmm...I cannot reproduce this. What I tried exactly is to:

  1. Open Conemu / Command Prompt (tried both)
  2. Run following commands (see issue-122-test.bat):
    wget https://swing.fit.cvut.cz/jenkins/job/stx_jv/2480/artifact/artifacts/smalltalkx-jv-branch-6.2.6_build2480_x86_64-win32.zip
    unzip smalltalkx-jv-branch-6.2.6_build2480_x86_64-win32.zip
    smalltalkx-jv-branch-6.2.6_build2480_x86_64-win32\bin\stx.bat
    

Everything was as expected, UI theme was OK, no messages like you mentioned in console. Tried both Win 7 and Win 10 (merely to try on two different instances).

Could you try with attached script? If it still could not find stylesheets or the UI is ugly, could you attach environment variables (output of set command, maybe you may need to sanitize some values containing secrets :-)

comment:3 Changed 9 months ago by Patrik Svestka

My bad. I have downloaded an older build #2430 not #2480.

I have tried the #2480 and it works! Sorry about that.

comment:5 Changed 9 months ago by Patrik Svestka

Resolution: fixed
Status: acceptedclosed
Note: See TracTickets for help on using tickets.