Faculty of Information Technology
Software Engineering Group

Opened 4 months ago

Closed 3 months ago

#145 closed defect (fixed)

DNU when opening help topic from dev tools

Reported by: Jan Vrany Owned by:
Priority: major Milestone: 8.0.0
Component: default Keywords:
Cc: Also affects CVS HEAD (eXept version): no

Description

Steps to reproduce:

  1. Start Smalltalk/X from build tree
  2. Open new workspace
  3. Pick Help -> Workspace Documentation

Observed behavior:

[MessageNotUnderstood]: String does not understand: #isURL in process WorkspaceApplication [148]

Expected behavior:

No DNU, naturally.

Notes:

  • this happen for every development tool I tried. When testing, try also launcher, browser, debugger, inspector...
  • when testing, also try release build (build artifact) to make sure it works in both

Change History (2)

comment:1 Changed 4 months ago by Jan Vrany

This is due to a missing #isURL on Object, we need to cherry-pick the change from upstream.

comment:2 Changed 3 months ago by Jan Vrany

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.