Faculty of Information Technology
Software Engineering Group

Opened 20 months ago

Last modified 4 months ago

#154 reopened defect

The embedded debugger on windows should behave the same way as on Linux

Reported by: Patrik Svestka Owned by:
Priority: major Milestone: 8.0.0
Component: default Keywords:
Cc: Also affects CVS HEAD (eXept version): no

Description

The embedded debugger should:

  • stay on top
  • should not have, if possible, any decorations except close
  • the cursor should change when you hoover over the picture button of the embedded debugger.

Change History (12)

comment:1 Changed 19 months ago by Jan Vrany

Status: newtesting

Attached patches should:

  • make it a tool window (thinner frame, only close button).
  • restores the hand-cursor on buttons on Windows.

They does not make the mini-testrunner to stay on top. After reading MSDN, it looks that we can make it a top-most window - so it will be above all non-topmost windows, no matter to which application they belong (not great). Or leave it as it is.

Under GNOME shell, the tool window is above all non-tool windows *of the same program* - which is IMO the best - but this seems to be impossible on Windows.

Shall we make it a top-most Window?

comment:2 Changed 19 months ago by Patrik Svestka

I'll be testing the patches soon. Just wanted to answer your question. Yes you are right, the only option is, not that great, have it top-most window from all windows.

I think that is still reasonable because when you are working with the embedded debug window you usually work with StX so that is fine, if you do not want that window you can still work just with StX integrated debugger only.

To answer the question yes lets make it a top-most window.

Last edited 19 months ago by Patrik Svestka (previous) (diff)

comment:3 Changed 19 months ago by Patrik Svestka

I do confirm that these patches work as desired.

Both functionality is done and works correctly:

  • make it a tool window (thinner frame, only close button).
  • restores the hand-cursor on buttons on Windows.

When a top-most window patch will be available I'll test it too and close the ticket afterwards.

comment:4 Changed 18 months ago by Jan Vrany

OK, I just pushed for integration:

The fix to making it topmost is still pending....

comment:5 Changed 13 months ago by Jan Vrany

Milestone: 8.0.0

Uff, after so long I finally wrote the last missing but, see the last patch. Please have a look.

Note that all previous patches from this ticket are already integrated, no need to apply them if you hav up-to-date libview/libtool.

comment:6 Changed 13 months ago by Patrik Svestka

This works perfectly now. I'm closing this issue as it is now complete.

comment:7 Changed 13 months ago by Patrik Svestka

Resolution: fixed
Status: testingclosed

comment:8 Changed 4 months ago by Patrik Svestka

Resolution: fixed
Status: closedreopened

A regression happened with the top most functionality. The Mini test Runner does not stay above all windows atat Windows 10 1703 (OS build 15063.1387).

Note: See TracTickets for help on using tickets.