Faculty of Information Technology
Software Engineering Group

Opened 16 months ago

Closed 7 months ago

#176 closed defect (fixed)

[Windows-only] SmallSense unusable when autoraise feature turn-on

Reported by: Patrik Svestka Owned by:
Priority: major Milestone: 8.0.0
Component: default Keywords:
Cc: Also affects CVS HEAD (eXept version): no

Description

SmallSense? is practically unusable when having windows auto-raise turn-on.

The issue is that the code suggestion window appears but disappears when the focus changes via the mouse (automatically via auto-raise).

Nothing helps, you can move the mouse manually to the suggestion window, but the original window gets selected instead of it so you can not use the suggestion.

Attachments (13)

settings.stx (15.0 KB) - added by Patrik Svestka 13 months ago.
My settings file
autoraise_with_SmallSense.mp4 (685.2 KB) - added by Patrik Svestka 13 months ago.
Issues with autoraise window feature turned on and using SmallSense?
libwidg_fix_1_of_1_rev_52dc9c4dc482_Issue__176__do_not_close_completion_view_on_editor_focus_lost_event.patch (2.5 KB) - added by Jan Vrany 12 months ago.
smallsense_giving_wrong_results.mp4 (2.4 MB) - added by Patrik Svestka 12 months ago.
SmallSense? giving wrong restults at the start
autoraise_properties_from_rubymine_where_it_works.7z (314.4 KB) - added by Patrik Svestka 12 months ago.
properties of rubymine rubysense pop-up window which works
smallsense_fix_1_of_1_rev_031924a79f90_Issue__176__fix_handling_of_keyboard_events_when_completion_view_has_focus_.patch (2.1 KB) - added by Jan Vrany 11 months ago.
Fix for keyboard issues including the Escape key handling
autoraise_still_having_issues_20180124_slow.mp4 (2.4 MB) - added by Patrik Svestka 11 months ago.
Showing autoraise still having some issues when both keyboard and mouse are used
autoraise_still_having_issues_20180125.mp4 (2.6 MB) - added by Patrik Svestka 11 months ago.
New issues with both patches applied
smallsense_fix_1_of_1_rev_11647b544ea4_Issue__176__fix__disappearing__completon_view_when_pointer_moves_out_of_it.patch (1.6 KB) - added by Jan Vrany 10 months ago.
persistent_pop_up_and_inconsistent_popup.mp4 (1.3 MB) - added by Patrik Svestka 10 months ago.
persistent and inconsisten popup
smallsense_fix_1_of_1_rev_ba0bfcd8ab18_Issue__176__fix__disappearing__completon_view_when_pointer_moves_out_of_it.patch (2.7 KB) - added by Jan Vrany 9 months ago.
smallsense_fix_1_of_1_rev_b6dbdc4fd7f5_Issue__176__fix__disappearing__completon_view_when_pointer_moves_out_of_it.patch (4.2 KB) - added by Jan Vrany 8 months ago.
menu_beneath_the_design_application_window.png (132.5 KB) - added by Patrik Svestka 8 months ago.

Change History (37)

Changed 13 months ago by Patrik Svestka

Attachment: settings.stx added

My settings file

comment:1 Changed 13 months ago by Patrik Svestka

Milestone: 8.0.0

Changed 13 months ago by Patrik Svestka

Issues with autoraise window feature turned on and using SmallSense?

comment:2 Changed 12 months ago by Jan Vrany

Status: newtesting

comment:3 Changed 12 months ago by Patrik Svestka

There are good parts of the patch and bad parts of the patch.

The good part: the autoraise does not close when mouse is not over it.

The bad part: the SmallSense? functionality, in my eyes, does not work as it should. I'll give an example: When I type Smalltalk version @Workspace. When I start typing *Small* the SmallSense? picks it up. The issue is when I continue typing.

The SmallSense? then considers further typing as new keyword and is searching completely out-of-line. What is weird is its inconsistent behaviour. Sometimes SmallSense? does not start at all, sometimes it starts working from one point on. I'll attach a video for better understanding.

The pop-up window now does not at all react to ESC key.

Last edited 12 months ago by Patrik Svestka (previous) (diff)

comment:4 Changed 12 months ago by Patrik Svestka

Status: testingneeds_work

Changed 12 months ago by Patrik Svestka

SmallSense? giving wrong restults at the start

Changed 12 months ago by Patrik Svestka

properties of rubymine rubysense pop-up window which works

Changed 11 months ago by Jan Vrany

Fix for keyboard issues including the Escape key handling

comment:5 Changed 11 months ago by Jan Vrany

Status: needs_worktesting

Last patch should fix the (annoying) problem with Escape plus few other keyboard problems.

Not sure whether it fixes what you demonstrated in the second video, but may well so. Please let me know.

comment:6 Changed 11 months ago by Patrik Svestka

I have tested the patch and still found some issues.

First what has been fixed: the ESC now works perfectly.

What works sometime:

The TAB key used for completion. Sometime it works perfectly and as you will see later on the screen cast it suddenly stops working. The pop-up window gets black, probably gets the event, but does not fill the suggested code.

The SmallSense? pop-up window works when only keys are used for completion. When the user starts using mouse, just moving over the pop-up window, the SmallSense? pop-up window starts closing again without any reason. Maybe this action is also connected to the TAB key and its malfunction.

Changed 11 months ago by Patrik Svestka

Showing autoraise still having some issues when both keyboard and mouse are used

comment:7 Changed 11 months ago by Patrik Svestka

Status: testingneeds_work

comment:8 Changed 11 months ago by Jan Vrany

Patrik, looking at the video, are you sure you have both patches applied:

  1. libwidg_fix_1_of_1_rev_52dc9c4dc482_Issue__176__do_not_close_completion_view_on_editor_focus_lost_event.patch
  2. smallsense_fix_1_of_1_rev_031924a79f90_Issue__176__fix_handling_of_keyboard_events_when_completion_view_has_focus_.patch

You need both. The first once fixes the problem of "disappearing" completion view if it happens to popup under cursor, which seems to be happening on the second video.

comment:9 Changed 11 months ago by Patrik Svestka

Jan, you were probably right about the patches - I have applied last time only the SmallSense? patch as I somehow thought that the previous one is already included.

It now behaves differently when I have applied both patches. The issues with the window appearing and disappearing is mostly gone now (only when moving the mouse out of active pop-up it disappears).

Most of these comments are already in the video but I want to leave a summery here too:

  • The TAB key is definitely acting strangely.
  • Left clicking with mouse on the suggesting does not do anything.
  • sometimes the suggestion pop-up window does not appear at all
  • What I find strange is that the text typed is sometimes selected and sometimes not.

I hope I did not forget anything.

Last edited 11 months ago by Patrik Svestka (previous) (diff)

Changed 11 months ago by Patrik Svestka

New issues with both patches applied

comment:10 Changed 11 months ago by Patrik Svestka

I wanted to make sure that I have both patches applied so I have also checked it from Powershell.

It appears that the --no-commit flag works correctly as expected:

PS C:\prg_sdk\stx_8\stx-8.0.0\build\stx\libwidg> hg status | sls -Pattern ^M.*

M EditTextView.st
M EditTextViewCompletionSupport.st


PS C:\prg_sdk\stx_8\stx-8.0.0\build\stx\libwidg> cd C:\prg_sdk\stx_8\stx-8.0.0\build\stx\goodies\smallsense
PS C:\prg_sdk\stx_8\stx-8.0.0\build\stx\goodies\smallsense> hg status | sls -Pattern ^M.*

M SmallSense__CompletionController.st
M SmallSense__CompletionView.st
Last edited 11 months ago by Patrik Svestka (previous) (diff)

comment:11 Changed 11 months ago by Jan Vrany

Looking at the video at 0:34: just like in bash (for instance), tab complete longest unambiguous string. In this case, when ver is typed, it cannot complete anything since list contains version and verbose. Hence it flashes the completion view, just like bash.

comment:12 Changed 11 months ago by Patrik Svestka

The issue is not that it does that, that is actually nice feature. The issue is that it does not do it consistently. The ver is selected only sometimes. I did not yet see a pattern there.

comment:13 Changed 10 months ago by Jan Vrany

I watched the video again and I think we're mixing multiple different problems together. We should keep this small and focused. This is how
I see it;

  1. 0:17 single-left click does not work since this was never implemented. Please open a new 'TODO' ticket for this. Double clock should work, though.
  2. 0:35 tab seems to work as intended. If there's a case when it does not, we need to isolate that case first. Please open a new issue once you manage to isolate a reproducible case.
  3. 1:16 Disappearing completion list when you move pointer out of list is definitely within scope of this issue. Will fix.
  4. 1:27 No completion window is definitely within scope of this issue. Will fix.
  5. 2:05 This is I believe the same as above. Will fix.

Hope it makes sense.

comment:15 Changed 10 months ago by Patrik Svestka

I have applied all 3 above mentioned patches. It works better, but there appears to be still some glitches:

1) pop-up window remains active even when the main window is covered by other window (from different application)

2) pop-up window stays on even when the main window moves around

3) pop-up window disappears when mouse cursor goes to another StX window like launcher. It, however, stays on when cursor is moved to other non-StX window. What is correct behavior? It should be consistent in any case. In my personal opinion, the pop-up should stay on when no action is done on window where the pop-up window appeared.

Changed 10 months ago by Patrik Svestka

persistent and inconsisten popup

comment:16 Changed 10 months ago by Patrik Svestka

Status: testingneeds_work

comment:17 Changed 9 months ago by Jan Vrany

Status: needs_worktesting

Hi, could you try another patch:

INSTEAD of the last one (11647b544ea4)?

Let's keep this open for a while an test the last patch in real life to see how it works (or not). Will do the same on Linux.

comment:19 Changed 8 months ago by Jan Vrany

Hmm...the last patch ba0bfcd8ab18 is no good on Linux, one cannot continue typing if pointer is on completion view - extremely annoying.

comment:20 Changed 8 months ago by Jan Vrany

Hi, please try another one instead of ba0bfcd8ab18:

This one fixes the problem on Linux while should preserve behavior on Windows. Please, use it for a while and let me know of any issues.

comment:21 Changed 8 months ago by Patrik Svestka

When "designing" a new application and right-clicking on the widget (within designer window) the menu is now below the window which makes it hard to use (see the screenshot).


(Perhaps the reason is the window being always on top as written at ticket #210)

Last edited 8 months ago by Patrik Svestka (previous) (diff)

Changed 8 months ago by Patrik Svestka

comment:22 Changed 7 months ago by Jan Vrany

Patrik, I cannot reproduce the problem you show in above.

comment:23 Changed 7 months ago by Patrik Svestka

Eh, weird things happen. I can not reproduce it any more too. I'll close the issue.

comment:24 Changed 7 months ago by Patrik Svestka

Resolution: fixed
Status: testingclosed
Note: See TracTickets for help on using tickets.