Faculty of Information Technology
Software Engineering Group

Opened 13 months ago

Closed 5 months ago

#185 closed defect (fixed)

MEM [error] (17-12-04 10:46:07): tried to mark strange object: 24efe30 in 24ef900(1)

Reported by: Patrik Svestka Owned by:
Priority: critical Milestone: 8.0.0
Component: default Keywords:
Cc: Also affects CVS HEAD (eXept version): no

Description

An VM error occured when running StX 8.0.0:

VM dump 1497
VM [dump object]:24ef900 
|  class:7fff0b48 (Context)
|  size:136   flags:0x0 ()   space:0xf0 (
STACK)
|  c_flags:10014001 (800a000) (METHOD_VALID ) na=0 nv=5 nt=0
|  sender:0x24efe30 (*** invalid ***)
|  home:0x0 
(nil)
|  receiver:0x804bea38 (Smalltalk class)
|  selector:0x20021878 
(Symbol: #start) #start
|  search:0x804be9f0 
(Metaclass)
|  line:0x2040b 
(Integer: 66053)
|  ret:0x0 (nil)
|  handle:0
|  method:0x804c8130 
(Method)
|  local 0:0x1 (Integer: 0)
|  local 1:0x1ffe6c00 
(true)
|  local 2:0x0 (nil)
|  local 3:0x1ffe6c00 
(true)
|  local 4:0x1ffe6c18 
(false)
done
VM dump 1497

VM [dump object]:24efe30 
Object [info] (2017-12-04 14:43:54.192): recursionInterrupt from:


[[INVALID]] VM [info]: dumpObject 24efe30 - an invalid object
VM [info]: soft stackLimit reached - interrupt (limit=35838050 stack=35837dec)

|

Attachments (1)

settings.stx (15.0 KB) - added by Patrik Svestka 13 months ago.
My settings file

Download all attachments as: .zip

Change History (4)

comment:1 Changed 13 months ago by Patrik Svestka

librun version:

#define BUILD_DATE "Sun Nov 26 09:34:35 MET  2017"
#define BUILD_NUMBER "138"

Changed 13 months ago by Patrik Svestka

Attachment: settings.stx added

My settings file

comment:2 Changed 11 months ago by Jan Vrany

Status: newtesting

It seems that the problem is no longer reproducible with recent versions of librun. It could be that some other fixes fixed this issue too.

After a discussion with Patrik we decided to put it to "testing" phase and if it would not reappear during testing period of 8.0.0, we will close it (and eventually reopen it if it bites us again).

comment:3 Changed 5 months ago by Jan Vrany

Resolution: fixed
Status: testingclosed

Closed for it could not be reproduced for a long time.

Note: See TracTickets for help on using tickets.