Faculty of Information Technology
Software Engineering Group

Opened 16 months ago

Last modified 16 months ago

#222 reopened todo

Switching view Category to Package should focus on the "main" package

Reported by: Patrik Svestka Owned by:
Priority: major Milestone:
Component: default Keywords:
Cc: Also affects CVS HEAD (eXept version): no

Description (last modified by Patrik Svestka)

How to reproduce the error?

  1. Open a browser (default is a Category view)
  2. Search for a selector via ctrl + shift + t e.g.asCollectionOfSubCollectionsSeparatedByAnyForWhich
  3. Then switch to View\Package
  4. The first selected line is on Monticello but should be on libbasic

Here is a screenshot:


Attachments (1)

multiple_packages_selected_after_search.png (241.0 KB) - added by Patrik Svestka 16 months ago.

Download all attachments as: .zip

Change History (6)

Changed 16 months ago by Patrik Svestka

comment:1 Changed 16 months ago by Jan Vrany

Resolution: invalid
Status: newclosed

Why there are multiple packages...

This is because selected class (SequencableCollection in this case) has methods in all four packages. The reason is the following: when you're in category view you see all methods (of the given class) in all packages. Now when you switch to package view, you have to select all those packages in order to keep the list of the methods same (i.e., with same contents).

If you'd select only the package of currently selected methods, methods from other package would disapper, which would be confusing too. I'd argue current behavior is better (meaning "less confusing").

comment:2 Changed 16 months ago by Patrik Svestka

Resolution: invalid
Status: closedreopened

comment:3 Changed 16 months ago by Patrik Svestka

Description: modified (diff)
Summary: Switching view Category to Package does not reflect the reality of method searchSwitching view Category to Package should focus on the "main" package
Type: defecttodo

comment:4 Changed 16 months ago by Patrik Svestka

Description: modified (diff)

comment:5 Changed 16 months ago by Patrik Svestka

TODO:
The user should always see the libbasic package in the package view. If the window is small only monticello is displayed.

Note: See TracTickets for help on using tickets.