Faculty of Information Technology
Software Engineering Group

Opened 6 weeks ago

Closed 6 weeks ago

#251 closed defect (invalid)

Problems displaying UTF-16 characters

Reported by: Patrik Svestka Owned by:
Priority: major Milestone:
Component: default Keywords:
Cc: Also affects CVS HEAD (eXept version): no

Description

This maybe connected to the issue #126 (perphaps some settings interact with it.

When you paste the UTF-16 string like to a method or Workspace:

'Testing Unicode chars: ř ž č ルすしかき'

The only partical text is displayed:

Right after paste:

Text displayed right after pasting

After pressing home/end few times:

Pressing home end few times

Attachments (2)

after_pressing_home_end.png (23.3 KB) - added by Patrik Svestka 6 weeks ago.
Pressing home end few times
right_after_paste.png (14.9 KB) - added by Patrik Svestka 6 weeks ago.
Text displayed right after pasting

Download all attachments as: .zip

Change History (5)

Changed 6 weeks ago by Patrik Svestka

Attachment: after_pressing_home_end.png added

Pressing home end few times

Changed 6 weeks ago by Patrik Svestka

Attachment: right_after_paste.png added

Text displayed right after pasting

comment:1 Changed 6 weeks ago by Patrik Svestka

It appears to be a problem of the particular font Source code pro. This is a TrueType? font created by Adobe - https://github.com/adobe-fonts/source-code-pro.

This is my favourite font now, I'll try to investigate the issue further.

comment:2 Changed 6 weeks ago by Patrik Svestka

The issue is definitely font issue! I'm glad that it is not a bug.

There appears to be a bug with, probably an OTF fonts. If I want to setup it directly I see only one size 30pt (for Source Code pro). If I click on TTF font like Times New Roman, where I see all sizes and click back to the Source Code pro I will see all sizes. I'll open a separate ticket on this one, when I understand the pattern.

Some interesting font comparisons:

Source Han Sans vs Source Sans Pro & Source Code Pro
https://blogs.adobe.com/CCJKType/2015/01/shs-vs-ssp-and-scp.html

OTF vs TTF
http://www.differencebetween.net/technology/difference-between-ttf-and-otf/

Last edited 6 weeks ago by Patrik Svestka (previous) (diff)

comment:3 Changed 6 weeks ago by Patrik Svestka

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.