Faculty of Information Technology
Software Engineering Group

Opened 4 years ago

Closed 4 years ago

#31 closed defect (fixed)

startup error - NoHandlerError: Depth8Image does not understand: #isViewBackground

Reported by: nesvejak Owned by:
Priority: major Milestone:
Component: default Keywords:
Cc: Also affects CVS HEAD (eXept version): no

Description

Evironment: Ubuntu 12.04 LTS, x86

When trying to run stx by bin/stx (build 1106) then following error occurs in the console:

splash.rc [info] displaying splash screen
NoHandlerError?: Depth8Image does not understand: #isViewBackground
process: id=0 name=scheduler
context: Depth8Image(Object) >> doesNotUnderstand: [0]

......: Depth8Image(NONE) >> isViewBackground [26]
......: PopUpBanner?(DisplaySurface?) >> setViewBackground [26]
......: PopUpBanner?(SimpleView?) >> create [44]
......: PopUpBanner?(PopUpView?) >> create [2]
......: [ intermediate recursive contexts skipped ]
......: PopUpBanner?(PopUpView?) >> create [2]
......: PopUpBanner?(SimpleView?) >> raise [10]
......: PopUpBanner?(PopUpView?) >> realize [3]
......: PopUpBanner? >> open [15]
......: PopUpBanner?(PopUpView?) >> showAt:resizing: [9]
......: PopUpBanner?(PopUpView?) >> showAt: [4]
......: PopUpBanner? >> showCentered [3]
......: [] in UndefinedObject?>>doIt >> value [27]
......: UndefinedObject?(DIRECTED) >> doIt [34]
......: Method(CompiledCode?) >> valueWithReceiver:arguments:selector:search:sender: [17]
......: [] in Parser>>evaluate:in:receiver:notifying:logged:ifFail:compile:checkForEndOfInput: >> value [194]
......: QuerySignal? >> answer:do: [10]
......: [] in Parser>>evaluate:in:receiver:notifying:logged:ifFail:compile:checkForEndOfInput: >> value [120]
......: UndefinedVariableError? class(GenericException? class) >> handle:do: [14]
......: ByteCodeCompiler?(Parser) >> evaluate:in:receiver:notifying:logged:ifFail:compile:checkForEndOfInput: [113]
......: ByteCodeCompiler?(Parser) >> evaluate:notifying: [3]
......: EncodedStream?(PeekableStream?) >> fileInNextChunkNotifying:passChunk:silent: [37]
......: EncodedStream?(PeekableStream?) >> fileInNextChunkNotifying:passChunk: [14]
......: [] in EncodedStream?>>basicFileInNotifying:passChunk: >> value [146]
......: SignalSet? >> handle:do: [14]
......: EncodedStream? >> basicFileInNotifying:passChunk: [100]
......: EncodedStream?(PeekableStream?) >> fileInNotifying:passChunk: [6]
......: [] in PeekableStream?>>fileIn >> value [14]
......: QuerySignal?(Signal) >> handle:do: [14]
......: EncodedStream?(PeekableStream?) >> fileIn [11]
......: SmalltalkChunkFileSourceReader? >> fileInStream: [2]
......: SmalltalkChunkFileSourceReader? class(AbstractSourceFileReader? class) >> fileInStream: [3]
......: [ intermediate recursive contexts skipped ]
......: SmalltalkChunkFileSourceReader? class(AbstractSourceFileReader? class) >> fileInStream: [3]
......: SmalltalkLanguage?(ProgrammingLanguage?) >> fileInStream: [3]
......: [ intermediate recursive contexts skipped ]
......: SmalltalkLanguage?(ProgrammingLanguage?) >> fileInStream: [3]
......: [] in Smalltalk class>>fileInStream:lazy:silent:logged:addPath: >> value [37]
......: SignalSet? >> answer:do: [10]
......: [] in Smalltalk class>>fileInStream:lazy:silent:logged:addPath: >> value [33]
......: Block >> ensure: [11]
......: Smalltalk class >> fileInStream:lazy:silent:logged:addPath: [39]
......: Smalltalk class >> fileIn:lazy:silent:logged: [60]
......: Smalltalk class >> fileIn: [10]
......: [] in UndefinedObject?>>doIt >> value [58]
......: UndefinedObject?(DIRECTED) >> doIt [96]
......: Method(CompiledCode?) >> valueWithReceiver:arguments:selector:search:sender: [17]
......: [] in Parser>>evaluate:in:receiver:notifying:logged:ifFail:compile:checkForEndOfInput: >> value [194]
......: QuerySignal? >> answer:do: [10]
......: [] in Parser>>evaluate:in:receiver:notifying:logged:ifFail:compile:checkForEndOfInput: >> value [120]
......: UndefinedVariableError? class(GenericException? class) >> handle:do: [14]
......: ByteCodeCompiler?(Parser) >> evaluate:in:receiver:notifying:logged:ifFail:compile:checkForEndOfInput: [113]
......: ByteCodeCompiler?(Parser) >> evaluate:notifying: [3]
......: EncodedStream?(PeekableStream?) >> fileInNextChunkNotifying:passChunk:silent: [37]
......: EncodedStream?(PeekableStream?) >> fileInNextChunkNotifying:passChunk: [14]
......: [] in EncodedStream?>>basicFileInNotifying:passChunk: >> value [146]
......: SignalSet? >> handle:do: [14]
......: EncodedStream? >> basicFileInNotifying:passChunk: [100]
......: EncodedStream?(PeekableStream?) >> fileInNotifying:passChunk: [6]
......: [] in PeekableStream?>>fileIn >> value [14]
......: QuerySignal?(Signal) >> handle:do: [14]
......: EncodedStream?(PeekableStream?) >> fileIn [11]
......: SmalltalkChunkFileSourceReader? >> fileInStream: [2]
......: SmalltalkChunkFileSourceReader? class(AbstractSourceFileReader? class) >> fileInStream: [3]
......: [ intermediate recursive contexts skipped ]
......: SmalltalkChunkFileSourceReader? class(AbstractSourceFileReader? class) >> fileInStream: [3]
......: SmalltalkLanguage?(ProgrammingLanguage?) >> fileInStream: [3]
......: [ intermediate recursive contexts skipped ]
......: SmalltalkLanguage?(ProgrammingLanguage?) >> fileInStream: [3]
......: [] in Smalltalk class>>fileInStream:lazy:silent:logged:addPath: >> value [37]
......: SignalSet? >> answer:do: [10]
......: [] in Smalltalk class>>fileInStream:lazy:silent:logged:addPath: >> value [33]
......: Block >> ensure: [11]
......: Smalltalk class >> fileInStream:lazy:silent:logged:addPath: [39]
......: Smalltalk class >> fileIn:lazy:silent:logged: [60]
......: Smalltalk class >> fileIn: [10]
......: UndefinedObject?(DIRECTED) >> doIt [6]
......: Method(CompiledCode?) >> valueWithReceiver:arguments:selector:search:sender: [17]
......: [] in Parser>>evaluate:in:receiver:notifying:logged:ifFail:compile:checkForEndOfInput: >> value [194]
......: QuerySignal? >> answer:do: [10]
......: [] in Parser>>evaluate:in:receiver:notifying:logged:ifFail:compile:checkForEndOfInput: >> value [120]
......: UndefinedVariableError? class(GenericException? class) >> handle:do: [14]
......: ByteCodeCompiler?(Parser) >> evaluate:in:receiver:notifying:logged:ifFail:compile:checkForEndOfInput: [113]
......: ByteCodeCompiler?(Parser) >> evaluate:notifying: [3]
......: EncodedStream?(PeekableStream?) >> fileInNextChunkNotifying:passChunk:silent: [37]
......: EncodedStream?(PeekableStream?) >> fileInNextChunkNotifying:passChunk: [14]
......: [] in EncodedStream?>>basicFileInNotifying:passChunk: >> value [146]
......: SignalSet? >> handle:do: [14]
......: EncodedStream? >> basicFileInNotifying:passChunk: [100]
......: EncodedStream?(PeekableStream?) >> fileInNotifying:passChunk: [6]
......: [] in PeekableStream?>>fileIn >> value [14]
......: QuerySignal?(Signal) >> handle:do: [14]
......: EncodedStream?(PeekableStream?) >> fileIn [11]
......: SmalltalkChunkFileSourceReader? >> fileInStream: [2]
......: SmalltalkChunkFileSourceReader? class(AbstractSourceFileReader? class) >> fileInStream: [3]
......: [ intermediate recursive contexts skipped ]
......: SmalltalkChunkFileSourceReader? class(AbstractSourceFileReader? class) >> fileInStream: [3]
......: SmalltalkLanguage?(ProgrammingLanguage?) >> fileInStream: [3]
......: [ intermediate recursive contexts skipped ]
......: SmalltalkLanguage?(ProgrammingLanguage?) >> fileInStream: [3]
......: [] in Smalltalk class>>fileInStream:lazy:silent:logged:addPath: >> value [37]
......: SignalSet? >> answer:do: [10]
......: [] in Smalltalk class>>fileInStream:lazy:silent:logged:addPath: >> value [33]
......: Block >> ensure: [11]
......: Smalltalk class >> fileInStream:lazy:silent:logged:addPath: [39]
......: Smalltalk class >> fileIn:lazy:silent:logged: [60]
......: Smalltalk class >> fileIn: [10]
......: UndefinedObject?(DIRECTED) >> doIt [8]
......: Method(CompiledCode?) >> valueWithReceiver:arguments:selector:search:sender: [17]
......: [] in Parser>>evaluate:in:receiver:notifying:logged:ifFail:compile:checkForEndOfInput: >> value [194]
......: QuerySignal? >> answer:do: [10]
......: [] in Parser>>evaluate:in:receiver:notifying:logged:ifFail:compile:checkForEndOfInput: >> value [120]
......: UndefinedVariableError? class(GenericException? class) >> handle:do: [14]
......: ByteCodeCompiler?(Parser) >> evaluate:in:receiver:notifying:logged:ifFail:compile:checkForEndOfInput: [113]
......: ByteCodeCompiler?(Parser) >> evaluate:notifying: [3]
......: EncodedStream?(PeekableStream?) >> fileInNextChunkNotifying:passChunk:silent: [37]
......: EncodedStream?(PeekableStream?) >> fileInNextChunkNotifying:passChunk: [14]
......: [] in EncodedStream?>>basicFileInNotifying:passChunk: >> value [146]
......: SignalSet? >> handle:do: [14]
......: EncodedStream? >> basicFileInNotifying:passChunk: [100]
......: EncodedStream?(PeekableStream?) >> fileInNotifying:passChunk: [6]
......: [] in PeekableStream?>>fileIn >> value [14]
......: QuerySignal?(Signal) >> handle:do: [14]
......: EncodedStream?(PeekableStream?) >> fileIn [11]
......: SmalltalkChunkFileSourceReader? >> fileInStream: [2]
......: SmalltalkChunkFileSourceReader? class(AbstractSourceFileReader? class) >> fileInStream: [3]
......: [ intermediate recursive contexts skipped ]
......: SmalltalkChunkFileSourceReader? class(AbstractSourceFileReader? class) >> fileInStream: [3]
......: SmalltalkLanguage?(ProgrammingLanguage?) >> fileInStream: [3]
......: [ intermediate recursive contexts skipped ]
......: SmalltalkLanguage?(ProgrammingLanguage?) >> fileInStream: [3]
......: [] in Smalltalk class>>fileInStream:lazy:silent:logged:addPath: >> value [37]
......: SignalSet? >> answer:do: [10]
......: [] in Smalltalk class>>fileInStream:lazy:silent:logged:addPath: >> value [33]
......: Block >> ensure: [11]
......: Smalltalk class >> fileInStream:lazy:silent:logged:addPath: [39]
......: Smalltalk class >> fileIn:lazy:silent:logged: [60]
......: Smalltalk class >> fileIn: [10]
......: [] in Smalltalk class>>secureFileIn: >> value [14]
......: SignalSet? >> handle:do: [14]
......: Smalltalk class >> secureFileIn: [13]
......: [] in Smalltalk class>>start >> value [161]
......: [] in ClassDescription?>>withoutUpdatingChangesDo: >> value [9]
......: [ intermediate recursive contexts skipped ]
......: [] in ClassDescription?>>withoutUpdatingChangesDo: >> value [9]
......: SignalSet? >> answer:do: [10]
......: Class class(ClassDescription?) >> withoutUpdatingChangesDo: [7]
......: Smalltalk class >> start [19]
......: UndefinedObject? >> nil [0]
......: nil

Type "c" to proceed, "?" for help
MiniDebugger?>

Change History (1)

comment:1 Changed 4 years ago by Jan Vrany

Resolution: fixed
Status: newclosed

Fixed - caused by temporary instability in CVS

Note: See TracTickets for help on using tickets.