Faculty of Information Technology
Software Engineering Group

#76 closed defect (worksforme)

Test Runner Tool window appears from nowhere

Reported by: Patrik Svestka Owned by: vranyj1
Priority: major Milestone:
Component: VM support Keywords:
Cc: Also affects CVS HEAD (eXept version): no

Description

When SmalltalkX app is started, it starts also a Test Runner Tool window 5x times which shows only empty screen. Now a new thing - the last 'Test Runner Tool' window is impossible to close. does not react to any event - and it freezes the whole environment.

The StX version:
smalltalkx-jv-branch-6.2.5_x86_64-win32.zip.
Smalltalk versionString -> '6.2.5.2046'

The output of the application when it got killed by the system.

IMG [warning]: Warning: cannot stat stx-bin.com (not in PATH ?)
IMG [info]: executable and/or shared libraries changed address(es).
IMG [info]: updating cached function pointers.
Processor [info]: timeslicer started
Smalltalk [info]: startup process 1 active.
NoHandlerError?: UndefinedObject? does not understand: #isModal
process: id=8 name=event dispatcher (local)
context: UndefinedObject?(Object) >> doesNotUnderstand: [16]

......: UndefinedObject?(NONE) >> isModal [7]
......: ApplicationWindow?(TopView?) >> startWindowMoveOnButtonPress [7]
......: ApplicationWindow?(SimpleView?) >> buttonPress:x:y: [14]
......: ApplicationWindow?(Object) >> perform:withArguments: [169]
......: ApplicationWindow?(DisplaySurface?) >> dispatchEvent:type:arguments:withF

ocusOn:delegate: [236]

......: ApplicationWindow?(DisplaySurface?) >> dispatchEvent:withFocusOn:delegate

: [5]

......: ApplicationWindow?(DisplaySurface?) >> dispatchEvent: [5]
......: [] in SynchronousWindowSensor?>>basicPushEvent: >> value [8]
......: WindowGroup::LastEventQuery? class(Notification class) >> answer:do: [10

]

......: SynchronousWindowSensor? >> basicPushEvent: [7]
......: SynchronousWindowSensor?(WindowSensor?) >> pushEvent: [18]
......: SynchronousWindowSensor?(WindowSensor?) >> buttonPress:x:y:view: [18]
......: WinWorkstation?(DeviceWorkstation?) >> buttonPress:x:y:view: [27]
......: [ intermediate recursive contexts skipped ]
......: WinWorkstation?(DeviceWorkstation?) >> buttonPress:x:y:view: [27]
......: WinWorkstation? >> dispatchLastEvent [0]
......: [] in WinWorkstation?>>dispatchPendingEvents >> value [15]
......: AbortOperationRequest? class(GenericException? class) >> handle:do: [14]
......: WinWorkstation? >> dispatchPendingEvents [12]
......: [] in DeviceWorkstation?>>dispatchLoop >> value [26]
......: AbortAllOperationRequest? class(GenericException? class) >> handle:do: [1

4]

......: WinWorkstation?(DeviceWorkstation?) >> dispatchLoop [6]
......: [] in DeviceWorkstation?>>setupDispatchLoop >> value [48]
......: Block >> ifCurtailed: [14]
......: [] in DeviceWorkstation?>>setupDispatchLoop >> value [49]
......: Signal >> handle:do: [14]
......: WinWorkstation?(DeviceWorkstation?) >> setupDispatchLoop [30]
......: [] in DeviceWorkstation?>>startDispatch >> value [14]
......: ExceptionHandlerSet? >> handleDo: [14]
......: [] in Process>>start >> value [35]
......: SignalSet? >> handle:do: [14]
......: [] in Process>>start >> value [23]
......: Block >> ensure: [12]
......: Process >> start [37]
......: UndefinedObject? >> nil [0]
......: nil

Type "c" to proceed, "?" for help
MiniDebugger?>

Attachments (1)

testRunnerTool.jpg (34.6 KB) - added by Patrik Svestka 18 months ago.
The Test runner tools windows - blank and start after while

Download all attachments as: .zip

Change History (8)

Changed 18 months ago by Patrik Svestka

Attachment: testRunnerTool.jpg added

The Test runner tools windows - blank and start after while

comment:1 Changed 18 months ago by Patrik Svestka

Component: stx:libjavaVM support

comment:3 Changed 17 months ago by Jan Vrany

Also affects CVS HEAD (eXept version): unset

I cannot reproduce this, but:

This

IMG [info]: executable and/or shared libraries changed address(es).
IMG [info]: updating cached function pointers.

suggests you're restarting St/X from a snapshot. This may well be broken (I personally don't save images so I won't notice).
The problem may be two-fold:

  • VM might be broken (especially after switching to MINGW compiler under Windows)
  • The separated-gc code might be broken w.r.t restarting from a snapshot.

I'll need to have a closer look and fix some - likely unrelated - problems in the VM first. Meanwhile, start Smalltalk/X from scratch by

stx.bat -I --quick

That's how I start it. For the code, either file it out or - better - commit it to repository.

comment:4 Changed 17 months ago by Patrik Svestka

stx.bat -I --quick

This works well, the only thing is that I'm getting this warning when started.

smalltalk.rc [warning]: error while filing in 'patches' - some patches have not
been loaded!

comment:5 in reply to:  4 Changed 17 months ago by Jan Vrany

smalltalk.rc [warning]: error while filing in 'patches' - some patches have not
been loaded!

This should be fixed by now (packaging problem, but should not harm as there are no patches anyway)


FYI: I have tried to reproduce the bug but now it seems that restarting from an image somewhat works. I have fixed some issues, but they were Linux / X11 related:

I have also fixed a performance problem in VM regarding snapshot restart by optimizing various lookups. On my system it is 4 times faster then before. Yeah, CS lectures seems to pay off :-)

Could you try with some recent build to save a snapshot and then restart if the same problem happens again? You may restart from snapshot by

stx.bat -i snapshot.img

NOTE: lowercase -i, uppercase -I means ignore any image.

Could it be that the windows got somehow broken before you saved an image?

Last edited 17 months ago by Jan Vrany (previous) (diff)

comment:6 Changed 17 months ago by Patrik Svestka

I confirm the speed. Now it is WAY faster than before, since I did not measure it before I don't have objective criteria but the feel is definitely there.

I'm loading the image via (it is working correctly)

stx.bat --image stx.img

"Could it be that the windows got somehow broken before you saved an image?"
I remember only running the Test Runner Tool and closed it afterwards but nothing went visibly broken.

p.s. What is the CS in the "CS lectures"? ;)

comment:7 in reply to:  6 Changed 17 months ago by Jan Vrany

Resolution: worksforme
Status: newclosed

Replying to patrik.svestka@…:

I remember only running the Test Runner Tool and closed it afterwards but nothing went visibly broken.

I cannot reproduce it. I'm closing this issue - if this happens again, please reopen.

p.s. What is the CS in the "CS lectures"? ;)

Computer Science

Note: See TracTickets for help on using tickets.