Faculty of Information Technology
Software Engineering Group

#78 closed defect (fixed)

Getting an error when trying to use MenuBar element in Menu tab in widget

Reported by: Patrik Svestka Owned by: vranyj1
Priority: minor Milestone:
Component: default Keywords:
Cc: Also affects CVS HEAD (eXept version): yes

Description

Getting an error message:
MenuPanel::Item [error]: application (a UISelectionPanel) does not provide aspect: imageIsLoaded (in saveMethod) when clicking on MenuBar? item.

Change History (4)

comment:2 Changed 19 months ago by Jan Vrany

Also affects CVS HEAD (eXept version): set
Component: VM supportdefault
Status: newtesting

The problem is actually only the (confusing) message which should not be shown
in this case, i.e., when building a menu for UIPainter/UISelectionDialog.

228412f59c2c/stx.libwidg2 should fix it, i.e., suppress the message in UI painter code.
The commit will be included in jenkins build #2085 and later.

comment:3 Changed 19 months ago by Patrik Svestka

The patch itself is working correctly.

The is only one mistake in the comment ;):
/ The isKinfOf: below is a super ugly, whip me hard,

isKinfOf => isKindOf code is correct (no whipping thou)

comment:4 Changed 19 months ago by Jan Vrany

Resolution: fixed
Status: testingclosed
Note: See TracTickets for help on using tickets.