Faculty of Information Technology
Software Engineering Group

Opened 3 years ago

Closed 12 months ago

#80 closed defect (fixed)

Language setting is not preserved

Reported by: Jan Vrany Owned by:
Priority: major Milestone:
Component: default Keywords:
Cc: Also affects CVS HEAD (eXept version): yes

Description

...even when set in user preferences. Steps to reproduce:

  1. Start fresh St/X (-I option)
  2. Pick menu to System"" -> Settings..., then go to Language settings and change it
  3. Save settings
  4. Start fresh St/X again

It should come up and use the language set in step 2.

Change History (5)

comment:1 Changed 22 months ago by Patrik Svestka

This looks like it works now, if you uncheck the checkbox Use OS Language on Startup and save the settings. Could you confirm it too?

comment:2 in reply to:  1 Changed 13 months ago by Jan Vrany

Replying to Patrik Svestka:

This looks like it works now, if you uncheck the checkbox Use OS Language on Startup and save the settings. Could you confirm it too?

Yes, that worked too. The problem was that this was not so obvious :-)

comment:3 Changed 13 months ago by Jan Vrany

Status: newtesting

While it actually worked, the UI was hard to understand (hence this report and other reports off this tracker). To address this, the settings UI has been cleaned up to make it simpler.

Moreover, the default settings have been changed to ignore system locale an use Ennlish (US). In
my observation, most programmers prefer English and besides, translations to other languages are
so incomplete so that the UX is far from good.

As a side effect, language/locale initialization has been cleaned up so that there's no longer a global variable holding the language / region - code should always consult preferences.

In particular, this issue has been addressed by:

Note that the above fixes are in 8.0.0 branch only and won't be back-ported to 6.x.x (8.0.0 will be released soon(tm), I hope)

comment:4 Changed 12 months ago by Patrik Svestka

I have tested these languages: CZ, EN(US), DE, RU, SK. The resources are incomplete for the other languages than English, but that calls for volunteers. There are more urgent matters to attend.

Good job!

comment:5 Changed 12 months ago by Patrik Svestka

Resolution: fixed
Status: testingclosed
Note: See TracTickets for help on using tickets.