Faculty of Information Technology
Software Engineering Group

Opened 10 years ago

Closed 8 years ago

#20 closed defect (fixed)

Java tests are broken

Reported by: Jan Vraný Owned by: hlopkmar
Priority: major Milestone: milestone:
Component: stx:libjava Keywords:
Cc: kursjan

Description

Two Java tests are broken:
stx.libjava.tests.log4j.Log4JTests and stx.libjava.tests.annotations.AnnotationTests

Steps to reproduce:

  1. Load libjava and initialize VM
  2. Run JavaJUnitTests >> testLog4J and JavaJUnitTests >> testJunitAnnotations

They should pass by they fail.

It seems that Log4J never passed since there are some missing native methods. But they looks trivial to implement...

The annotation test would require bit more debugging...

Change History (4)

comment:1 Changed 10 years ago by hlopkmar

Status: newaccepted

I tried to debug annotation tests and I believe that raw annotations are not set for java fields.. Is it possible?

comment:2 Changed 10 years ago by hlopkmar

Annotations fixed, problem with log4j.
Steps to reproduce:
Load java and execute:

UnixOperatingSystem executeCommand: ('ant -f ' , ((Smalltalk packageDirectoryForPackageId: 'stx:libjava') / 'java' / 'libjava-tests') pathName , '/build.xml').
Java addToClassPath: ((Smalltalk packageDirectoryForPackageId: 'stx:libjava') / 'java' / 'libjava-tests' / 'bin') pathName.
Java addToClassPath: '/usr/share/java/junit4.jar'.
Java addToClassPath: '/usr/share/java/log4j-1.2.jar'.
(Java classForName: 'stx.libjava.tests.log4j.Log4JTests') main:#().

comment:3 Changed 9 years ago by Jan Vraný

Milestone: M1 - Maintenance

Milestone M1 - Maintenance deleted

comment:4 Changed 8 years ago by Jan Vraný

Resolution: fixed
Status: acceptedclosed
Note: See TracTickets for help on using tickets.