Faculty of Information Technology
Software Engineering Group

Opened 10 years ago

Closed 9 years ago

#29 closed defect (fixed)

Lookup VM Error

Reported by: kursjan Owned by: kursjan
Priority: major Milestone: milestone:
Component: VM support Keywords: VM, lookup
Cc:

Description

FileIn attached Regression Test file.

Execute following code:

RegressionTests::LookupCachingTests::ObjectSample setLookupObject: Lookup new.
ObjectMemory garbageCollect.
Delay forSeconds:1.
RegressionTests::LookupCachingTests::ObjectSample new perform: #n: withArguments: #(1).

Do it several times, until error occurs.

Attachments (1)

RegressionTests__LookupCachingTests.st (8.7 KB) - added by kursjan 10 years ago.

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by kursjan

comment:1 Changed 10 years ago by kursjan

RegressionTests::LookupCachingTests::ObjectSample setLookupObject: RegressionTests::LookupCachingTests::LookupNoCachingStub new.
ObjectMemory garbageCollect.
Delay forSeconds:1.
RegressionTests::LookupCachingTests::ObjectSample new perform: #n: withArguments: #(1).

IMHO error is not in the __ilcBind() function, because this code raise an exception as well. LookupNoCachingStub is an object which does not do any caching.

Last edited 10 years ago by kursjan (previous) (diff)

comment:2 Changed 10 years ago by kursjan

Seems there were an error in __SEND2 method. The wrong number of arguments was inserted to __externaMethodLookup method call.

comment:3 Changed 9 years ago by kursjan

Status: newtesting

comment:4 Changed 9 years ago by kursjan

Resolution: fixed
Status: testingclosed

Does not happen any more,...

Note: See TracTickets for help on using tickets.