Faculty of Information Technology
Software Engineering Group

Opened 7 years ago

Closed 7 years ago

#59 closed defect (fixed)

VM crash when running 50 threads

Reported by: Jan Vraný Owned by: Jan Vraný
Priority: major Milestone: milestone:
Component: VM support Keywords:
Cc:

Description

VM crashes when running Groovy 1+1 in 50 thread in parallel, usually because there are obsolete survivors somewhere.

With 100 parallel threads the VM crashes because it runs out of protect list.

Attachments (1)

bug_44_100_parallel_threads_evaluating_groovy.st (1.8 KB) - added by Jan Vraný 7 years ago.
Script to reproduce

Download all attachments as: .zip

Change History (5)

Changed 7 years ago by Jan Vraný

Script to reproduce

comment:1 Changed 7 years ago by Jan Vraný

Component: stx:libjavaVM support

comment:2 Changed 7 years ago by Jan Vraný

Sometimes also deadlocks. Class resolving is buggy with respect to threads...

comment:3 Changed 7 years ago by Jan Vraný

After class loading refactoring and cleanup (commit 83d32dc4fcea) the crash seems to be less likely even when using 75 threads (but still not rare!)

The deadlocks seem to be gone, never seen one since 83d32dc4fcea.

comment:4 Changed 7 years ago by Jan Vraný

Resolution: fixed
Status: newclosed

Fixed somewhere around f44a7499454b.

Note: See TracTickets for help on using tickets.