Faculty of Information Technology
Software Engineering Group

Opened 10 years ago

Closed 10 years ago

#7 closed defect (fixed)

Strange svn + class browser behavior

Reported by: hlopkmar Owned by: hlopkmar
Priority: major Milestone: milestone:
Component: stx:libjava Keywords:
Cc: Jan Vraný, kursjan

Description

  1. Download and unpack stx night build
  2. Be sure to delete old changes, working copies etc.
  3. Run stx
  4. execute Smalltalk loadPackage:'stx:libjava'.
  5. open class browser and find JavaVM::Reflection

What should you see:
methods
What do you see instead:
empty list

Working copy is ok, downloaded files are up to date at latest revision, class browser is just not showing them correctly.

Change History (2)

comment:1 Changed 10 years ago by Jan Vraný

Cc: kursjan added
Component: VM supportstx:libjava
Status: newtesting

Should be fixed in r905. The problem was caused by bug in JavaVM>>addSelector:withMethod:. It flushes java native method cache, but
the class JavaNativeMethod may be not loaded when this method is called during
file-in. Therefore a DNU is raised and the rest of the file was not loaded.

Please, test the r905 and close it if it works.

comment:2 Changed 10 years ago by Jan Vraný

Resolution: fixed
Status: testingclosed
Note: See TracTickets for help on using tickets.