Make.spec
changeset 27 45902cde2ab1
parent 21 a5d30403049c
child 32 326e2b5665e1
equal deleted inserted replaced
26:db19d89eef60 27:45902cde2ab1
     1 # $Header$
     1 # $Header$
     2 #
     2 #
     3 # DO NOT EDIT 
     3 # DO NOT EDIT 
     4 # automagically generated from the projectDefinition: stx_goodies_newcompiler.
     4 # automagically generated from the projectDefinition: cvut_stx_goodies_newcompiler.
     5 #
     5 #
     6 # Warning: once you modify this file, do not rerun
     6 # Warning: once you modify this file, do not rerun
     7 # stmkmp or projectDefinition-build again - otherwise, your changes are lost.
     7 # stmkmp or projectDefinition-build again - otherwise, your changes are lost.
     8 #
     8 #
     9 # This file contains specifications which are common to all platforms.
     9 # This file contains specifications which are common to all platforms.
    10 #
    10 #
    11 
    11 
    12 # Do NOT CHANGE THESE DEFINITIONS
    12 # Do NOT CHANGE THESE DEFINITIONS
    13 # (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
    13 # (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
    14 #  to find the source code of a class and to find the library for a package)
    14 #  to find the source code of a class and to find the library for a package)
    15 MODULE=stx
    15 MODULE=cvut
    16 MODULE_DIR=goodies/newcompiler
    16 MODULE_DIR=stx/goodies/newcompiler
    17 PACKAGE=$(MODULE):$(MODULE_DIR)
    17 PACKAGE=$(MODULE):$(MODULE_DIR)
    18 
    18 
    19 
    19 
    20 # Argument(s) to the stc compiler (stc --usage).
    20 # Argument(s) to the stc compiler (stc --usage).
    21 #  -H.         : create header files locally
    21 #  -H.         : create header files locally
    47 # STCWARNINGS=-warn
    47 # STCWARNINGS=-warn
    48 # STCWARNINGS=-warnNonStandard
    48 # STCWARNINGS=-warnNonStandard
    49 # STCWARNINGS=-warnEOLComments
    49 # STCWARNINGS=-warnEOLComments
    50 STCWARNINGS=-warnNonStandard
    50 STCWARNINGS=-warnNonStandard
    51 
    51 
       
    52 COMMON_CLASSES= \
       
    53 	IRBuilder \
       
    54 	IRBuilderTest \
       
    55 	IRBytecodeGenerator \
       
    56 	IRFunction \
       
    57 	IRInstruction \
       
    58 	IRInterpreter \
       
    59 	IRSequence \
       
    60 	IRStackCount \
       
    61 	IRTransformTest \
       
    62 	cvut_stx_goodies_newcompiler \
       
    63 	IRAccess \
       
    64 	IRClosure \
       
    65 	IRConstant \
       
    66 	IRDecompiler \
       
    67 	IRDup \
       
    68 	IRJump \
       
    69 	IRLine \
       
    70 	IRMethod \
       
    71 	IRPop \
       
    72 	IRPrinter \
       
    73 	IRReturn \
       
    74 	IRSend \
       
    75 	IRTranslator \
       
    76 	IRBlockReturnTop \
       
    77 	IRInstVarAccess \
       
    78 	IRJumpIf \
       
    79 	IRJumpOverBlock \
       
    80 	IRLiteralVariableAccess \
       
    81 	IRTempAccess \
       
    82 	IRInstVarRead \
       
    83 	IRInstVarStore \
       
    84 	IRLiteralVariableRead \
       
    85 	IRLiteralVariableStore \
       
    86 	IRTempRead \
       
    87 	IRTempStore \
       
    88 
       
    89 
       
    90 
       
    91 
    52 COMMON_OBJS= \
    92 COMMON_OBJS= \
    53     $(OUTDIR)IRBuilder.$(O) \
    93     $(OUTDIR)IRBuilder.$(O) \
       
    94     $(OUTDIR)IRBuilderTest.$(O) \
    54     $(OUTDIR)IRBytecodeGenerator.$(O) \
    95     $(OUTDIR)IRBytecodeGenerator.$(O) \
    55     $(OUTDIR)IRFunction.$(O) \
    96     $(OUTDIR)IRFunction.$(O) \
    56     $(OUTDIR)IRInstruction.$(O) \
    97     $(OUTDIR)IRInstruction.$(O) \
    57     $(OUTDIR)IRInterpreter.$(O) \
    98     $(OUTDIR)IRInterpreter.$(O) \
    58     $(OUTDIR)IRSequence.$(O) \
    99     $(OUTDIR)IRSequence.$(O) \
    59     $(OUTDIR)IRStackCount.$(O) \
   100     $(OUTDIR)IRStackCount.$(O) \
    60     $(OUTDIR)stx_goodies_newcompiler.$(O) \
   101     $(OUTDIR)IRTransformTest.$(O) \
       
   102     $(OUTDIR)cvut_stx_goodies_newcompiler.$(O) \
    61     $(OUTDIR)IRAccess.$(O) \
   103     $(OUTDIR)IRAccess.$(O) \
    62     $(OUTDIR)IRClosure.$(O) \
   104     $(OUTDIR)IRClosure.$(O) \
    63     $(OUTDIR)IRConstant.$(O) \
   105     $(OUTDIR)IRConstant.$(O) \
    64     $(OUTDIR)IRDecompiler.$(O) \
   106     $(OUTDIR)IRDecompiler.$(O) \
    65     $(OUTDIR)IRDup.$(O) \
   107     $(OUTDIR)IRDup.$(O) \
    84     $(OUTDIR)IRTempRead.$(O) \
   126     $(OUTDIR)IRTempRead.$(O) \
    85     $(OUTDIR)IRTempStore.$(O) \
   127     $(OUTDIR)IRTempStore.$(O) \
    86     $(OUTDIR)extensions.$(O) \
   128     $(OUTDIR)extensions.$(O) \
    87 
   129 
    88 
   130 
       
   131