Make.spec
author Jan Vrany <jan.vrany@fit.cvut.cz>
Wed, 12 Aug 2009 10:22:31 +0000
changeset 21 a5d30403049c
child 27 45902cde2ab1
permissions -rw-r--r--
Small improvement in IRFunction>>addTemps:

# $Header$
#
# DO NOT EDIT 
# automagically generated from the projectDefinition: stx_goodies_newcompiler.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=stx
MODULE_DIR=goodies/newcompiler
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -H.         : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optspace3


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard

COMMON_OBJS= \
    $(OUTDIR)IRBuilder.$(O) \
    $(OUTDIR)IRBytecodeGenerator.$(O) \
    $(OUTDIR)IRFunction.$(O) \
    $(OUTDIR)IRInstruction.$(O) \
    $(OUTDIR)IRInterpreter.$(O) \
    $(OUTDIR)IRSequence.$(O) \
    $(OUTDIR)IRStackCount.$(O) \
    $(OUTDIR)stx_goodies_newcompiler.$(O) \
    $(OUTDIR)IRAccess.$(O) \
    $(OUTDIR)IRClosure.$(O) \
    $(OUTDIR)IRConstant.$(O) \
    $(OUTDIR)IRDecompiler.$(O) \
    $(OUTDIR)IRDup.$(O) \
    $(OUTDIR)IRJump.$(O) \
    $(OUTDIR)IRLine.$(O) \
    $(OUTDIR)IRMethod.$(O) \
    $(OUTDIR)IRPop.$(O) \
    $(OUTDIR)IRPrinter.$(O) \
    $(OUTDIR)IRReturn.$(O) \
    $(OUTDIR)IRSend.$(O) \
    $(OUTDIR)IRTranslator.$(O) \
    $(OUTDIR)IRBlockReturnTop.$(O) \
    $(OUTDIR)IRInstVarAccess.$(O) \
    $(OUTDIR)IRJumpIf.$(O) \
    $(OUTDIR)IRJumpOverBlock.$(O) \
    $(OUTDIR)IRLiteralVariableAccess.$(O) \
    $(OUTDIR)IRTempAccess.$(O) \
    $(OUTDIR)IRInstVarRead.$(O) \
    $(OUTDIR)IRInstVarStore.$(O) \
    $(OUTDIR)IRLiteralVariableRead.$(O) \
    $(OUTDIR)IRLiteralVariableStore.$(O) \
    $(OUTDIR)IRTempRead.$(O) \
    $(OUTDIR)IRTempStore.$(O) \
    $(OUTDIR)extensions.$(O) \