s/benchmarks/micro/Make.spec
author Jan Vrany <jan.vrany@fit.cvut.cz>
Thu, 27 Nov 2014 21:59:38 +0000
changeset 264 1835162be709
parent 135 b80ce920afe2
child 316 44346cc94ec4
permissions -rw-r--r--
Added micro-benchmark to benchmark string concatenation ..both using , on String and using memory Stream>>nextPutAll:

# $Header$
#
# DO NOT EDIT
# automagically generated from the projectDefinition: jv_calipel_s_benchmarks_micro.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=jv
MODULE_DIR=calipel/s/benchmarks/micro
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -headerDir=. : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optspace3


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#  -warnUnused      : no warnings about unused variables
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard

COMMON_CLASSES= \
	BenchmarkMicroStringConcat \
	BenchmarkMicroStringConcatN \
	BenchmarkPerform \
	jv_calipel_s_benchmarks_micro \




COMMON_OBJS= \
    $(OUTDIR_SLASH)BenchmarkMicroStringConcat.$(O) \
    $(OUTDIR_SLASH)BenchmarkMicroStringConcatN.$(O) \
    $(OUTDIR_SLASH)BenchmarkPerform.$(O) \
    $(OUTDIR_SLASH)jv_calipel_s_benchmarks_micro.$(O) \