Make.spec
author Jan Vrany <jan.vrany@fit.cvut.cz>
Thu, 17 Sep 2015 07:36:40 +0100
changeset 49 307d55f736ec
parent 45 86de1611e013
permissions -rw-r--r--
LLVM bindings: allow to specify path to llvm-config ..by setting LLVM_CONFIG variable when generating definitions for LLVM bindings. Example: make LVM_CONFIG=~/Projects/LLVM/sources1/build/Debug+Asserts/bin/llvm-config

# $Header$
#
# DO NOT EDIT
# automagically generated from the projectDefinition: jv_cface.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=jv
MODULE_DIR=cface
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -headerDir=. : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optspace3


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#  -warnUnused      : no warnings about unused variables
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard

COMMON_CLASSES= \
	Cface::CDefinitionParser \
	Cface::CDefinitionScanner \
	Cface::CNode \
	Cface::CNodeVisitor \
	Cface::GeneratorCommand \
	Cface::Platform \
	Cface::TypeMapping \
	jv_cface \
	Cface::CDefinitionNode \
	Cface::CModifierNode \
	Cface::CNoNode \
	Cface::CairoMapping \
	Cface::GTKMapping \
	Cface::Generator \
	Cface::LLVM_C \
	Cface::Libgit2Mapping \
	Cface::SVNMapping \
	Cface::SmalltalkX \
	Cface::TypeCollector \
	Cface::TypeMapper \
	Cface::TypeResolver \
	Cface::CArgumentNode \
	Cface::CConstNode \
	Cface::CDefinitionFileNode \
	Cface::CEnumValueNode \
	Cface::CFunctionNode \
	Cface::CLongNode \
	Cface::CShortNode \
	Cface::CStructFieldNode \
	Cface::CTypeNode \
	Cface::CUnsignedNode \
	Cface::LLVM_C_EXT \
	Cface::SmalltalkXGenerator \
	Cface::CArrayNode \
	Cface::CBuiltinNode \
	Cface::CDerivedTypeNode \
	Cface::CPointerNode \
	Cface::CUnresolvedTypeNode \
	Cface::CCharNode \
	Cface::CDoubleNode \
	Cface::CEnumNode \
	Cface::CFloatNode \
	Cface::CFunctionTypeNode \
	Cface::CIntNode \
	Cface::CStructuredNode \
	Cface::CTypedefNode \
	Cface::CVoidNode \
	Cface::CWCharNode \
	Cface::CBoolNode \
	Cface::CStructNode \
	Cface::CUnionNode \




COMMON_OBJS= \
    $(OUTDIR_SLASH)Cface__CDefinitionParser.$(O) \
    $(OUTDIR_SLASH)Cface__CDefinitionScanner.$(O) \
    $(OUTDIR_SLASH)Cface__CNode.$(O) \
    $(OUTDIR_SLASH)Cface__CNodeVisitor.$(O) \
    $(OUTDIR_SLASH)Cface__GeneratorCommand.$(O) \
    $(OUTDIR_SLASH)Cface__Platform.$(O) \
    $(OUTDIR_SLASH)Cface__TypeMapping.$(O) \
    $(OUTDIR_SLASH)jv_cface.$(O) \
    $(OUTDIR_SLASH)Cface__CDefinitionNode.$(O) \
    $(OUTDIR_SLASH)Cface__CModifierNode.$(O) \
    $(OUTDIR_SLASH)Cface__CNoNode.$(O) \
    $(OUTDIR_SLASH)Cface__CairoMapping.$(O) \
    $(OUTDIR_SLASH)Cface__GTKMapping.$(O) \
    $(OUTDIR_SLASH)Cface__Generator.$(O) \
    $(OUTDIR_SLASH)Cface__LLVM_C.$(O) \
    $(OUTDIR_SLASH)Cface__Libgit2Mapping.$(O) \
    $(OUTDIR_SLASH)Cface__SVNMapping.$(O) \
    $(OUTDIR_SLASH)Cface__SmalltalkX.$(O) \
    $(OUTDIR_SLASH)Cface__TypeCollector.$(O) \
    $(OUTDIR_SLASH)Cface__TypeMapper.$(O) \
    $(OUTDIR_SLASH)Cface__TypeResolver.$(O) \
    $(OUTDIR_SLASH)Cface__CArgumentNode.$(O) \
    $(OUTDIR_SLASH)Cface__CConstNode.$(O) \
    $(OUTDIR_SLASH)Cface__CDefinitionFileNode.$(O) \
    $(OUTDIR_SLASH)Cface__CEnumValueNode.$(O) \
    $(OUTDIR_SLASH)Cface__CFunctionNode.$(O) \
    $(OUTDIR_SLASH)Cface__CLongNode.$(O) \
    $(OUTDIR_SLASH)Cface__CShortNode.$(O) \
    $(OUTDIR_SLASH)Cface__CStructFieldNode.$(O) \
    $(OUTDIR_SLASH)Cface__CTypeNode.$(O) \
    $(OUTDIR_SLASH)Cface__CUnsignedNode.$(O) \
    $(OUTDIR_SLASH)Cface__LLVM_C_EXT.$(O) \
    $(OUTDIR_SLASH)Cface__SmalltalkXGenerator.$(O) \
    $(OUTDIR_SLASH)Cface__CArrayNode.$(O) \
    $(OUTDIR_SLASH)Cface__CBuiltinNode.$(O) \
    $(OUTDIR_SLASH)Cface__CDerivedTypeNode.$(O) \
    $(OUTDIR_SLASH)Cface__CPointerNode.$(O) \
    $(OUTDIR_SLASH)Cface__CUnresolvedTypeNode.$(O) \
    $(OUTDIR_SLASH)Cface__CCharNode.$(O) \
    $(OUTDIR_SLASH)Cface__CDoubleNode.$(O) \
    $(OUTDIR_SLASH)Cface__CEnumNode.$(O) \
    $(OUTDIR_SLASH)Cface__CFloatNode.$(O) \
    $(OUTDIR_SLASH)Cface__CFunctionTypeNode.$(O) \
    $(OUTDIR_SLASH)Cface__CIntNode.$(O) \
    $(OUTDIR_SLASH)Cface__CStructuredNode.$(O) \
    $(OUTDIR_SLASH)Cface__CTypedefNode.$(O) \
    $(OUTDIR_SLASH)Cface__CVoidNode.$(O) \
    $(OUTDIR_SLASH)Cface__CWCharNode.$(O) \
    $(OUTDIR_SLASH)Cface__CBoolNode.$(O) \
    $(OUTDIR_SLASH)Cface__CStructNode.$(O) \
    $(OUTDIR_SLASH)Cface__CUnionNode.$(O) \
    $(OUTDIR_SLASH)extensions.$(O) \