Make.spec
author Jan Vrany <jan.vrany@fit.cvut.cz>
Tue, 23 Sep 2014 16:52:40 +0100
changeset 32 d7464405cbda
parent 22 57da23a9fbbd
child 33 f87d54770abe
permissions -rw-r--r--
Package renamed from cvut:fel/cface to jv:cface

# $Header$
#
# DO NOT EDIT
# automagically generated from the projectDefinition: jv_cface.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=jv
MODULE_DIR=cface
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -headerDir=. : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optspace3


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard

COMMON_CLASSES= \
	Cface::CDefinitionParser \
	Cface::CDefinitionScanner \
	Cface::CNode \
	Cface::CNodeVisitor \
	Cface::GeneratorCommand \
	Cface::Platform \
	Cface::TypeMapping \
	jv_cface \
	Cface::CDefinitionNode \
	Cface::CModifierNode \
	Cface::CNoNode \
	Cface::CairoMapping \
	Cface::GTKMapping \
	Cface::Generator \
	Cface::SVNMapping \
	Cface::SmalltalkX \
	Cface::TypeCollector \
	Cface::TypeMapper \
	Cface::TypeResolver \
	Cface::CArgumentNode \
	Cface::CConstNode \
	Cface::CDefinitionFileNode \
	Cface::CEnumValueNode \
	Cface::CFunctionNode \
	Cface::CLongNode \
	Cface::CShortNode \
	Cface::CStructFieldNode \
	Cface::CTypeNode \
	Cface::CUnsignedNode \
	Cface::SmalltalkXGenerator \
	Cface::CArrayNode \
	Cface::CBuiltinNode \
	Cface::CDerivedTypeNode \
	Cface::CPointerNode \
	Cface::CTypedefNode \
	Cface::CUserDefinedTypeNode \
	Cface::CCharNode \
	Cface::CDoubleNode \
	Cface::CEnumNode \
	Cface::CFloatNode \
	Cface::CFunctionTypeNode \
	Cface::CIntNode \
	Cface::CStructuredNode \
	Cface::CVoidNode \
	Cface::CWCharNode \
	Cface::CStructNode \
	Cface::CUnionNode \
	Cface::Libgit2Mapping \




COMMON_OBJS= \
    $(OUTDIR)Cface__CDefinitionParser.$(O) \
    $(OUTDIR)Cface__CDefinitionScanner.$(O) \
    $(OUTDIR)Cface__CNode.$(O) \
    $(OUTDIR)Cface__CNodeVisitor.$(O) \
    $(OUTDIR)Cface__GeneratorCommand.$(O) \
    $(OUTDIR)Cface__Platform.$(O) \
    $(OUTDIR)Cface__TypeMapping.$(O) \
    $(OUTDIR)jv_cface.$(O) \
    $(OUTDIR)Cface__CDefinitionNode.$(O) \
    $(OUTDIR)Cface__CModifierNode.$(O) \
    $(OUTDIR)Cface__CNoNode.$(O) \
    $(OUTDIR)Cface__CairoMapping.$(O) \
    $(OUTDIR)Cface__GTKMapping.$(O) \
    $(OUTDIR)Cface__Generator.$(O) \
    $(OUTDIR)Cface__SVNMapping.$(O) \
    $(OUTDIR)Cface__SmalltalkX.$(O) \
    $(OUTDIR)Cface__TypeCollector.$(O) \
    $(OUTDIR)Cface__TypeMapper.$(O) \
    $(OUTDIR)Cface__TypeResolver.$(O) \
    $(OUTDIR)Cface__CArgumentNode.$(O) \
    $(OUTDIR)Cface__CConstNode.$(O) \
    $(OUTDIR)Cface__CDefinitionFileNode.$(O) \
    $(OUTDIR)Cface__CEnumValueNode.$(O) \
    $(OUTDIR)Cface__CFunctionNode.$(O) \
    $(OUTDIR)Cface__CLongNode.$(O) \
    $(OUTDIR)Cface__CShortNode.$(O) \
    $(OUTDIR)Cface__CStructFieldNode.$(O) \
    $(OUTDIR)Cface__CTypeNode.$(O) \
    $(OUTDIR)Cface__CUnsignedNode.$(O) \
    $(OUTDIR)Cface__SmalltalkXGenerator.$(O) \
    $(OUTDIR)Cface__CArrayNode.$(O) \
    $(OUTDIR)Cface__CBuiltinNode.$(O) \
    $(OUTDIR)Cface__CDerivedTypeNode.$(O) \
    $(OUTDIR)Cface__CPointerNode.$(O) \
    $(OUTDIR)Cface__CTypedefNode.$(O) \
    $(OUTDIR)Cface__CUserDefinedTypeNode.$(O) \
    $(OUTDIR)Cface__CCharNode.$(O) \
    $(OUTDIR)Cface__CDoubleNode.$(O) \
    $(OUTDIR)Cface__CEnumNode.$(O) \
    $(OUTDIR)Cface__CFloatNode.$(O) \
    $(OUTDIR)Cface__CFunctionTypeNode.$(O) \
    $(OUTDIR)Cface__CIntNode.$(O) \
    $(OUTDIR)Cface__CStructuredNode.$(O) \
    $(OUTDIR)Cface__CVoidNode.$(O) \
    $(OUTDIR)Cface__CWCharNode.$(O) \
    $(OUTDIR)Cface__CStructNode.$(O) \
    $(OUTDIR)Cface__CUnionNode.$(O) \
    $(OUTDIR)Cface__Libgit2Mapping.$(O) \
    $(OUTDIR)extensions.$(O) \