Make.spec
author Jan Vrany <jan.vrany@fit.cvut.cz>
Mon, 21 Dec 2015 22:46:06 +0100
changeset 2 88445baa732f
child 9 40f9438e9de3
permissions -rw-r--r--
Introduced a CompiledCodeObject - an interface to VM's macine code management. This is an API object alowing to read and write machine code from Smalltalk. The code is managed by the VM, i.e., it's garbage colledted by the VM.

# $Header$
#
# DO NOT EDIT
# automagically generated from the projectDefinition: jv_dragonfly.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=jv
MODULE_DIR=dragonfly
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -headerDir=. : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optspace3


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#  -warnUnused      : no warnings about unused variables
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard

COMMON_CLASSES= \
	CompiledCodeObject \
	CompiledCodeObjectSectionType \
	jv_dragonfly \
	CompiledCodeObjectSection \




COMMON_OBJS= \
    $(OUTDIR_SLASH)CompiledCodeObject.$(O) \
    $(OUTDIR_SLASH)CompiledCodeObjectSectionType.$(O) \
    $(OUTDIR_SLASH)jv_dragonfly.$(O) \
    $(OUTDIR_SLASH)CompiledCodeObjectSection.$(O) \
    $(OUTDIR_SLASH)extensions.$(O) \