asm/Make.spec
author Jan Vrany <jan.vrany@fit.cvut.cz>
Wed, 15 Jun 2016 23:46:29 +0100
changeset 23 d2d9a2d4d6bf
parent 3 483729eb4432
permissions -rw-r--r--
Added README, licenses and copyright notices.

# $Header$
#
# DO NOT EDIT
# automagically generated from the projectDefinition: jv_dragonfly_asm.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=jv
MODULE_DIR=dragonfly/asm
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -headerDir=. : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optspace3


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#  -warnUnused      : no warnings about unused variables
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard

COMMON_CLASSES= \
	AJAssembler \
	AJCallInfo \
	AJConstants \
	AJGeneratedCode \
	AJInstruction \
	AJLineStream \
	AJRoutineStackManager \
	jv_dragonfly_asm \
	AJAlignmentInstruction \
	AJCdeclCallInfo \
	AJData \
	AJInstructionDecoration \
	AJJumpInstruction \
	AJJumpLabel \
	AJOperand \
	AJReleaseTemps \
	AJReserveTemp \
	AJRoutineEpilogue \
	AJRoutinePrologue \
	AJStackInstruction \
	AJStdCallCallInfo \
	AJx86Instruction \
	AJx86Registers \
	AJBaseReg \
	AJCallArgument \
	AJCallCleanup \
	AJImmediate \
	AJMem \
	AJx64Instruction \
	AJx86Assembler \
	AJx86InstructionDescription \
	AJx86JumpInstruction \
	AJMMRegister \
	AJRegister \
	AJx64Assembler \
	AJx64InstructionDescription \
	AJx64JumpInstruction \
	AJx87Register \
	AJxMMRegister \
	AJx86GPRegister \
	AJx64RipRegister \




COMMON_OBJS= \
    $(OUTDIR_SLASH)AJAssembler.$(O) \
    $(OUTDIR_SLASH)AJCallInfo.$(O) \
    $(OUTDIR_SLASH)AJConstants.$(O) \
    $(OUTDIR_SLASH)AJGeneratedCode.$(O) \
    $(OUTDIR_SLASH)AJInstruction.$(O) \
    $(OUTDIR_SLASH)AJLineStream.$(O) \
    $(OUTDIR_SLASH)AJRoutineStackManager.$(O) \
    $(OUTDIR_SLASH)jv_dragonfly_asm.$(O) \
    $(OUTDIR_SLASH)AJAlignmentInstruction.$(O) \
    $(OUTDIR_SLASH)AJCdeclCallInfo.$(O) \
    $(OUTDIR_SLASH)AJData.$(O) \
    $(OUTDIR_SLASH)AJInstructionDecoration.$(O) \
    $(OUTDIR_SLASH)AJJumpInstruction.$(O) \
    $(OUTDIR_SLASH)AJJumpLabel.$(O) \
    $(OUTDIR_SLASH)AJOperand.$(O) \
    $(OUTDIR_SLASH)AJReleaseTemps.$(O) \
    $(OUTDIR_SLASH)AJReserveTemp.$(O) \
    $(OUTDIR_SLASH)AJRoutineEpilogue.$(O) \
    $(OUTDIR_SLASH)AJRoutinePrologue.$(O) \
    $(OUTDIR_SLASH)AJStackInstruction.$(O) \
    $(OUTDIR_SLASH)AJStdCallCallInfo.$(O) \
    $(OUTDIR_SLASH)AJx86Instruction.$(O) \
    $(OUTDIR_SLASH)AJx86Registers.$(O) \
    $(OUTDIR_SLASH)AJBaseReg.$(O) \
    $(OUTDIR_SLASH)AJCallArgument.$(O) \
    $(OUTDIR_SLASH)AJCallCleanup.$(O) \
    $(OUTDIR_SLASH)AJImmediate.$(O) \
    $(OUTDIR_SLASH)AJMem.$(O) \
    $(OUTDIR_SLASH)AJx64Instruction.$(O) \
    $(OUTDIR_SLASH)AJx86Assembler.$(O) \
    $(OUTDIR_SLASH)AJx86InstructionDescription.$(O) \
    $(OUTDIR_SLASH)AJx86JumpInstruction.$(O) \
    $(OUTDIR_SLASH)AJMMRegister.$(O) \
    $(OUTDIR_SLASH)AJRegister.$(O) \
    $(OUTDIR_SLASH)AJx64Assembler.$(O) \
    $(OUTDIR_SLASH)AJx64InstructionDescription.$(O) \
    $(OUTDIR_SLASH)AJx64JumpInstruction.$(O) \
    $(OUTDIR_SLASH)AJx87Register.$(O) \
    $(OUTDIR_SLASH)AJxMMRegister.$(O) \
    $(OUTDIR_SLASH)AJx86GPRegister.$(O) \
    $(OUTDIR_SLASH)AJx64RipRegister.$(O) \
    $(OUTDIR_SLASH)extensions.$(O) \