udis86sx/Make.spec
author Jan Vrany <jan.vrany@fit.cvut.cz>
Wed, 27 Jan 2016 08:34:29 +0000
changeset 15 eccc20e9c2e1
parent 1 aa002d0c231b
child 22 9ee423bb2e37
permissions -rw-r--r--
Added subpackage c1 for LLVM based compiler.

# $Header$
#
# DO NOT EDIT
# automagically generated from the projectDefinition: jv_dragonfly_udis86sx.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=jv
MODULE_DIR=dragonfly/udis86sx
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -headerDir=. : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optspace3


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#  -warnUnused      : no warnings about unused variables
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard

COMMON_CLASSES= \
	UDIS86 \
	UDIS86Instruction \
	jv_dragonfly_udis86sx \




COMMON_OBJS= \
    $(OUTDIR_SLASH)UDIS86.$(O) \
    $(OUTDIR_SLASH)UDIS86Instruction.$(O) \
    $(OUTDIR_SLASH)jv_dragonfly_udis86sx.$(O) \