tests/Make.spec
changeset 95 f417138e9c48
parent 92 0f11fece852c
child 97 b17c889076e4
--- a/tests/Make.spec	Mon Jan 08 19:43:49 2018 +0000
+++ b/tests/Make.spec	Thu Jan 11 23:53:06 2018 +0000
@@ -1,75 +1,75 @@
-# $Header$
-#
-# DO NOT EDIT
-# automagically generated from the projectDefinition: jv_libgdbs_tests.
-#
-# Warning: once you modify this file, do not rerun
-# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
-#
-# This file contains specifications which are common to all platforms.
-#
-
-# Do NOT CHANGE THESE DEFINITIONS
-# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
-#  to find the source code of a class and to find the library for a package)
-MODULE=jv
-MODULE_DIR=libgdbs/tests
-PACKAGE=$(MODULE):$(MODULE_DIR)
-
-
-# Argument(s) to the stc compiler (stc --usage).
-#  -headerDir=. : create header files locally
-#                (if removed, they will be created as common
-#  -Pxxx       : defines the package
-#  -Zxxx       : a prefix for variables within the classLib
-#  -Dxxx       : defines passed to CC for inline C-code
-#  -Ixxx       : include path passed to CC for inline C-code
-#  +optspace   : optimized for space
-#  +optspace2  : optimized more for space
-#  +optspace3  : optimized even more for space
-#  +optinline  : generate inline code for some ST constructs
-#  +inlineNew  : additionally inline new
-#  +inlineMath : additionally inline some floatPnt math stuff
-#
-# ********** OPTIONAL: MODIFY the next line(s) ***
-# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
-# STCLOCALOPTIMIZATIONS=+optspace3
-STCLOCALOPTIMIZATIONS=+optspace3
-
-
-# Argument(s) to the stc compiler (stc --usage).
-#  -warn            : no warnings
-#  -warnNonStandard : no warnings about ST/X extensions
-#  -warnEOLComments : no warnings about EOL comment extension
-#  -warnPrivacy     : no warnings about privateClass extension
-#  -warnUnused      : no warnings about unused variables
-#
-# ********** OPTIONAL: MODIFY the next line(s) ***
-# STCWARNINGS=-warn
-# STCWARNINGS=-warnNonStandard
-# STCWARNINGS=-warnEOLComments
-STCWARNINGS=-warnNonStandard
-
-COMMON_CLASSES= \
-	GDBDebuggeesResource \
-	GDBDebuggerTestCase \
-	GDBInternalPipeStreamTests \
-	GDBMIParserTests \
-	GDBMIPrinterTests \
-	jv_libgdbs_tests \
-	GDBDebuggerTestsR \
-
-
-
-
-COMMON_OBJS= \
-    $(OUTDIR)GDBDebuggeesResource.$(O) \
-    $(OUTDIR)GDBDebuggerTestCase.$(O) \
-    $(OUTDIR)GDBInternalPipeStreamTests.$(O) \
-    $(OUTDIR)GDBMIParserTests.$(O) \
-    $(OUTDIR)GDBMIPrinterTests.$(O) \
-    $(OUTDIR)jv_libgdbs_tests.$(O) \
-    $(OUTDIR)GDBDebuggerTestsR.$(O) \
-
-
-
+# $Header$
+#
+# DO NOT EDIT
+# automagically generated from the projectDefinition: jv_libgdbs_tests.
+#
+# Warning: once you modify this file, do not rerun
+# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
+#
+# This file contains specifications which are common to all platforms.
+#
+
+# Do NOT CHANGE THESE DEFINITIONS
+# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
+#  to find the source code of a class and to find the library for a package)
+MODULE=jv
+MODULE_DIR=libgdbs/tests
+PACKAGE=$(MODULE):$(MODULE_DIR)
+
+
+# Argument(s) to the stc compiler (stc --usage).
+#  -headerDir=. : create header files locally
+#                (if removed, they will be created as common
+#  -Pxxx       : defines the package
+#  -Zxxx       : a prefix for variables within the classLib
+#  -Dxxx       : defines passed to CC for inline C-code
+#  -Ixxx       : include path passed to CC for inline C-code
+#  +optspace   : optimized for space
+#  +optspace2  : optimized more for space
+#  +optspace3  : optimized even more for space
+#  +optinline  : generate inline code for some ST constructs
+#  +inlineNew  : additionally inline new
+#  +inlineMath : additionally inline some floatPnt math stuff
+#
+# ********** OPTIONAL: MODIFY the next line(s) ***
+# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
+# STCLOCALOPTIMIZATIONS=+optspace3
+STCLOCALOPTIMIZATIONS=+optspace3
+
+
+# Argument(s) to the stc compiler (stc --usage).
+#  -warn            : no warnings
+#  -warnNonStandard : no warnings about ST/X extensions
+#  -warnEOLComments : no warnings about EOL comment extension
+#  -warnPrivacy     : no warnings about privateClass extension
+#  -warnUnused      : no warnings about unused variables
+#
+# ********** OPTIONAL: MODIFY the next line(s) ***
+# STCWARNINGS=-warn
+# STCWARNINGS=-warnNonStandard
+# STCWARNINGS=-warnEOLComments
+STCWARNINGS=-warnNonStandard
+
+COMMON_CLASSES= \
+	GDBDebuggeesResource \
+	GDBDebuggerTestCase \
+	GDBInternalPipeStreamTests \
+	GDBMIParserTests \
+	GDBMIPrinterTests \
+	jv_libgdbs_tests \
+	GDBDebuggerTestsR \
+
+
+
+
+COMMON_OBJS= \
+    $(OUTDIR)GDBDebuggeesResource.$(O) \
+    $(OUTDIR)GDBDebuggerTestCase.$(O) \
+    $(OUTDIR)GDBInternalPipeStreamTests.$(O) \
+    $(OUTDIR)GDBMIParserTests.$(O) \
+    $(OUTDIR)GDBMIPrinterTests.$(O) \
+    $(OUTDIR)jv_libgdbs_tests.$(O) \
+    $(OUTDIR)GDBDebuggerTestsR.$(O) \
+
+
+