Make.spec
author Jan Vrany <jan.vrany@fit.cvut.cz>
Wed, 18 Jun 2014 07:54:03 +0100
changeset 15 65d3b4bfe871
parent 13 45ec9353003f
child 16 a5a8c0454395
permissions -rw-r--r--
Initial support for parsing typed values (now only booleans and integers)

# $Header$
#
# DO NOT EDIT
# automagically generated from the projectDefinition: jv_libgdbs.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=jv
MODULE_DIR=libgdbs
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -headerDir=. : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optspace3


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard

COMMON_CLASSES= \
	GDBCommand \
	GDBCommandResult \
	GDBCommandStatus \
	GDBDebugFlags \
	GDBEvent \
	GDBEventSet \
	GDBInternalPipeStream \
	GDBLauncher \
	GDBObject \
	GDBPTY \
	jv_libgdbs \
	GDB \
	GDBAsyncEvent \
	GDBCLICommand \
	GDBCommandEvent \
	GDBCommandResultEvent \
	GDBDriver \
	GDBInternalEvent \
	GDBMICommand \
	GDBParser \
	GDBStreamOutputEvent \
	GDBConsoleOutputEvent \
	GDBExecutionEvent \
	GDBExitEvent \
	GDBLogOutputEvent \
	GDBMI_ada_task_info \
	GDBMI_add_inferior \
	GDBMI_break_after \
	GDBMI_break_commands \
	GDBMI_break_condition \
	GDBMI_break_delete \
	GDBMI_break_disable \
	GDBMI_break_enable \
	GDBMI_break_info \
	GDBMI_break_insert \
	GDBMI_break_list \
	GDBMI_break_passcount \
	GDBMI_break_watch \
	GDBMI_catch_assert \
	GDBMI_catch_exception \
	GDBMI_catch_load \
	GDBMI_catch_unload \
	GDBMI_data_disassemble \
	GDBMI_data_evaluate_expression \
	GDBMI_data_list_changed_registers \
	GDBMI_data_list_register_names \
	GDBMI_data_list_register_values \
	GDBMI_data_read_memory \
	GDBMI_data_read_memory_bytes \
	GDBMI_data_write_memory \
	GDBMI_data_write_memory_bytes \
	GDBMI_data_write_register_values \
	GDBMI_dprintf_insert \
	GDBMI_enable_frame_filters \
	GDBMI_enable_pretty_printing \
	GDBMI_enable_timings \
	GDBMI_environment_cd \
	GDBMI_environment_directory \
	GDBMI_environment_path \
	GDBMI_environment_pwd \
	GDBMI_exec_arguments \
	GDBMI_exec_continue \
	GDBMI_exec_finish \
	GDBMI_exec_interrupt \
	GDBMI_exec_jump \
	GDBMI_exec_next \
	GDBMI_exec_next_instruction \
	GDBMI_exec_return \
	GDBMI_exec_run \
	GDBMI_exec_step \
	GDBMI_exec_step_instruction \
	GDBMI_exec_until \
	GDBMI_file_exec_and_symbols \
	GDBMI_file_exec_file \
	GDBMI_file_list_exec_source_file \
	GDBMI_file_list_exec_source_files \
	GDBMI_file_symbol_file \
	GDBMI_gdb_exit \
	GDBMI_gdb_set \
	GDBMI_gdb_show \
	GDBMI_gdb_version \
	GDBMI_inferior_tty_set \
	GDBMI_inferior_tty_show \
	GDBMI_info_ada_exceptions \
	GDBMI_info_gdb_mi_command \
	GDBMI_info_os \
	GDBMI_interpreter_exec \
	GDBMI_list_features \
	GDBMI_list_target_features \
	GDBMI_list_thread_groups \
	GDBMI_remove_inferior \
	GDBMI_stack_info_depth \
	GDBMI_stack_info_frame \
	GDBMI_stack_list_arguments \
	GDBMI_stack_list_frames \
	GDBMI_stack_list_locals \
	GDBMI_stack_list_variables \
	GDBMI_stack_select_frame \
	GDBMI_symbol_list_lines \
	GDBMI_target_attach \
	GDBMI_target_detach \
	GDBMI_target_disconnect \
	GDBMI_target_download \
	GDBMI_target_file_delete \
	GDBMI_target_file_get \
	GDBMI_target_file_put \
	GDBMI_target_select \
	GDBMI_thread_info \
	GDBMI_thread_list_ids \
	GDBMI_thread_select \
	GDBMI_trace_define_variable \
	GDBMI_trace_find \
	GDBMI_trace_frame_collected \
	GDBMI_trace_list_variables \
	GDBMI_trace_save \
	GDBMI_trace_start \
	GDBMI_trace_status \
	GDBMI_trace_stop \
	GDBMI_var_assign \
	GDBMI_var_create \
	GDBMI_var_delete \
	GDBMI_var_evaluate_expression \
	GDBMI_var_info_expression \
	GDBMI_var_info_num_children \
	GDBMI_var_info_path_expression \
	GDBMI_var_info_type \
	GDBMI_var_list_children \
	GDBMI_var_set_format \
	GDBMI_var_set_frozen \
	GDBMI_var_set_update_range \
	GDBMI_var_set_visualizer \
	GDBMI_var_show_attributes \
	GDBMI_var_show_format \
	GDBMI_var_update \
	GDBNotificationEvent \
	GDBStatusEvent \
	GDBTargetOutputEvent \
	GDBBreakpointCreatedEvent \
	GDBBreakpointDeletedEvent \
	GDBBreakpointModifiedEvent \
	GDBLibraryLoadedEvent \
	GDBLibraryUnloadedEvent \
	GDBRunningEvent \
	GDBStoppedEvent \
	GDBThreadCreatedEvent \
	GDBThreadExitedEvent \
	GDBThreadGroupAddedEvent \
	GDBThreadGroupExitedEvent \
	GDBThreadGroupStartedEvent \




COMMON_OBJS= \
    $(OUTDIR_SLASH)GDBCommand.$(O) \
    $(OUTDIR_SLASH)GDBCommandResult.$(O) \
    $(OUTDIR_SLASH)GDBCommandStatus.$(O) \
    $(OUTDIR_SLASH)GDBDebugFlags.$(O) \
    $(OUTDIR_SLASH)GDBEvent.$(O) \
    $(OUTDIR_SLASH)GDBEventSet.$(O) \
    $(OUTDIR_SLASH)GDBInternalPipeStream.$(O) \
    $(OUTDIR_SLASH)GDBLauncher.$(O) \
    $(OUTDIR_SLASH)GDBObject.$(O) \
    $(OUTDIR_SLASH)GDBPTY.$(O) \
    $(OUTDIR_SLASH)jv_libgdbs.$(O) \
    $(OUTDIR_SLASH)GDB.$(O) \
    $(OUTDIR_SLASH)GDBAsyncEvent.$(O) \
    $(OUTDIR_SLASH)GDBCLICommand.$(O) \
    $(OUTDIR_SLASH)GDBCommandEvent.$(O) \
    $(OUTDIR_SLASH)GDBCommandResultEvent.$(O) \
    $(OUTDIR_SLASH)GDBDriver.$(O) \
    $(OUTDIR_SLASH)GDBInternalEvent.$(O) \
    $(OUTDIR_SLASH)GDBMICommand.$(O) \
    $(OUTDIR_SLASH)GDBParser.$(O) \
    $(OUTDIR_SLASH)GDBStreamOutputEvent.$(O) \
    $(OUTDIR_SLASH)GDBConsoleOutputEvent.$(O) \
    $(OUTDIR_SLASH)GDBExecutionEvent.$(O) \
    $(OUTDIR_SLASH)GDBExitEvent.$(O) \
    $(OUTDIR_SLASH)GDBLogOutputEvent.$(O) \
    $(OUTDIR_SLASH)GDBMI_ada_task_info.$(O) \
    $(OUTDIR_SLASH)GDBMI_add_inferior.$(O) \
    $(OUTDIR_SLASH)GDBMI_break_after.$(O) \
    $(OUTDIR_SLASH)GDBMI_break_commands.$(O) \
    $(OUTDIR_SLASH)GDBMI_break_condition.$(O) \
    $(OUTDIR_SLASH)GDBMI_break_delete.$(O) \
    $(OUTDIR_SLASH)GDBMI_break_disable.$(O) \
    $(OUTDIR_SLASH)GDBMI_break_enable.$(O) \
    $(OUTDIR_SLASH)GDBMI_break_info.$(O) \
    $(OUTDIR_SLASH)GDBMI_break_insert.$(O) \
    $(OUTDIR_SLASH)GDBMI_break_list.$(O) \
    $(OUTDIR_SLASH)GDBMI_break_passcount.$(O) \
    $(OUTDIR_SLASH)GDBMI_break_watch.$(O) \
    $(OUTDIR_SLASH)GDBMI_catch_assert.$(O) \
    $(OUTDIR_SLASH)GDBMI_catch_exception.$(O) \
    $(OUTDIR_SLASH)GDBMI_catch_load.$(O) \
    $(OUTDIR_SLASH)GDBMI_catch_unload.$(O) \
    $(OUTDIR_SLASH)GDBMI_data_disassemble.$(O) \
    $(OUTDIR_SLASH)GDBMI_data_evaluate_expression.$(O) \
    $(OUTDIR_SLASH)GDBMI_data_list_changed_registers.$(O) \
    $(OUTDIR_SLASH)GDBMI_data_list_register_names.$(O) \
    $(OUTDIR_SLASH)GDBMI_data_list_register_values.$(O) \
    $(OUTDIR_SLASH)GDBMI_data_read_memory.$(O) \
    $(OUTDIR_SLASH)GDBMI_data_read_memory_bytes.$(O) \
    $(OUTDIR_SLASH)GDBMI_data_write_memory.$(O) \
    $(OUTDIR_SLASH)GDBMI_data_write_memory_bytes.$(O) \
    $(OUTDIR_SLASH)GDBMI_data_write_register_values.$(O) \
    $(OUTDIR_SLASH)GDBMI_dprintf_insert.$(O) \
    $(OUTDIR_SLASH)GDBMI_enable_frame_filters.$(O) \
    $(OUTDIR_SLASH)GDBMI_enable_pretty_printing.$(O) \
    $(OUTDIR_SLASH)GDBMI_enable_timings.$(O) \
    $(OUTDIR_SLASH)GDBMI_environment_cd.$(O) \
    $(OUTDIR_SLASH)GDBMI_environment_directory.$(O) \
    $(OUTDIR_SLASH)GDBMI_environment_path.$(O) \
    $(OUTDIR_SLASH)GDBMI_environment_pwd.$(O) \
    $(OUTDIR_SLASH)GDBMI_exec_arguments.$(O) \
    $(OUTDIR_SLASH)GDBMI_exec_continue.$(O) \
    $(OUTDIR_SLASH)GDBMI_exec_finish.$(O) \
    $(OUTDIR_SLASH)GDBMI_exec_interrupt.$(O) \
    $(OUTDIR_SLASH)GDBMI_exec_jump.$(O) \
    $(OUTDIR_SLASH)GDBMI_exec_next.$(O) \
    $(OUTDIR_SLASH)GDBMI_exec_next_instruction.$(O) \
    $(OUTDIR_SLASH)GDBMI_exec_return.$(O) \
    $(OUTDIR_SLASH)GDBMI_exec_run.$(O) \
    $(OUTDIR_SLASH)GDBMI_exec_step.$(O) \
    $(OUTDIR_SLASH)GDBMI_exec_step_instruction.$(O) \
    $(OUTDIR_SLASH)GDBMI_exec_until.$(O) \
    $(OUTDIR_SLASH)GDBMI_file_exec_and_symbols.$(O) \
    $(OUTDIR_SLASH)GDBMI_file_exec_file.$(O) \
    $(OUTDIR_SLASH)GDBMI_file_list_exec_source_file.$(O) \
    $(OUTDIR_SLASH)GDBMI_file_list_exec_source_files.$(O) \
    $(OUTDIR_SLASH)GDBMI_file_symbol_file.$(O) \
    $(OUTDIR_SLASH)GDBMI_gdb_exit.$(O) \
    $(OUTDIR_SLASH)GDBMI_gdb_set.$(O) \
    $(OUTDIR_SLASH)GDBMI_gdb_show.$(O) \
    $(OUTDIR_SLASH)GDBMI_gdb_version.$(O) \
    $(OUTDIR_SLASH)GDBMI_inferior_tty_set.$(O) \
    $(OUTDIR_SLASH)GDBMI_inferior_tty_show.$(O) \
    $(OUTDIR_SLASH)GDBMI_info_ada_exceptions.$(O) \
    $(OUTDIR_SLASH)GDBMI_info_gdb_mi_command.$(O) \
    $(OUTDIR_SLASH)GDBMI_info_os.$(O) \
    $(OUTDIR_SLASH)GDBMI_interpreter_exec.$(O) \
    $(OUTDIR_SLASH)GDBMI_list_features.$(O) \
    $(OUTDIR_SLASH)GDBMI_list_target_features.$(O) \
    $(OUTDIR_SLASH)GDBMI_list_thread_groups.$(O) \
    $(OUTDIR_SLASH)GDBMI_remove_inferior.$(O) \
    $(OUTDIR_SLASH)GDBMI_stack_info_depth.$(O) \
    $(OUTDIR_SLASH)GDBMI_stack_info_frame.$(O) \
    $(OUTDIR_SLASH)GDBMI_stack_list_arguments.$(O) \
    $(OUTDIR_SLASH)GDBMI_stack_list_frames.$(O) \
    $(OUTDIR_SLASH)GDBMI_stack_list_locals.$(O) \
    $(OUTDIR_SLASH)GDBMI_stack_list_variables.$(O) \
    $(OUTDIR_SLASH)GDBMI_stack_select_frame.$(O) \
    $(OUTDIR_SLASH)GDBMI_symbol_list_lines.$(O) \
    $(OUTDIR_SLASH)GDBMI_target_attach.$(O) \
    $(OUTDIR_SLASH)GDBMI_target_detach.$(O) \
    $(OUTDIR_SLASH)GDBMI_target_disconnect.$(O) \
    $(OUTDIR_SLASH)GDBMI_target_download.$(O) \
    $(OUTDIR_SLASH)GDBMI_target_file_delete.$(O) \
    $(OUTDIR_SLASH)GDBMI_target_file_get.$(O) \
    $(OUTDIR_SLASH)GDBMI_target_file_put.$(O) \
    $(OUTDIR_SLASH)GDBMI_target_select.$(O) \
    $(OUTDIR_SLASH)GDBMI_thread_info.$(O) \
    $(OUTDIR_SLASH)GDBMI_thread_list_ids.$(O) \
    $(OUTDIR_SLASH)GDBMI_thread_select.$(O) \
    $(OUTDIR_SLASH)GDBMI_trace_define_variable.$(O) \
    $(OUTDIR_SLASH)GDBMI_trace_find.$(O) \
    $(OUTDIR_SLASH)GDBMI_trace_frame_collected.$(O) \
    $(OUTDIR_SLASH)GDBMI_trace_list_variables.$(O) \
    $(OUTDIR_SLASH)GDBMI_trace_save.$(O) \
    $(OUTDIR_SLASH)GDBMI_trace_start.$(O) \
    $(OUTDIR_SLASH)GDBMI_trace_status.$(O) \
    $(OUTDIR_SLASH)GDBMI_trace_stop.$(O) \
    $(OUTDIR_SLASH)GDBMI_var_assign.$(O) \
    $(OUTDIR_SLASH)GDBMI_var_create.$(O) \
    $(OUTDIR_SLASH)GDBMI_var_delete.$(O) \
    $(OUTDIR_SLASH)GDBMI_var_evaluate_expression.$(O) \
    $(OUTDIR_SLASH)GDBMI_var_info_expression.$(O) \
    $(OUTDIR_SLASH)GDBMI_var_info_num_children.$(O) \
    $(OUTDIR_SLASH)GDBMI_var_info_path_expression.$(O) \
    $(OUTDIR_SLASH)GDBMI_var_info_type.$(O) \
    $(OUTDIR_SLASH)GDBMI_var_list_children.$(O) \
    $(OUTDIR_SLASH)GDBMI_var_set_format.$(O) \
    $(OUTDIR_SLASH)GDBMI_var_set_frozen.$(O) \
    $(OUTDIR_SLASH)GDBMI_var_set_update_range.$(O) \
    $(OUTDIR_SLASH)GDBMI_var_set_visualizer.$(O) \
    $(OUTDIR_SLASH)GDBMI_var_show_attributes.$(O) \
    $(OUTDIR_SLASH)GDBMI_var_show_format.$(O) \
    $(OUTDIR_SLASH)GDBMI_var_update.$(O) \
    $(OUTDIR_SLASH)GDBNotificationEvent.$(O) \
    $(OUTDIR_SLASH)GDBStatusEvent.$(O) \
    $(OUTDIR_SLASH)GDBTargetOutputEvent.$(O) \
    $(OUTDIR_SLASH)GDBBreakpointCreatedEvent.$(O) \
    $(OUTDIR_SLASH)GDBBreakpointDeletedEvent.$(O) \
    $(OUTDIR_SLASH)GDBBreakpointModifiedEvent.$(O) \
    $(OUTDIR_SLASH)GDBLibraryLoadedEvent.$(O) \
    $(OUTDIR_SLASH)GDBLibraryUnloadedEvent.$(O) \
    $(OUTDIR_SLASH)GDBRunningEvent.$(O) \
    $(OUTDIR_SLASH)GDBStoppedEvent.$(O) \
    $(OUTDIR_SLASH)GDBThreadCreatedEvent.$(O) \
    $(OUTDIR_SLASH)GDBThreadExitedEvent.$(O) \
    $(OUTDIR_SLASH)GDBThreadGroupAddedEvent.$(O) \
    $(OUTDIR_SLASH)GDBThreadGroupExitedEvent.$(O) \
    $(OUTDIR_SLASH)GDBThreadGroupStartedEvent.$(O) \