Make.spec
author Jan Vrany <jan.vrany@fit.cvut.cz>
Tue, 30 Aug 2016 16:57:29 +0100
changeset 78 7a4c769a9fea
parent 76 a1cd10a34b21
child 79 6d6e5a3ec6b1
permissions -rw-r--r--
llvm_c_ext: Improved `LLVMSetMetadata2()` to support also function values ...in addition to instruction values. This is handy to attach data to functions, such as debugging information. Added Smalltalk API for setting metadata nodes on instructions and functions.

# $Header$
#
# DO NOT EDIT
# automagically generated from the projectDefinition: jv_llvm_s.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=jv
MODULE_DIR=llvm_s
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -headerDir=. : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optspace3


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#  -warnUnused      : no warnings about unused variables
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard

COMMON_CLASSES= \
	LLVM \
	LLVMAtomicOrdering \
	LLVMAtomicRMWBinOp \
	LLVMAttribute \
	LLVMByteOrdering \
	LLVMCEXT \
	LLVMCallConv \
	LLVMConfig \
	LLVMConstant \
	LLVMDLLStorageClass \
	LLVMDWARFEncoding \
	LLVMDWARFLamguage \
	LLVMDiagnosticSeverity \
	LLVMError \
	LLVMIntPredicate \
	LLVMLandingPadClauseTy \
	LLVMLinkage \
	LLVMMCJITCompilerOptions \
	LLVMMetadataID \
	LLVMMetadataKind \
	LLVMModuleFlagBehavior \
	LLVMModuleVerificationError \
	LLVMObjectArray \
	LLVMOpcode \
	LLVMRealPredicate \
	LLVMThreadLocalMode \
	LLVMTypeKind \
	LLVMVerifierFailureAction \
	LLVMVisibility \
	jv_llvm_s \
	LLVMObject \
	LLVMTypeError \
	LLVMBasicBlock \
	LLVMContext \
	LLVMDiagnosticInfo \
	LLVMDisposableObject \
	LLVMMetadata \
	LLVMPassRegistry \
	LLVMTargetLibraryInfo \
	LLVMType \
	LLVMTypeMismatchError \
	LLVMUse \
	LLVMValue \
	LLVMDIBuilder \
	LLVMExecutionEngine \
	LLVMFunction \
	LLVMGenericValue \
	LLVMIRBuilder \
	LLVMMCJITMemoryManager \
	LLVMModule \
	LLVMModuleProvider \
	LLVMPassManager \
	LLVMTargetData \
	LLVMTypeFunction \
	LLVMTypeLabel \
	LLVMTypeMetadata \
	LLVMTypeScalar \
	LLVMTypeSequential \
	LLVMTypeStruct \
	LLVMTypeVoid \
	LLVMStXMethod \
	LLVMTypeArray \
	LLVMTypeFloatingPoint \
	LLVMTypeHalt \
	LLVMTypeInteger \
	LLVMTypePointer \
	LLVMTypeVector \
	LLVMTypeX86_MMX \
	LLVMTypeDouble \
	LLVMTypeFP128 \
	LLVMTypeFloat \
	LLVMTypePPC_FP128 \
	LLVMTypeX86_FP80 \




COMMON_OBJS= \
    $(OUTDIR_SLASH)LLVM.$(O) \
    $(OUTDIR_SLASH)LLVMAtomicOrdering.$(O) \
    $(OUTDIR_SLASH)LLVMAtomicRMWBinOp.$(O) \
    $(OUTDIR_SLASH)LLVMAttribute.$(O) \
    $(OUTDIR_SLASH)LLVMByteOrdering.$(O) \
    $(OUTDIR_SLASH)LLVMCEXT.$(O) \
    $(OUTDIR_SLASH)LLVMCallConv.$(O) \
    $(OUTDIR_SLASH)LLVMConfig.$(O) \
    $(OUTDIR_SLASH)LLVMConstant.$(O) \
    $(OUTDIR_SLASH)LLVMDLLStorageClass.$(O) \
    $(OUTDIR_SLASH)LLVMDWARFEncoding.$(O) \
    $(OUTDIR_SLASH)LLVMDWARFLamguage.$(O) \
    $(OUTDIR_SLASH)LLVMDiagnosticSeverity.$(O) \
    $(OUTDIR_SLASH)LLVMError.$(O) \
    $(OUTDIR_SLASH)LLVMIntPredicate.$(O) \
    $(OUTDIR_SLASH)LLVMLandingPadClauseTy.$(O) \
    $(OUTDIR_SLASH)LLVMLinkage.$(O) \
    $(OUTDIR_SLASH)LLVMMCJITCompilerOptions.$(O) \
    $(OUTDIR_SLASH)LLVMMetadataID.$(O) \
    $(OUTDIR_SLASH)LLVMMetadataKind.$(O) \
    $(OUTDIR_SLASH)LLVMModuleFlagBehavior.$(O) \
    $(OUTDIR_SLASH)LLVMModuleVerificationError.$(O) \
    $(OUTDIR_SLASH)LLVMObjectArray.$(O) \
    $(OUTDIR_SLASH)LLVMOpcode.$(O) \
    $(OUTDIR_SLASH)LLVMRealPredicate.$(O) \
    $(OUTDIR_SLASH)LLVMThreadLocalMode.$(O) \
    $(OUTDIR_SLASH)LLVMTypeKind.$(O) \
    $(OUTDIR_SLASH)LLVMVerifierFailureAction.$(O) \
    $(OUTDIR_SLASH)LLVMVisibility.$(O) \
    $(OUTDIR_SLASH)jv_llvm_s.$(O) \
    $(OUTDIR_SLASH)LLVMObject.$(O) \
    $(OUTDIR_SLASH)LLVMTypeError.$(O) \
    $(OUTDIR_SLASH)LLVMBasicBlock.$(O) \
    $(OUTDIR_SLASH)LLVMContext.$(O) \
    $(OUTDIR_SLASH)LLVMDiagnosticInfo.$(O) \
    $(OUTDIR_SLASH)LLVMDisposableObject.$(O) \
    $(OUTDIR_SLASH)LLVMMetadata.$(O) \
    $(OUTDIR_SLASH)LLVMPassRegistry.$(O) \
    $(OUTDIR_SLASH)LLVMTargetLibraryInfo.$(O) \
    $(OUTDIR_SLASH)LLVMType.$(O) \
    $(OUTDIR_SLASH)LLVMTypeMismatchError.$(O) \
    $(OUTDIR_SLASH)LLVMUse.$(O) \
    $(OUTDIR_SLASH)LLVMValue.$(O) \
    $(OUTDIR_SLASH)LLVMDIBuilder.$(O) \
    $(OUTDIR_SLASH)LLVMExecutionEngine.$(O) \
    $(OUTDIR_SLASH)LLVMFunction.$(O) \
    $(OUTDIR_SLASH)LLVMGenericValue.$(O) \
    $(OUTDIR_SLASH)LLVMIRBuilder.$(O) \
    $(OUTDIR_SLASH)LLVMMCJITMemoryManager.$(O) \
    $(OUTDIR_SLASH)LLVMModule.$(O) \
    $(OUTDIR_SLASH)LLVMModuleProvider.$(O) \
    $(OUTDIR_SLASH)LLVMPassManager.$(O) \
    $(OUTDIR_SLASH)LLVMTargetData.$(O) \
    $(OUTDIR_SLASH)LLVMTypeFunction.$(O) \
    $(OUTDIR_SLASH)LLVMTypeLabel.$(O) \
    $(OUTDIR_SLASH)LLVMTypeMetadata.$(O) \
    $(OUTDIR_SLASH)LLVMTypeScalar.$(O) \
    $(OUTDIR_SLASH)LLVMTypeSequential.$(O) \
    $(OUTDIR_SLASH)LLVMTypeStruct.$(O) \
    $(OUTDIR_SLASH)LLVMTypeVoid.$(O) \
    $(OUTDIR_SLASH)LLVMStXMethod.$(O) \
    $(OUTDIR_SLASH)LLVMTypeArray.$(O) \
    $(OUTDIR_SLASH)LLVMTypeFloatingPoint.$(O) \
    $(OUTDIR_SLASH)LLVMTypeHalt.$(O) \
    $(OUTDIR_SLASH)LLVMTypeInteger.$(O) \
    $(OUTDIR_SLASH)LLVMTypePointer.$(O) \
    $(OUTDIR_SLASH)LLVMTypeVector.$(O) \
    $(OUTDIR_SLASH)LLVMTypeX86_MMX.$(O) \
    $(OUTDIR_SLASH)LLVMTypeDouble.$(O) \
    $(OUTDIR_SLASH)LLVMTypeFP128.$(O) \
    $(OUTDIR_SLASH)LLVMTypeFloat.$(O) \
    $(OUTDIR_SLASH)LLVMTypePPC_FP128.$(O) \
    $(OUTDIR_SLASH)LLVMTypeX86_FP80.$(O) \
    $(OUTDIR_SLASH)extensions.$(O) \