Make.spec
author Jan Vrany <jan.vrany@fit.cvut.cz>
Fri, 17 Jul 2015 12:40:26 +0100
changeset 8 890eb7591eca
parent 4 d33c64726c86
child 12 f98e97fd02ef
permissions -rw-r--r--
Added class LLVMExamples ...with low-level examples how to use LLVM

# $Header$
#
# DO NOT EDIT
# automagically generated from the projectDefinition: jv_libllvms.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=jv
MODULE_DIR=libllvms
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -headerDir=. : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optspace3


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#  -warnUnused      : no warnings about unused variables
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard

COMMON_CLASSES= \
	LLVM \
	LLVMAtomicOrdering \
	LLVMAtomicRMWBinOp \
	LLVMAttribute \
	LLVMByteOrdering \
	LLVMCallConv \
	LLVMDLLStorageClass \
	LLVMDiagnosticSeverity \
	LLVMExamples \
	LLVMIntPredicate \
	LLVMLandingPadClauseTy \
	LLVMLinkage \
	LLVMObject \
	LLVMObjectArray \
	LLVMOpcode \
	LLVMRealPredicate \
	LLVMThreadLocalMode \
	LLVMTypeKind \
	LLVMVerifierFailureAction \
	LLVMVisibility \
	jv_libllvms \
	LLVMBasicBlock \
	LLVMContext \
	LLVMDiagnosticInfo \
	LLVMDisposableObject \
	LLVMMCJITCompilerOptions \
	LLVMPassRegistry \
	LLVMTargetLibraryInfo \
	LLVMType \
	LLVMUse \
	LLVMValue \
	LLVMBuilder \
	LLVMExecutionEngine \
	LLVMFunction \
	LLVMGenericValue \
	LLVMMCJITMemoryManager \
	LLVMModule \
	LLVMModuleProvider \
	LLVMPassManager \
	LLVMTargetData \
	LLVMStXMethod \




COMMON_OBJS= \
    $(OUTDIR_SLASH)LLVM.$(O) \
    $(OUTDIR_SLASH)LLVMAtomicOrdering.$(O) \
    $(OUTDIR_SLASH)LLVMAtomicRMWBinOp.$(O) \
    $(OUTDIR_SLASH)LLVMAttribute.$(O) \
    $(OUTDIR_SLASH)LLVMByteOrdering.$(O) \
    $(OUTDIR_SLASH)LLVMCallConv.$(O) \
    $(OUTDIR_SLASH)LLVMDLLStorageClass.$(O) \
    $(OUTDIR_SLASH)LLVMDiagnosticSeverity.$(O) \
    $(OUTDIR_SLASH)LLVMExamples.$(O) \
    $(OUTDIR_SLASH)LLVMIntPredicate.$(O) \
    $(OUTDIR_SLASH)LLVMLandingPadClauseTy.$(O) \
    $(OUTDIR_SLASH)LLVMLinkage.$(O) \
    $(OUTDIR_SLASH)LLVMObject.$(O) \
    $(OUTDIR_SLASH)LLVMObjectArray.$(O) \
    $(OUTDIR_SLASH)LLVMOpcode.$(O) \
    $(OUTDIR_SLASH)LLVMRealPredicate.$(O) \
    $(OUTDIR_SLASH)LLVMThreadLocalMode.$(O) \
    $(OUTDIR_SLASH)LLVMTypeKind.$(O) \
    $(OUTDIR_SLASH)LLVMVerifierFailureAction.$(O) \
    $(OUTDIR_SLASH)LLVMVisibility.$(O) \
    $(OUTDIR_SLASH)jv_libllvms.$(O) \
    $(OUTDIR_SLASH)LLVMBasicBlock.$(O) \
    $(OUTDIR_SLASH)LLVMContext.$(O) \
    $(OUTDIR_SLASH)LLVMDiagnosticInfo.$(O) \
    $(OUTDIR_SLASH)LLVMDisposableObject.$(O) \
    $(OUTDIR_SLASH)LLVMMCJITCompilerOptions.$(O) \
    $(OUTDIR_SLASH)LLVMPassRegistry.$(O) \
    $(OUTDIR_SLASH)LLVMTargetLibraryInfo.$(O) \
    $(OUTDIR_SLASH)LLVMType.$(O) \
    $(OUTDIR_SLASH)LLVMUse.$(O) \
    $(OUTDIR_SLASH)LLVMValue.$(O) \
    $(OUTDIR_SLASH)LLVMBuilder.$(O) \
    $(OUTDIR_SLASH)LLVMExecutionEngine.$(O) \
    $(OUTDIR_SLASH)LLVMFunction.$(O) \
    $(OUTDIR_SLASH)LLVMGenericValue.$(O) \
    $(OUTDIR_SLASH)LLVMMCJITMemoryManager.$(O) \
    $(OUTDIR_SLASH)LLVMModule.$(O) \
    $(OUTDIR_SLASH)LLVMModuleProvider.$(O) \
    $(OUTDIR_SLASH)LLVMPassManager.$(O) \
    $(OUTDIR_SLASH)LLVMTargetData.$(O) \
    $(OUTDIR_SLASH)LLVMStXMethod.$(O) \
    $(OUTDIR_SLASH)extensions.$(O) \