Make.spec
changeset 40 d766d4c854a2
parent 37 f417fe8685c5
child 46 6b857f3cec8c
equal deleted inserted replaced
39:d2afdbaaabdb 40:d766d4c854a2
    20 # Argument(s) to the stc compiler (stc --usage).
    20 # Argument(s) to the stc compiler (stc --usage).
    21 #  -headerDir=. : create header files locally
    21 #  -headerDir=. : create header files locally
    22 #                (if removed, they will be created as common
    22 #                (if removed, they will be created as common
    23 #  -Pxxx       : defines the package
    23 #  -Pxxx       : defines the package
    24 #  -Zxxx       : a prefix for variables within the classLib
    24 #  -Zxxx       : a prefix for variables within the classLib
    25 #  -Dxxx       : defines passed to to CC for inline C-code
    25 #  -Dxxx       : defines passed to CC for inline C-code
    26 #  -Ixxx       : include path passed to CC for inline C-code
    26 #  -Ixxx       : include path passed to CC for inline C-code
    27 #  +optspace   : optimized for space
    27 #  +optspace   : optimized for space
    28 #  +optspace2  : optimized more for space
    28 #  +optspace2  : optimized more for space
    29 #  +optspace3  : optimized even more for space
    29 #  +optspace3  : optimized even more for space
    30 #  +optinline  : generate inline code for some ST constructs
    30 #  +optinline  : generate inline code for some ST constructs
    50 # STCWARNINGS=-warnEOLComments
    50 # STCWARNINGS=-warnEOLComments
    51 STCWARNINGS=-warnNonStandard
    51 STCWARNINGS=-warnNonStandard
    52 
    52 
    53 COMMON_CLASSES= \
    53 COMMON_CLASSES= \
    54 	VDBAbstractApplication \
    54 	VDBAbstractApplication \
    55 	VDBDebuggerConsoleView \
       
    56 	VDBIconLibrary \
    55 	VDBIconLibrary \
    57 	VDBModelPresenter \
    56 	VDBModelPresenter \
    58 	jv_vdb \
    57 	jv_vdb \
       
    58 	VDBAbstractConsoleApplication \
    59 	VDBAbstractContainer \
    59 	VDBAbstractContainer \
    60 	VDBAbstractListApplication \
    60 	VDBAbstractListApplication \
    61 	VDBDebuggerApplication \
    61 	VDBDebuggerApplication \
    62 	VDBDebuggerConsoleApplication \
       
    63 	VDBEventLogApplication \
    62 	VDBEventLogApplication \
    64 	VDBFramePresenter \
    63 	VDBFramePresenter \
    65 	VDBInferiorConsoleApplication \
       
    66 	VDBSourceApplication \
    64 	VDBSourceApplication \
    67 	VDBThreadGroupPresenter \
    65 	VDBThreadGroupPresenter \
    68 	VDBThreadPresenter \
    66 	VDBThreadPresenter \
    69 	VDBVariablePresenter \
    67 	VDBVariablePresenter \
    70 	VDBAbstractTreeApplication \
    68 	VDBAbstractTreeApplication \
       
    69 	VDBDebuggerConsoleApplication \
       
    70 	VDBInferiorConsoleApplication \
    71 	VDBTabbingContainer \
    71 	VDBTabbingContainer \
    72 	VDBFrameApplication \
    72 	VDBFrameApplication \
    73 	VDBStackApplication \
    73 	VDBStackApplication \
    74 
    74 
    75 
    75 
    76 
    76 
    77 
    77 
    78 COMMON_OBJS= \
    78 COMMON_OBJS= \
    79     $(OUTDIR_SLASH)VDBAbstractApplication.$(O) \
    79     $(OUTDIR)VDBAbstractApplication.$(O) \
    80     $(OUTDIR_SLASH)VDBDebuggerConsoleView.$(O) \
    80     $(OUTDIR)VDBIconLibrary.$(O) \
    81     $(OUTDIR_SLASH)VDBIconLibrary.$(O) \
    81     $(OUTDIR)VDBModelPresenter.$(O) \
    82     $(OUTDIR_SLASH)VDBModelPresenter.$(O) \
    82     $(OUTDIR)jv_vdb.$(O) \
    83     $(OUTDIR_SLASH)jv_vdb.$(O) \
    83     $(OUTDIR)VDBAbstractConsoleApplication.$(O) \
    84     $(OUTDIR_SLASH)VDBAbstractContainer.$(O) \
    84     $(OUTDIR)VDBAbstractContainer.$(O) \
    85     $(OUTDIR_SLASH)VDBAbstractListApplication.$(O) \
    85     $(OUTDIR)VDBAbstractListApplication.$(O) \
    86     $(OUTDIR_SLASH)VDBDebuggerApplication.$(O) \
    86     $(OUTDIR)VDBDebuggerApplication.$(O) \
    87     $(OUTDIR_SLASH)VDBDebuggerConsoleApplication.$(O) \
    87     $(OUTDIR)VDBEventLogApplication.$(O) \
    88     $(OUTDIR_SLASH)VDBEventLogApplication.$(O) \
    88     $(OUTDIR)VDBFramePresenter.$(O) \
    89     $(OUTDIR_SLASH)VDBFramePresenter.$(O) \
    89     $(OUTDIR)VDBSourceApplication.$(O) \
    90     $(OUTDIR_SLASH)VDBInferiorConsoleApplication.$(O) \
    90     $(OUTDIR)VDBThreadGroupPresenter.$(O) \
    91     $(OUTDIR_SLASH)VDBSourceApplication.$(O) \
    91     $(OUTDIR)VDBThreadPresenter.$(O) \
    92     $(OUTDIR_SLASH)VDBThreadGroupPresenter.$(O) \
    92     $(OUTDIR)VDBVariablePresenter.$(O) \
    93     $(OUTDIR_SLASH)VDBThreadPresenter.$(O) \
    93     $(OUTDIR)VDBAbstractTreeApplication.$(O) \
    94     $(OUTDIR_SLASH)VDBVariablePresenter.$(O) \
    94     $(OUTDIR)VDBDebuggerConsoleApplication.$(O) \
    95     $(OUTDIR_SLASH)VDBAbstractTreeApplication.$(O) \
    95     $(OUTDIR)VDBInferiorConsoleApplication.$(O) \
    96     $(OUTDIR_SLASH)VDBTabbingContainer.$(O) \
    96     $(OUTDIR)VDBTabbingContainer.$(O) \
    97     $(OUTDIR_SLASH)VDBFrameApplication.$(O) \
    97     $(OUTDIR)VDBFrameApplication.$(O) \
    98     $(OUTDIR_SLASH)VDBStackApplication.$(O) \
    98     $(OUTDIR)VDBStackApplication.$(O) \
    99 
    99 
   100 
   100 
   101 
   101