gui/Make.spec
changeset 349 060302f619fa
equal deleted inserted replaced
348:9a04cc03d392 349:060302f619fa
       
     1 # $Header: /cvs/stx/stx/goodies/petitparser/gui/Make.spec,v 1.1 2014-03-04 21:20:14 cg Exp $
       
     2 #
       
     3 # DO NOT EDIT
       
     4 # automagically generated from the projectDefinition: stx_goodies_petitparser_gui.
       
     5 #
       
     6 # Warning: once you modify this file, do not rerun
       
     7 # stmkmp or projectDefinition-build again - otherwise, your changes are lost.
       
     8 #
       
     9 # This file contains specifications which are common to all platforms.
       
    10 #
       
    11 
       
    12 # Do NOT CHANGE THESE DEFINITIONS
       
    13 # (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
       
    14 #  to find the source code of a class and to find the library for a package)
       
    15 MODULE=stx
       
    16 MODULE_DIR=goodies/petitparser/gui
       
    17 PACKAGE=$(MODULE):$(MODULE_DIR)
       
    18 
       
    19 
       
    20 # Argument(s) to the stc compiler (stc --usage).
       
    21 #  -headerDir=. : create header files locally
       
    22 #                (if removed, they will be created as common
       
    23 #  -Pxxx       : defines the package
       
    24 #  -Zxxx       : a prefix for variables within the classLib
       
    25 #  -Dxxx       : defines passed to to CC for inline C-code
       
    26 #  -Ixxx       : include path passed to CC for inline C-code
       
    27 #  +optspace   : optimized for space
       
    28 #  +optspace2  : optimized more for space
       
    29 #  +optspace3  : optimized even more for space
       
    30 #  +optinline  : generate inline code for some ST constructs
       
    31 #  +inlineNew  : additionally inline new
       
    32 #  +inlineMath : additionally inline some floatPnt math stuff
       
    33 #
       
    34 # ********** OPTIONAL: MODIFY the next line(s) ***
       
    35 # STCLOCALOPTIMIZATIONS=+optinline +inlineNew
       
    36 # STCLOCALOPTIMIZATIONS=+optspace3
       
    37 STCLOCALOPTIMIZATIONS=+optspace3
       
    38 
       
    39 
       
    40 # Argument(s) to the stc compiler (stc --usage).
       
    41 #  -warn            : no warnings
       
    42 #  -warnNonStandard : no warnings about ST/X extensions
       
    43 #  -warnEOLComments : no warnings about EOL comment extension
       
    44 #  -warnPrivacy     : no warnings about privateClass extension
       
    45 #
       
    46 # ********** OPTIONAL: MODIFY the next line(s) ***
       
    47 # STCWARNINGS=-warn
       
    48 # STCWARNINGS=-warnNonStandard
       
    49 # STCWARNINGS=-warnEOLComments
       
    50 STCWARNINGS=-warnNonStandard
       
    51 
       
    52 COMMON_CLASSES= \
       
    53 	GLMCompositePresentation \
       
    54 	PPAddParserRefactoring \
       
    55 	PPBrowserStream \
       
    56 	PPDefineProdcutionRefactoring \
       
    57 	PPDrabBrowser \
       
    58 	PPExtractProdcutionRefactoring \
       
    59 	PPParserDebuggerResult \
       
    60 	PPRefactoringUtils \
       
    61 	PPRemoveParserRefactoring \
       
    62 	PPRenameProdcutionRefactoring \
       
    63 	PPTextHighlighter \
       
    64 	RBRefactoring \
       
    65 	RBRemoveClassRefactoring \
       
    66 	stx_goodies_petitparser_gui \
       
    67 	PPBrowser \
       
    68 	PPParserBrowser \
       
    69 	PPParserInspector \
       
    70 	PPRemoveProdcutionRefactoring \
       
    71 
       
    72 
       
    73 
       
    74 
       
    75 COMMON_OBJS= \
       
    76     $(OUTDIR_SLASH)GLMCompositePresentation.$(O) \
       
    77     $(OUTDIR_SLASH)PPAddParserRefactoring.$(O) \
       
    78     $(OUTDIR_SLASH)PPBrowserStream.$(O) \
       
    79     $(OUTDIR_SLASH)PPDefineProdcutionRefactoring.$(O) \
       
    80     $(OUTDIR_SLASH)PPDrabBrowser.$(O) \
       
    81     $(OUTDIR_SLASH)PPExtractProdcutionRefactoring.$(O) \
       
    82     $(OUTDIR_SLASH)PPParserDebuggerResult.$(O) \
       
    83     $(OUTDIR_SLASH)PPRefactoringUtils.$(O) \
       
    84     $(OUTDIR_SLASH)PPRemoveParserRefactoring.$(O) \
       
    85     $(OUTDIR_SLASH)PPRenameProdcutionRefactoring.$(O) \
       
    86     $(OUTDIR_SLASH)PPTextHighlighter.$(O) \
       
    87     $(OUTDIR_SLASH)RBRefactoring.$(O) \
       
    88     $(OUTDIR_SLASH)RBRemoveClassRefactoring.$(O) \
       
    89     $(OUTDIR_SLASH)stx_goodies_petitparser_gui.$(O) \
       
    90     $(OUTDIR_SLASH)PPBrowser.$(O) \
       
    91     $(OUTDIR_SLASH)PPParserBrowser.$(O) \
       
    92     $(OUTDIR_SLASH)PPParserInspector.$(O) \
       
    93     $(OUTDIR_SLASH)PPRemoveProdcutionRefactoring.$(O) \
       
    94     $(OUTDIR_SLASH)extensions.$(O) \
       
    95 
       
    96 
       
    97